summaryrefslogtreecommitdiff
path: root/sci-biology/bedtools/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sci-biology/bedtools/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sci-biology/bedtools/files')
-rw-r--r--sci-biology/bedtools/files/bedtools-2.29.2-buildsystem.patch82
-rw-r--r--sci-biology/bedtools/files/bedtools-2.29.2-python.patch41
-rw-r--r--sci-biology/bedtools/files/bedtools-2.29.2-samtools-1.10.patch13
3 files changed, 136 insertions, 0 deletions
diff --git a/sci-biology/bedtools/files/bedtools-2.29.2-buildsystem.patch b/sci-biology/bedtools/files/bedtools-2.29.2-buildsystem.patch
new file mode 100644
index 000000000000..573e88993bc9
--- /dev/null
+++ b/sci-biology/bedtools/files/bedtools-2.29.2-buildsystem.patch
@@ -0,0 +1,82 @@
+--- a/Makefile
++++ b/Makefile
+@@ -4,44 +4,29 @@
+ # (c) 2009 Aaron Quinlan
+ # ==========================
+
+-SHELL := /bin/bash -e
++SHELL := bash -e
+
+ VERSION_FILE=./src/utils/version/version_git.h
+ RELEASED_VERSION_FILE=./src/utils/version/version_release.txt
+
+
+ # define our object and binary directories
+-ifeq ($(VERBOSE),1)
+ CCPREFIX =
+-else
+-CCPREFIX = @
+-endif
+
+ OBJ_DIR = obj
+ BIN_DIR = bin
+ SRC_DIR = src
+
+-CXX = g++
+-
+-ifeq ($(DEBUG),1)
+-BT_CPPFLAGS = -DDEBUG -D_DEBUG -D_FILE_OFFSET_BITS=64 -DWITH_HTS_CB_API $(INCLUDES)
+-BT_CXXFLAGS = -Wconversion -Wall -Wextra -g -O0
+-else
+ BT_CPPFLAGS = -D_FILE_OFFSET_BITS=64 -DWITH_HTS_CB_API $(INCLUDES)
+-BT_CXXFLAGS = -g -Wall -O2
+-endif
++BT_CXXFLAGS = -Wall
+
+ # If the user has specified to do so, tell the compile to use rand() (instead of mt19937).
+-ifeq ($(USE_RAND),1)
+-BT_CXXFLAGS += -DUSE_RAND
+-else
+ BT_CXXFLAGS += -std=c++11
+-endif
+
+ BT_LDFLAGS =
+ BT_LIBS = -lz -lm -lbz2 -llzma -lpthread
+
+-prefix ?= /usr/local
++prefix = $(EPREFIX)/usr
+
+ SUBDIRS = $(SRC_DIR)/annotateBed \
+ $(SRC_DIR)/bamToBed \
+@@ -204,7 +189,7 @@
+
+ # make the "obj/" and "bin/" directories, if they don't exist
+ $(OBJ_DIR) $(BIN_DIR):
+- @mkdir -p $@
++ mkdir -p $@
+
+
+ # Usually HTSlib's configure script has not been used (detected via config.mk
+--- a/src/utils/htslib/Makefile
++++ b/src/utils/htslib/Makefile
+@@ -22,20 +22,13 @@
+ # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ # DEALINGS IN THE SOFTWARE.
+
+-CC = gcc
+-AR = ar
+-RANLIB = ranlib
+-
+ # Default libraries to link if configure is not used
+ htslib_default_libs = -lz -lm -lbz2 -llzma
+
+-CPPFLAGS =
+ # TODO: probably update cram code to make it compile cleanly with -Wc++-compat
+ # For testing strict C99 support add -std=c99 -D_XOPEN_SOURCE=600
+ #CFLAGS = -g -Wall -O2 -pedantic -std=c99 -D_XOPEN_SOURCE=600 -D__FUNCTION__=__func__
+-CFLAGS = -g -Wall -O2
+ EXTRA_CFLAGS_PIC = -fpic
+-LDFLAGS =
+ LIBS = $(htslib_default_libs)
+
+ prefix = /usr/local
diff --git a/sci-biology/bedtools/files/bedtools-2.29.2-python.patch b/sci-biology/bedtools/files/bedtools-2.29.2-python.patch
new file mode 100644
index 000000000000..9576a78bd1dd
--- /dev/null
+++ b/sci-biology/bedtools/files/bedtools-2.29.2-python.patch
@@ -0,0 +1,41 @@
+--- a/Makefile
++++ b/Makefile
+@@ -183,7 +168,7 @@
+
+ $(BIN_DIR)/intersectBed: | $(BIN_DIR)
+ @echo "- Creating executables for old CLI."
+- @python scripts/makeBashScripts.py
++ $(EPYTHON) scripts/makeBashScripts.py
+ @chmod +x bin/*
+ @echo "done."
+
+--- a/src/utils/BamTools/Makefile.frag
++++ b/src/utils/BamTools/Makefile.frag
+@@ -1,4 +1,4 @@
+ src/utils/BamTools/include/BamAlignment.mapping.hpp: src/utils/BamTools/mapping/BamAlignment.py src/utils/BamTools/mapping/BamAlignment.map
+
+ src/utils/BamTools/include/%.mapping.hpp: src/utils/BamTools/mapping/%.py src/utils/BamTools/mapping/%.map
+- python $^ > $@
++ $(EPYTHON) $^ > $@
+--- a/test/bigchroms/test-bigchroms.sh
++++ b/test/bigchroms/test-bigchroms.sh
+@@ -28,7 +28,7 @@
+ rm obs
+
+ if [[ "$BT_NO_BIG_FILES" != "" ]]; then
+-python make-big-chrom.py
++${EPYTHON} make-big-chrom.py
+
+ echo -e " bigchroms.t03...big get fasta \c"
+ $BT getfasta -fi bigx.fasta -bed bigx.bed | tail -1 > obs
+--- a/test/fisher/cmp.sh
++++ b/test/fisher/cmp.sh
+@@ -3,7 +3,7 @@
+ echo "fisher,shuffled"
+
+ for i in $(seq 1000); do
+- fisher=$(python ./sim.py | tail -1 | cut -f 2)
++ fisher=$(${EPYTHON} ./sim.py | tail -1 | cut -f 2)
+ shuffle=$(bash shuf.sh)
+ echo "$fisher,$shuffle"
+ done
diff --git a/sci-biology/bedtools/files/bedtools-2.29.2-samtools-1.10.patch b/sci-biology/bedtools/files/bedtools-2.29.2-samtools-1.10.patch
new file mode 100644
index 000000000000..7cc0e23de2d4
--- /dev/null
+++ b/sci-biology/bedtools/files/bedtools-2.29.2-samtools-1.10.patch
@@ -0,0 +1,13 @@
+--- a/test/intersect/new_test-intersect.sh
++++ b/test/intersect/new_test-intersect.sh
+@@ -975,8 +975,8 @@
+ # Test intersect preserve the text header in bam
+ ############################################################
+ echo -e " intersect.new.t78...\c"
+-echo -e "@HD VN:1.5 SO:coordinate" > exp
+-echo "@HD VN:1.5 SO:coordinate" | samtools view -b | $BT intersect -a /dev/stdin -b b.bed | samtools view -H >obs
++echo -e "@HD VN:1.5 SO:coordinate" > exp
++echo "@HD VN:1.5 SO:coordinate" | samtools view --no-PG -b | $BT intersect -a /dev/stdin -b b.bed | samtools view --no-PG -H >obs
+ check exp obs
+ rm exp obs
+ [[ $FAILURES -eq 0 ]] || exit 1;