summaryrefslogtreecommitdiff
path: root/sci-biology/bcftools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/bcftools
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/bcftools')
-rw-r--r--sci-biology/bcftools/Manifest5
-rw-r--r--sci-biology/bcftools/bcftools-1.5.ebuild45
-rw-r--r--sci-biology/bcftools/files/bcftools-1.5-buildsystem.patch10
-rw-r--r--sci-biology/bcftools/files/bcftools-1.5-fix-shebangs.patch24
-rw-r--r--sci-biology/bcftools/metadata.xml15
5 files changed, 99 insertions, 0 deletions
diff --git a/sci-biology/bcftools/Manifest b/sci-biology/bcftools/Manifest
new file mode 100644
index 000000000000..9f3fa1a6c35f
--- /dev/null
+++ b/sci-biology/bcftools/Manifest
@@ -0,0 +1,5 @@
+AUX bcftools-1.5-buildsystem.patch 376 SHA256 fe15af0cd646dbb51041f78d00287696ec70d19b592f8f1f9967b373a81ffbca SHA512 c8ede2be5205ab287843662e7b97ecae8d4fc7d2aaf09e0b9fa67f5a3168149b15457e73c2c9d8b74fcfada08ec5c1bbe61013a2ef434ee50acf56eccabf6723 WHIRLPOOL 590ff61577c5b55c553d37dbe7a421fa71c4f4c5648df8aff45d68027ee419574400d7660aee29f5f586fe73f3fad2bfe7893c3954c242a02d8d0c2faf00bc8f
+AUX bcftools-1.5-fix-shebangs.patch 594 SHA256 a2360809840fe2683c0c85edae8977f62eaa923b77c66921c69031ab35e8b7a7 SHA512 e00cc0de35ad5866f7321408a7995f054f80e37e642b6c3097c5e786635dc61baefa7ea8847f2222d32196825e3e44209d63fdfd219c54b09421a4bb310067f5 WHIRLPOOL 1589c582746650f357a3c28428e3900a2b6e56c3ea7bc538f4dc141cfb5112b467020e3da52886e4ad54929a02e72bd3411185ff623860062cf9a17309e42e1c
+DIST bcftools-1.5.tar.bz2 2975685 SHA256 9ff75a680891467776d7064f41deb6be7a595030ba807494727cd5bee7842301 SHA512 66b8bc61b9fbb381679a6781f77a18f66e8105567992da011413bc573d99b619558a1cf58e9e1373ae347a8b81638dd91977802a07a4578ddc9c61fb53403233 WHIRLPOOL 86b827d91351d8adc026a1d851bb708e35febcc36a947532662857787ec1da6eea2c88a684b15164638b7f9235f6a6f92f4d10618e1719aa891c44c69aaece77
+EBUILD bcftools-1.5.ebuild 868 SHA256 0fe3b3b2d2fa16dd56ecb5bc23f10726795ceb1b94feebd05bf596f60610bfef SHA512 e0aacba5fc54cbf7a8d64db84e52f28baf8df36fa01c63fc167998c6ec5ef65a040c0725f445970f32888ae947b89d50d92dc2fc704fdf63a8a900762ec367e6 WHIRLPOOL fee65a5eddf312b477af061eb12556b45e68e62b5e4aeeadfbb3bc8d2da5e06f2e918f4bba370454f696bf182b39c8784060bfcb6a499f8bf09d3d02e9e8e2ed
+MISC metadata.xml 461 SHA256 3e79956fe4c68d09a8a6983aa31ef61f484856b31671d9f99a1777a20f20bc6e SHA512 7aeb561d33cc1f47dd319d58b5fc5914aa5dc900a6cf0b6042556417ece3a31b809ad9ddde645f90725f44bb8ad82bf9beb2e279095df86a2d73ad0a4305b4fc WHIRLPOOL ecd91f17dae9d1c9a6262ae2ee4ef44b3635b20e26ead9a533566c96d74665df4a1e792e26e5bf69d704dc40a8e415c82f227511735d604346efe7ced9ee6baa
diff --git a/sci-biology/bcftools/bcftools-1.5.ebuild b/sci-biology/bcftools/bcftools-1.5.ebuild
new file mode 100644
index 000000000000..9b5df1130999
--- /dev/null
+++ b/sci-biology/bcftools/bcftools-1.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Utilities for variant calling and manipulating VCF and BCF files"
+HOMEPAGE="http://www.htslib.org"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lang/perl
+ =sci-libs/htslib-${PV}*:=
+ sys-libs/zlib
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5-buildsystem.patch
+ "${FILESDIR}"/${PN}-1.5-fix-shebangs.patch
+)
+
+src_prepare() {
+ default
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --disable-bcftools-plugins \
+ --disable-libgsl \
+ --disable-configure-htslib \
+ --with-htslib=system
+}
diff --git a/sci-biology/bcftools/files/bcftools-1.5-buildsystem.patch b/sci-biology/bcftools/files/bcftools-1.5-buildsystem.patch
new file mode 100644
index 000000000000..304fc03e7441
--- /dev/null
+++ b/sci-biology/bcftools/files/bcftools-1.5-buildsystem.patch
@@ -0,0 +1,10 @@
+--- a/Makefile
++++ b/Makefile
+@@ -275,7 +275,6 @@
+ $(INSTALL_PROGRAM) $(PROGRAMS) $(DESTDIR)$(bindir)
+ $(INSTALL_SCRIPT) $(MISC_SCRIPTS) $(DESTDIR)$(misc_bindir)
+ $(INSTALL_MAN) doc/bcftools.1 $(DESTDIR)$(man1dir)
+- $(INSTALL_PROGRAM) plugins/*.so $(DESTDIR)$(plugindir)
+
+ clean: testclean clean-plugins
+ -rm -f gmon.out *.o *~ $(PROG) version.h plugins/*.so plugins/*.P
diff --git a/sci-biology/bcftools/files/bcftools-1.5-fix-shebangs.patch b/sci-biology/bcftools/files/bcftools-1.5-fix-shebangs.patch
new file mode 100644
index 000000000000..c6cfc8b991d3
--- /dev/null
+++ b/sci-biology/bcftools/files/bcftools-1.5-fix-shebangs.patch
@@ -0,0 +1,24 @@
+--- a/misc/guess-ploidy.py
++++ b/misc/guess-ploidy.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2.7
+ #
+ # Plot the output of "bcftools +guess-ploidy -v"
+ #
+--- a/misc/plot-roh.py
++++ b/misc/plot-roh.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python2.7
+
+ import glob, gzip, csv, sys, os, copy, re
+ csv.register_dialect('tab', delimiter='\t', quoting=csv.QUOTE_NONE)
+--- a/misc/vcfutils.pl
++++ b/misc/vcfutils.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl -w
++#!/usr/bin/env perl
+ #
+ # Copyright (C) 2010 Broad Institute.
+ # Copyright (C) 2011, 2014 Genome Research Ltd.
diff --git a/sci-biology/bcftools/metadata.xml b/sci-biology/bcftools/metadata.xml
new file mode 100644
index 000000000000..4fd13be2f922
--- /dev/null
+++ b/sci-biology/bcftools/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">samtools/bcftools</remote-id>
+ </upstream>
+</pkgmetadata>