summaryrefslogtreecommitdiff
path: root/sci-biology/aaindex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/aaindex
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/aaindex')
-rw-r--r--sci-biology/aaindex/Manifest5
-rw-r--r--sci-biology/aaindex/aaindex-9.1-r1.ebuild42
-rw-r--r--sci-biology/aaindex/metadata.xml25
3 files changed, 72 insertions, 0 deletions
diff --git a/sci-biology/aaindex/Manifest b/sci-biology/aaindex/Manifest
new file mode 100644
index 000000000000..78f05182f5ed
--- /dev/null
+++ b/sci-biology/aaindex/Manifest
@@ -0,0 +1,5 @@
+DIST aaindex-9.1.tar.bz2 133780 SHA256 ae2e5aec2fc47835f26c8d8b5776966464bc08a5fca422c130d8312880382caa SHA512 d35760712a3f9d8c0d64e32ff450802eab20294851e569cbb9614610704f687c9ec56c440e6009b5c75c45ae12bd7968e28afcc414309318e94b092507df16d8 WHIRLPOOL c0bd3b3aa6ee730b5663f5b5c2be31925431d9f0a42488f2d2162e0d887f5ccc449c356f1c814854a0db2d48907763d586926ba14bbf3c277a006bb7f6b2fe4e
+EBUILD aaindex-9.1-r1.ebuild 967 SHA256 1f33080cbbd5ba79a0ac9fa522b06872c9c0fc901453a5aa91c0f449b49836d7 SHA512 97b5c262baaa4bec1f0d32d3f343252862f5f2510cf6c4972e63d500fcc6169a8eb8e62d1f0e64f0f4ff5c2b90cbfeb24abbbc676d1c05701f092e520d7ac490 WHIRLPOOL 4f8153b4f6cf870c0928abc1efb0343829b3a5ac83dc3899e2cae41f69a655fbedbf8e323c53a0181ed35e16b5f42a3844d32f0b008c74c4a69833bda37621ab
+MISC ChangeLog 2426 SHA256 1c2d7d20816e49468ac55e807a26b47aec49fc8a2219ddb769355c3fb09c60d0 SHA512 202c6d23baa93d0b18c915b924055015f7a2cd2dd803bb74faa17bac2d51d16f5b7e6c7fc7d421c49a49f0c1474b53f0cedf1f2eabe18b70847a94e085ad25e2 WHIRLPOOL 55c83b6ddb125ce870cf9f6b6fb93794cd34887afc1d4ba3719de3d99ab9d3eb11fd13806599b0dded8e13364f6c244bf7edac4983fc1874591c1fb58adbc6ce
+MISC ChangeLog-2015 3444 SHA256 d61bd3519476b3a4f0868d426c463cd28c7a3940fa9b1ae53c3a2bae383c07db SHA512 bde79cf2580cfedd9db9cdd6ab88c5c2984c92987a07e6c37b04d0d93534462fc4816486b9abfc8ff09550c4e5b6c08b6f7a4b273a73f360011e53900a9aac90 WHIRLPOOL 45b527594321c95635d859a368d86a428ce29c5f2c9b6a315973f711a79b4199c8a1253a5722f3b56423d64420eeb30b8f882bbbacb614fa7a0f6e6e5153095d
+MISC metadata.xml 1317 SHA256 526f2b21a5bfa52c18f4e6c67eba1e23699866d0a9c9ec5ac0cb4723a1432b10 SHA512 34360f262abb6d882e95272da0102519c75fac4a367c1e122cb91f3a81788e0693b33ee84f6a602a2fac965fb22ad2cec20c5f2950d3fa16af80cb18a274119d WHIRLPOOL a3fbc49445969106ae84e931bfe16f7af99e620c026aa2af80881e4b76a3e9c9367919fd974bca8e0ff7c571d36621990f25f517f2cd5bc1945962294d5b9b73
diff --git a/sci-biology/aaindex/aaindex-9.1-r1.ebuild b/sci-biology/aaindex/aaindex-9.1-r1.ebuild
new file mode 100644
index 000000000000..068902e96fae
--- /dev/null
+++ b/sci-biology/aaindex/aaindex-9.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Amino acid indices and similarity matrices"
+HOMEPAGE="http://www.genome.jp/aaindex/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="emboss minimal"
+
+DEPEND="emboss? ( sci-biology/emboss )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if use emboss; then
+ mkdir AAINDEX || die
+ einfo
+ einfo "Indexing AAindex for usage with EMBOSS."
+ EMBOSS_DATA="." aaindexextract -auto -infile ${PN}1 || die "Indexing AAindex failed"
+ einfo
+ fi
+}
+
+src_install() {
+ dodoc ${PN}.doc
+
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins ${PN}{1,2,3}
+ fi
+
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/AAINDEX
+ doins -r AAINDEX/.
+ fi
+}
diff --git a/sci-biology/aaindex/metadata.xml b/sci-biology/aaindex/metadata.xml
new file mode 100644
index 000000000000..ffe91c9020d6
--- /dev/null
+++ b/sci-biology/aaindex/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <longdescription>
+ Amino acid indices and similarity matrices maintained at Kyoto
+ University. An amino acid index is a set of 20 numerical values
+ representing any of the different physicochemical and biological
+ properties of amino acids. The AAindex1 section of the Amino Acid
+ Index Database is a collection of published indices together with the
+ result of cluster analysis using the correlation coefficient as the
+ distance between two indices. This section currently contains 494
+ indices. Another important feature of amino acids that can be
+ represented numerically is the similarity between amino acids. Thus, a
+ similarity matrix, also called a mutation matrix, is a set of 210
+ numerical values, 20 diagonal and 20x19/2 off-diagonal elements, used
+ for sequence alignments and similarity searches. The AAindex2 section
+ of the Amino Acid Index Database is a collection of published amino
+ acid mutation matrices together with the result of cluster analysis.
+ This section currently contains 83 matrices.
+ </longdescription>
+</pkgmetadata>