summaryrefslogtreecommitdiff
path: root/sci-biology/STAR/STAR-2.5.3a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-16 16:56:41 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-16 16:56:41 +0000
commit38f60b3ec9ff175535d9a056a76ae42931e61e21 (patch)
tree320bc3a66bb967560bbfe8c576a6e75333cf83cc /sci-biology/STAR/STAR-2.5.3a.ebuild
parente2d84e38284aeb9d522a7e935554340ddf0e4a6f (diff)
gentoo resync : 16.11.2017
Diffstat (limited to 'sci-biology/STAR/STAR-2.5.3a.ebuild')
-rw-r--r--sci-biology/STAR/STAR-2.5.3a.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-biology/STAR/STAR-2.5.3a.ebuild b/sci-biology/STAR/STAR-2.5.3a.ebuild
new file mode 100644
index 000000000000..73743cbb4e59
--- /dev/null
+++ b/sci-biology/STAR/STAR-2.5.3a.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="STAR aligner: align RNA-seq reads to reference genome uncompressed suffix arrays"
+HOMEPAGE="https://github.com/alexdobin/STAR"
+SRC_URI="https://github.com/alexdobin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="sci-libs/htslib:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.5.3a-fix-build-system.patch )
+DOCS=( README.md CHANGES.md RELEASEnotes.md doc/STARmanual.pdf )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+src_configure() {
+ tc-export CC CXX PKG_CONFIG
+}
+
+src_compile() {
+ emake -C source STAR
+}
+
+src_install() {
+ dobin source/STAR
+ einstalldocs
+}