summaryrefslogtreecommitdiff
path: root/sci-biology/HTSeq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-16 16:56:41 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-16 16:56:41 +0000
commit38f60b3ec9ff175535d9a056a76ae42931e61e21 (patch)
tree320bc3a66bb967560bbfe8c576a6e75333cf83cc /sci-biology/HTSeq
parente2d84e38284aeb9d522a7e935554340ddf0e4a6f (diff)
gentoo resync : 16.11.2017
Diffstat (limited to 'sci-biology/HTSeq')
-rw-r--r--sci-biology/HTSeq/HTSeq-0.9.1.ebuild31
-rw-r--r--sci-biology/HTSeq/HTSeq-9999.ebuild31
-rw-r--r--sci-biology/HTSeq/Manifest4
-rw-r--r--sci-biology/HTSeq/metadata.xml19
4 files changed, 85 insertions, 0 deletions
diff --git a/sci-biology/HTSeq/HTSeq-0.9.1.ebuild b/sci-biology/HTSeq/HTSeq-0.9.1.ebuild
new file mode 100644
index 000000000000..446bbef36efb
--- /dev/null
+++ b/sci-biology/HTSeq/HTSeq-0.9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python support for SAM/BAM/Bowtie/FASTA/Q/GFF/GTF files"
+HOMEPAGE="https://htseq.readthedocs.io/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/simon-anders/htseq.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-biology/pysam[${PYTHON_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ >=dev-lang/swig-3.0.8
+ dev-python/cython[${PYTHON_USEDEP}]"
diff --git a/sci-biology/HTSeq/HTSeq-9999.ebuild b/sci-biology/HTSeq/HTSeq-9999.ebuild
new file mode 100644
index 000000000000..446bbef36efb
--- /dev/null
+++ b/sci-biology/HTSeq/HTSeq-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python support for SAM/BAM/Bowtie/FASTA/Q/GFF/GTF files"
+HOMEPAGE="https://htseq.readthedocs.io/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/simon-anders/htseq.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-biology/pysam[${PYTHON_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ >=dev-lang/swig-3.0.8
+ dev-python/cython[${PYTHON_USEDEP}]"
diff --git a/sci-biology/HTSeq/Manifest b/sci-biology/HTSeq/Manifest
new file mode 100644
index 000000000000..ea6d4df9fe10
--- /dev/null
+++ b/sci-biology/HTSeq/Manifest
@@ -0,0 +1,4 @@
+DIST HTSeq-0.9.1.tar.gz 596941 SHA256 af5bba775e3fb45ed4cde64c691ebef36b0bf7a86efd35c884ad0734c27ad485 SHA512 ec3e1ec9cf66918f2afacf7997ab5da02015896ddd97260f5abec8343a9013cf6e857872be38b2cd3bb5bde655abe602a3c22c32448190f32e1a8f1153a19344 WHIRLPOOL da3f1d867f9cfa05e34321f75fb34ef79e943476ee650d4689e320078821703721168bfdd9e46f10f1319cc1006771cd205a80569549d21719d38aea6b0be3a8
+EBUILD HTSeq-0.9.1.ebuild 715 SHA256 21b215f330c0df909001000b539028aadb79b5a25652d236e11d7f69e4674a1e SHA512 eee6989a6910b4022b94982f1c8f598215431c6e0674609d8f30b992a4b9036fde82156fbec0bb4fad1b6bfbd56aa33dcb05cff136cb90a7f5678f18218f3fd0 WHIRLPOOL 1729d114f931a0617e59f95943175b890e80cbc678fbae57e1903e8ff18bfdd47cc526bbde26594efb3558d20ce7789e8050e9f7c33df89632c553fd65ea1b47
+EBUILD HTSeq-9999.ebuild 715 SHA256 21b215f330c0df909001000b539028aadb79b5a25652d236e11d7f69e4674a1e SHA512 eee6989a6910b4022b94982f1c8f598215431c6e0674609d8f30b992a4b9036fde82156fbec0bb4fad1b6bfbd56aa33dcb05cff136cb90a7f5678f18218f3fd0 WHIRLPOOL 1729d114f931a0617e59f95943175b890e80cbc678fbae57e1903e8ff18bfdd47cc526bbde26594efb3558d20ce7789e8050e9f7c33df89632c553fd65ea1b47
+MISC metadata.xml 564 SHA256 102e5db302a66dded538eafc86b66661637591f72fcda8cffea62b12b5aa031e SHA512 16ec7f26466ba1bb2549ee5a0362a7aebb1b8b48de51bacd37bb67a20ca1ca41b0009ca5eae304c5f29e991a79a2fda7bbc93c7dd7e2c8491a0df69a97d9821f WHIRLPOOL 4824b6a5f524d4783b04a3b9cf8c83752309a1101ce4905cd49db5c474718bd88e04afe065d64d7e9276b795fe1a98c18192719acf85f99b46873134549d4782
diff --git a/sci-biology/HTSeq/metadata.xml b/sci-biology/HTSeq/metadata.xml
new file mode 100644
index 000000000000..e9ba18c35b3c
--- /dev/null
+++ b/sci-biology/HTSeq/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">HTSeq</remote-id>
+ </upstream>
+</pkgmetadata>