summaryrefslogtreecommitdiff
path: root/sci-biology/HTSeq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /sci-biology/HTSeq
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'sci-biology/HTSeq')
-rw-r--r--sci-biology/HTSeq/HTSeq-0.12.4.ebuild33
-rw-r--r--sci-biology/HTSeq/HTSeq-2.0.2.ebuild68
-rw-r--r--sci-biology/HTSeq/HTSeq-9999.ebuild49
-rw-r--r--sci-biology/HTSeq/Manifest6
4 files changed, 113 insertions, 43 deletions
diff --git a/sci-biology/HTSeq/HTSeq-0.12.4.ebuild b/sci-biology/HTSeq/HTSeq-0.12.4.ebuild
deleted file mode 100644
index 548684fd531b..000000000000
--- a/sci-biology/HTSeq/HTSeq-0.12.4.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python support for SAM/BAM/Bowtie/FASTA/Q/GFF/GTF files"
-HOMEPAGE="https://htseq.readthedocs.io/"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/htseq/htseq.git"
-else
- SRC_URI="https://github.com/htseq/htseq/archive/release_${PV}.tar.gz -> ${P}.tar.gz"
-
- S="${WORKDIR}"/htseq-release_${PV}
- KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- sci-biology/pysam[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND="
- >=dev-lang/swig-3.0.8
- dev-python/cython[${PYTHON_USEDEP}]"
diff --git a/sci-biology/HTSeq/HTSeq-2.0.2.ebuild b/sci-biology/HTSeq/HTSeq-2.0.2.ebuild
new file mode 100644
index 000000000000..678968788ff7
--- /dev/null
+++ b/sci-biology/HTSeq/HTSeq-2.0.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python support for SAM/BAM/Bowtie/FASTA/Q/GFF/GTF files"
+HOMEPAGE="https://htseq.readthedocs.io/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/htseq/htseq.git"
+else
+ SRC_URI="https://github.com/htseq/htseq/archive/release_${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+ S="${WORKDIR}"/htseq-release_${PV}
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-biology/pysam[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )"
+BDEPEND="
+ >=dev-lang/swig-3.0.8
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # mask broken asserts in src/step_vector.h:72
+ append-cppflags -DNDEBUG
+
+ distutils-r1_src_configure
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ # Due to the build directories creating a competing
+ # hierarchy, we move to the test/ dir to avoid implicitly
+ # injecting the root HTSeq/ dir into the PYTHONPATH,
+ # which leads the python module lookup astray:
+ # ${PWD}
+ # ├── build
+ # │ ├── lib
+ # │ │ └── HTSeq
+ # │ [...]
+ # ├── HTSeq
+ # └── test
+ cd test/ || die
+ ln -s ../example_data || die
+ epytest
+}
diff --git a/sci-biology/HTSeq/HTSeq-9999.ebuild b/sci-biology/HTSeq/HTSeq-9999.ebuild
index 548684fd531b..678968788ff7 100644
--- a/sci-biology/HTSeq/HTSeq-9999.ebuild
+++ b/sci-biology/HTSeq/HTSeq-9999.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="Python support for SAM/BAM/Bowtie/FASTA/Q/GFF/GTF files"
HOMEPAGE="https://htseq.readthedocs.io/"
@@ -14,7 +15,7 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/htseq/htseq.git"
else
- SRC_URI="https://github.com/htseq/htseq/archive/release_${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/htseq/htseq/archive/release_${PV}.tar.gz -> ${P}.gh.tar.gz"
S="${WORKDIR}"/htseq-release_${PV}
KEYWORDS="~amd64"
@@ -22,12 +23,46 @@ fi
LICENSE="GPL-3+"
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
sci-biology/pysam[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )"
BDEPEND="
>=dev-lang/swig-3.0.8
dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # mask broken asserts in src/step_vector.h:72
+ append-cppflags -DNDEBUG
+
+ distutils-r1_src_configure
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ # Due to the build directories creating a competing
+ # hierarchy, we move to the test/ dir to avoid implicitly
+ # injecting the root HTSeq/ dir into the PYTHONPATH,
+ # which leads the python module lookup astray:
+ # ${PWD}
+ # ├── build
+ # │ ├── lib
+ # │ │ └── HTSeq
+ # │ [...]
+ # ├── HTSeq
+ # └── test
+ cd test/ || die
+ ln -s ../example_data || die
+ epytest
+}
diff --git a/sci-biology/HTSeq/Manifest b/sci-biology/HTSeq/Manifest
index a6845ab37446..5e3f78918536 100644
--- a/sci-biology/HTSeq/Manifest
+++ b/sci-biology/HTSeq/Manifest
@@ -1,4 +1,4 @@
-DIST HTSeq-0.12.4.tar.gz 36187218 BLAKE2B 27be4e8783f9e32c10e23ae812069b489eb11dfa4058db43b5db4b8089792351901255103e4d4de1bcf866da3acd13e742adf8d35a9b70305aa156c70dde0837 SHA512 ec4a1a7e9177f103465840ffa9f936a5e887ffd17760b99d4cbdfd5a88e2ab44275fadfcbee153aadc6e828de7be205ed7a07f3a0548457b7c66826341c3ca64
-EBUILD HTSeq-0.12.4.ebuild 773 BLAKE2B 78db5ac231e751e473d4e7e94aeeb86995fbf77b7576b404040e1383c99dbfa8fbcedeebdef803944cf542dbc022f95815de340e7a9b4cc3348a444a7f9818a1 SHA512 70fe71d67fd00635025efa19bcdf852da23412d2010057362b389ae67f52bebb83910e7c93f128932d00ed2db1f9c29b3b77cdaf5ce3230a135f9b3cad8d16e2
-EBUILD HTSeq-9999.ebuild 773 BLAKE2B 78db5ac231e751e473d4e7e94aeeb86995fbf77b7576b404040e1383c99dbfa8fbcedeebdef803944cf542dbc022f95815de340e7a9b4cc3348a444a7f9818a1 SHA512 70fe71d67fd00635025efa19bcdf852da23412d2010057362b389ae67f52bebb83910e7c93f128932d00ed2db1f9c29b3b77cdaf5ce3230a135f9b3cad8d16e2
+DIST HTSeq-2.0.2.gh.tar.gz 48468261 BLAKE2B c68ec67906f3cf78954e94214b82fd51bc19e0c505f994a3df4bfc682d804fa26f4883e9a8fa1e8ddf1e4f8ba8690d605705ebdd2d1695470984c2f04b6a19ce SHA512 96c0b4de6c9cfa9e405f02e366ecfed63bb0dba0ab76fe872f6f48b52a4956b08fa75efa4b1e4c6e4560e34b4e2921bf1ec9671831226ad415ed421a88ec3f6d
+EBUILD HTSeq-2.0.2.ebuild 1569 BLAKE2B 2a2b83903f275ad6f64da5611958f6e208293def1b2a99e16d505b7de24514b3aae090882263596727650c19f126a2707ef3fa1d17aa58fb9179ff399d62d4c5 SHA512 1ae7790220702b063c6e059459846b8eae4db76cf091651f9a3723bc27fdadf132916f2b7574e45b58af62976a0f67d007046be8ae84e0cc95c25aa95c342b1b
+EBUILD HTSeq-9999.ebuild 1569 BLAKE2B 2a2b83903f275ad6f64da5611958f6e208293def1b2a99e16d505b7de24514b3aae090882263596727650c19f126a2707ef3fa1d17aa58fb9179ff399d62d4c5 SHA512 1ae7790220702b063c6e059459846b8eae4db76cf091651f9a3723bc27fdadf132916f2b7574e45b58af62976a0f67d007046be8ae84e0cc95c25aa95c342b1b
MISC metadata.xml 330 BLAKE2B 0710ed510732fd584ecbee4d193bf2cccf72af692cc5ce7243ab7864f00ba23d22fca0c4b06213d7e40697c0e469c29f36d988c7fa0d8ab6ea985f8df7255388 SHA512 481004c3e6ba51f4e983e265b7a3f9e4281e27c95ea894eb7f166a339059507cb947eddba1d8642d952289936c8145fc20fa26ed11522535d4c097cc6a3cb018