summaryrefslogtreecommitdiff
path: root/sci-astronomy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-25 19:01:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-25 19:01:08 +0000
commitfc68863e718441fe15bb0dea2ca03ea06a6f558d (patch)
tree5cfeda3e589273a4fa9d6c84119acf0db4c2453c /sci-astronomy
parentecf595717796995cab38a07093dc9597d55d0ea6 (diff)
gentoo auto-resync : 25:03:2024 - 19:01:08
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/Manifest.gzbin6862 -> 6859 bytes
-rw-r--r--sci-astronomy/calcmysky/Manifest2
-rw-r--r--sci-astronomy/calcmysky/calcmysky-0.3.2.ebuild65
3 files changed, 67 insertions, 0 deletions
diff --git a/sci-astronomy/Manifest.gz b/sci-astronomy/Manifest.gz
index b491471cae77..e98e815faa0d 100644
--- a/sci-astronomy/Manifest.gz
+++ b/sci-astronomy/Manifest.gz
Binary files differ
diff --git a/sci-astronomy/calcmysky/Manifest b/sci-astronomy/calcmysky/Manifest
index 768745f9b109..83b458fece48 100644
--- a/sci-astronomy/calcmysky/Manifest
+++ b/sci-astronomy/calcmysky/Manifest
@@ -1,3 +1,5 @@
DIST calcmysky-0.3.1.tar.gz 2166487 BLAKE2B d1e2bf0a5a2118e3679427e705f5265c9d6c8962adb58b4a5a6464252ee10fcba396758ef3a1a8c1e57b2291a076bc034e4231ea21a6fc464eda3c5ffd376bc1 SHA512 3038feffdf3a61d49d39304b72f1c2809ea5e3a835c4b3c1603162802afc3d27af6cdfd63eb3286e9e614850b73e338e1cc2cf6a6e915ea968194c0a7a9a56eb
+DIST calcmysky-0.3.2.tar.gz 2166906 BLAKE2B c306b780b76ace936c373c4c554ed25fdfc3a507ebe34950634527c32deb59b99feb4d55e1b82150dd0611caf8835a1d178ec2a044a2ddf7b2ade604d6edb67a SHA512 a7f69b25c54be86ce179a118ca8a6d606e2c0fe7dc238b46620237e311dc5198a2aeb70e4885cc6553a26f7c38b78b5a338115a4606161fa249a806e891f88b6
EBUILD calcmysky-0.3.1.ebuild 1220 BLAKE2B 96fa75434224737253e61900154f96a9a1577c3a5afdcc927daf1fcc7e30652b9b6c55829efbc68efead24cae846ce0b2fb0cc96d089780dc965da4a3031e17f SHA512 cd3bee65131528c9a98304bce978b2cefd8cdaba347e3ff59d451d849b070e7fccf72b07be02c3c945fcafdf3d3bb85cdbab6aff091235b765cebfab59881c84
+EBUILD calcmysky-0.3.2.ebuild 1221 BLAKE2B 5b6c96ff1932a11b740d218ec98f9225180927ed5a9c0595006ac715e121b091e3fd3ac95d50c7e1faa56b28de52aaafbefe3debebe8412f9bf06034ef614296 SHA512 3e48c01ed09dcd101b68d9110afa30a1bd603da3d78d08109d8adbf47a8cb0ac950431d00f45642ea1eaa15ecf57d54b27981d17769b378e16d28c2915b0a360
MISC metadata.xml 582 BLAKE2B dbfe97e6d7c27ec436cd080f0d9c7969f4a13a174db9637970dc19d9ca3c6387e3de1f97093fb8699e22f77927daa49e10709bfe14b91ade50e3d8bc449bfcb2 SHA512 ec397bf939ac6935284ae74ceca2cd253b9558d963ab627153cd5360bff6f506a8cfe53cbf49a38a59a71fd3013f25138c44d1034aed134f0d1995d021ad7408
diff --git a/sci-astronomy/calcmysky/calcmysky-0.3.2.ebuild b/sci-astronomy/calcmysky/calcmysky-0.3.2.ebuild
new file mode 100644
index 000000000000..80cec5a5f753
--- /dev/null
+++ b/sci-astronomy/calcmysky/calcmysky-0.3.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multibuild cmake
+
+DESCRIPTION="Simulator of light scattering by planetary atmospheres"
+HOMEPAGE="https://github.com/10110111/CalcMySky"
+SRC_URI="
+ https://github.com/10110111/CalcMySky/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3"
+# subslot is soversion
+SLOT="0/15"
+KEYWORDS="amd64 ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="qt5 qt6"
+REQUIRED_USE="|| ( qt5 qt6 )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ media-libs/glm
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ qt6? (
+ dev-qt/qtbase:6[gui,opengl,widgets,-gles2-only]
+ )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/CalcMySky-${PV}"
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt5) $(usev qt6) )
+}
+
+src_configure() {
+ my_src_configure() {
+ local mycmakeargs=(
+ -DQT_VERSION="${MULTIBUILD_VARIANT/qt/}"
+ )
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_test() {
+ multibuild_foreach_variant cmake_build check
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+}