summaryrefslogtreecommitdiff
path: root/sci-astronomy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-23 14:44:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-23 14:44:46 +0100
commitcdfd4f0c915964d401cba19362c7dea8e89ad1da (patch)
treef6d313d1b57913d1309e00a578166e1e10fa6b8d /sci-astronomy
parent05a34d98821265bf73820931936f86704b9002c6 (diff)
gentoo auto-resync : 23:08:2022 - 14:44:46
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/Manifest.gzbin6843 -> 6842 bytes
-rw-r--r--sci-astronomy/pal/Manifest2
-rw-r--r--sci-astronomy/pal/pal-0.9.8.ebuild34
3 files changed, 36 insertions, 0 deletions
diff --git a/sci-astronomy/Manifest.gz b/sci-astronomy/Manifest.gz
index cd37d54d0ae1..a3a9fdb28c47 100644
--- a/sci-astronomy/Manifest.gz
+++ b/sci-astronomy/Manifest.gz
Binary files differ
diff --git a/sci-astronomy/pal/Manifest b/sci-astronomy/pal/Manifest
index d51dd6130b80..f3b919536598 100644
--- a/sci-astronomy/pal/Manifest
+++ b/sci-astronomy/pal/Manifest
@@ -1,3 +1,5 @@
DIST pal-0.9.7.tar.gz 1220443 BLAKE2B 99ffccf0eff340f21ea99bfa219d651d0773957152bdc840b2cc7596f14c0389846128947fb63607856e76ba6a98bd113fd04eddf819f71eaa5f16b957ebc78c SHA512 d3f13e7ff321500acc71198240392fe9a3304c4142cf5b1f1c3950ddb1351dddac8565ef27b1c724d608cc1053d15647c777c4d0dc466a99a1b08b64e62ec37b
+DIST pal-0.9.8.tar.gz 1267834 BLAKE2B 0f1735b564881785ddcfab5c73480905b47c7e7a1d2b9183069f5a620584cf552df9ecccac111b33f46d59a696a40762a0c95698a153a293636071a219ca39fb SHA512 659ca2f97ac58558a638b400f83773af39002785ae3734a195ff8bfbc968af76a6c2ec5ab2dfcb7b81908391c55f31c7d4a4172705bd5fab306ef2233587e2d3
EBUILD pal-0.9.7.ebuild 782 BLAKE2B 80b0d33feba8de8f71542bbd23172985ecd5a2fde98599a2dd33515dbb30674bf92dbe21352ba1298222a09df8079abf7f826e24a04fcff1c062464c66bbf6e6 SHA512 fd140421ae2b94d5423555f86716f629222e2d0445c74fab572fabf944d1b6ec554cf2e011c75f27e7cf8616d95796da7f018e0f72099e31662b779ef82dc6ff
+EBUILD pal-0.9.8.ebuild 788 BLAKE2B 81a95926b8655ede821b9c1dfb335185e11949a5fbc83af33ad6a42851f051ef8222369d4a4fc4767e9e9744e8beeffce5e5bd710dbc17923edda4fab1d3e149 SHA512 0df21125b4adcbeedc98b446d6d5b5330b7f31b778be428af77b79e5816717ace5c89f699e353d23336dce91f8e29f54873b853c170448b3bbe48cf866bbe5ac
MISC metadata.xml 642 BLAKE2B 505c91de974548999c77a29097c98efeb82dc49855bc8d92a3cdf664ba4c2c1977111a1c862862edc413366e162b043f272db71319757c4a79e43faf97b91ad8 SHA512 da8417f4a4f292929698b29d6d3219511f0b63e611d081726b13617708b222e72db4911f14cd381a50b195256c7ab5d5ee9e05e660a4885dda5575d20f0b5940
diff --git a/sci-astronomy/pal/pal-0.9.8.ebuild b/sci-astronomy/pal/pal-0.9.8.ebuild
new file mode 100644
index 000000000000..164a46ed2fe3
--- /dev/null
+++ b/sci-astronomy/pal/pal-0.9.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Positional Astronomy Library"
+HOMEPAGE="https://github.com/Starlink/pal"
+SRC_URI="https://github.com/Starlink/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+RDEPEND="sci-astronomy/erfa:="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --without-starlink \
+ --without-stardocs \
+ --with-erfa \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # remove cruft from non-fhs compliant
+ dodoc -r "${ED}"/usr/{docs,manifests,news}
+ rm -r "${ED}"/usr/{docs,manifests,news} || die
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}