summaryrefslogtreecommitdiff
path: root/sci-astronomy/weightwatcher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /sci-astronomy/weightwatcher
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'sci-astronomy/weightwatcher')
-rw-r--r--sci-astronomy/weightwatcher/Manifest4
-rw-r--r--sci-astronomy/weightwatcher/files/weightwatcher-1.12-AR.patch11
-rw-r--r--sci-astronomy/weightwatcher/files/weightwatcher-1.12-fno-common.patch160
-rw-r--r--sci-astronomy/weightwatcher/weightwatcher-1.12.ebuild17
4 files changed, 187 insertions, 5 deletions
diff --git a/sci-astronomy/weightwatcher/Manifest b/sci-astronomy/weightwatcher/Manifest
index c08b38123efa..df3d63c670d6 100644
--- a/sci-astronomy/weightwatcher/Manifest
+++ b/sci-astronomy/weightwatcher/Manifest
@@ -1,3 +1,5 @@
+AUX weightwatcher-1.12-AR.patch 206 BLAKE2B a2d02a51fa20765ec60b85a1c56533ac4cdb5d90afed30f8bb4a621aa044118ce082ae6d1a16166526ea8601ad36509f891bb8ae53bc0de7f6ff4917d03ac2c3 SHA512 ab78a5c3ae4cdbe3659dcf06c6c2f0615817eac44f08f5f01c54aa585cac629c3bef1c94ac49159df706bd5e8370f855a33c6b16724f2183d367623767e389a8
+AUX weightwatcher-1.12-fno-common.patch 4263 BLAKE2B f545cbe225b0b96b1a706b29342eeece1ffcb3e99371587e94734f44a9fbb310d97b10916f996d8787bdcf51d00f5da42efcdebbc8cdf973115dff60afb939fe SHA512 018f2d646585982cdd7c2f65d9a7142e592d92090e807ec503c4715437340dbb01c42f61e12b66c4d4444a514325243f056236cd061ee12a60a9a741f5eea87e
DIST weightwatcher-1.12.tar.gz 460583 BLAKE2B 6ea09dcb8ba527cdf40dc94a7ed7b11357ec438611cd0d30d99e209bd4d976454d064be77c98ec97d1c8946bfd987fdd2b34211e9b944c3ed293dd2e5c1a0fbf SHA512 392ca6442de96e6c35447b7b34c67b22e7793831337aaf0f06e45d40e63f8c5e9605649fe39a67a5baf9eadcb79fa9f5d998fcb9504f85606f75071d672b0ada
-EBUILD weightwatcher-1.12.ebuild 485 BLAKE2B 8d9f04061e97c08bc2171ad39ca51217d7a376e314c355049938e67cd94f3e100dbc4cca30914c51b7fb71867de750c3110751e5be45f15bfce2e7f23a91d4d6 SHA512 66844ff18af475cb91a152a701b43a445c9d31c7f921a23cbb50fb5476a4409337cb31509e814bb581eb49968fc7804426915af5579765f704b23f6a9553d6cf
+EBUILD weightwatcher-1.12.ebuild 592 BLAKE2B 2d59c39979cb4ac0cffb4864e86885ddd31e3c6eca0c41e34cd0824bc070a386c60626057cbb47afdf75525f0f5acead517764031d7ae7d2c1e5b6b09f08d2d4 SHA512 1e00a4cb90c30a7839f2bd5dfaf670e31d555035a77b7621236ad352c05b72e9de62148031ddb3132099c5df41726c6989f394418c0a6d2d57250239a0ae673f
MISC metadata.xml 586 BLAKE2B dd2a604c0b5315f0bf0efaec55818d19838ef9038b7e31d426db376877f884c799f110af45707c0e8f757990ce992418685c62d09ba6fea39277fb51f2a8dbc2 SHA512 68079ef915af3e2a28aeedac587ec907a2bc73568c16ecb914553ad82bd0f54466c6989296686799cf06017d1c1d9b8567e5bfede275339ee663913d7aa8688a
diff --git a/sci-astronomy/weightwatcher/files/weightwatcher-1.12-AR.patch b/sci-astronomy/weightwatcher/files/weightwatcher-1.12-AR.patch
new file mode 100644
index 000000000000..6c5b72ffc74c
--- /dev/null
+++ b/sci-astronomy/weightwatcher/files/weightwatcher-1.12-AR.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/725284
+--- a/configure.ac
++++ b/configure.ac
+@@ -78,6 +78,7 @@ fi
+
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
++AM_PROG_AR
+
+ # Checks for libraries.
+ # Replace `main' with a function in -lm:
diff --git a/sci-astronomy/weightwatcher/files/weightwatcher-1.12-fno-common.patch b/sci-astronomy/weightwatcher/files/weightwatcher-1.12-fno-common.patch
new file mode 100644
index 000000000000..a9071da81207
--- /dev/null
+++ b/sci-astronomy/weightwatcher/files/weightwatcher-1.12-fno-common.patch
@@ -0,0 +1,160 @@
+--- a/src/field.c
++++ b/src/field.c
+@@ -42,6 +42,9 @@
+ #include "prefs.h"
+ #include "readimage.h"
+
++extern prefstruct prefs;
++char gstr[MAXCHAR];
++
+ /********************************* newfield **********************************/
+ /*
+ Returns a pointer to a new field, ready to go!
+--- a/src/fits/fitsbody.c
++++ b/src/fits/fitsbody.c
+@@ -43,6 +43,7 @@
+ #include "fitscat_defs.h"
+ #include "fitscat.h"
+
++extern int bswapflag;
+ size_t body_maxram = BODY_DEFRAM,
+ body_maxvram = BODY_DEFVRAM,
+ body_ramleft, body_vramleft, body_ramflag;
+--- a/src/fits/fitscat.h
++++ b/src/fits/fitscat.h
+@@ -333,6 +333,6 @@ extern void error(int, char *, char *),
+ warning(char *msg1, char *msg2);
+
+
+-int bswapflag;
++extern int bswapflag;
+
+ #endif
+--- a/src/fits/fitscheck.c
++++ b/src/fits/fitscheck.c
+@@ -42,6 +42,7 @@
+ unsigned int exclude[13] = {0x3a, 0x3b, 0x3c, 0x3d, 0x3e, 0x3f, 0x40,
+ 0x5b, 0x5c, 0x5d, 0x5e, 0x5f, 0x60};
+
++extern int bswapflag;
+ /****** encode_checksum *****************************************************
+ PROTO void encode_checksum(unsigned int sum, char *str)
+ PURPOSE Encode a checksum to ASCII
+--- a/src/fits/fitskey.c
++++ b/src/fits/fitskey.c
+@@ -38,6 +38,7 @@
+ #include "fitscat_defs.h"
+ #include "fitscat.h"
+
++int bswapflag;
+ /****** add_key ****************************************************************
+ PROTO int add_key(keystruct *key, tabstruct *tab, int pos)
+ PURPOSE Copy a key from one table to another.
+--- a/src/fits/fitsread.c
++++ b/src/fits/fitsread.c
+@@ -38,6 +38,7 @@
+ #include "fitscat_defs.h"
+ #include "fitscat.h"
+
++extern int bswapflag;
+ char padbuf[FBSIZE];
+
+ /****** read_cat ***************************************************************
+--- a/src/fits/fitswrite.c
++++ b/src/fits/fitswrite.c
+@@ -39,6 +39,7 @@
+ #include "fitscat_defs.h"
+ #include "fitscat.h"
+
++extern int bswapflag;
+
+ /****** save_cat **************************************************************
+ PROTO void save_cat(catstruct *cat, char *filename)
+--- a/src/globals.h
++++ b/src/globals.h
+@@ -30,7 +30,7 @@
+ #include "types.h"
+
+ /*----------------------- miscellaneous variables ---------------------------*/
+-char gstr[MAXCHAR];
++extern char gstr[MAXCHAR];
+
+ /*------------------------------- functions ---------------------------------*/
+ extern void makeit(void),
+--- a/src/main.c
++++ b/src/main.c
+@@ -51,6 +51,8 @@ EXECUTABLE " [-c <configuration_file>] [-<keyword> <value>]\n"\
+ extern const char notokstr[];
+ time_t thetime, thetime2;
+
++extern prefstruct prefs;
++
+ /********************************** main ************************************/
+ int main(int argc, char *argv[])
+
+--- a/src/makeit.c
++++ b/src/makeit.c
+@@ -45,6 +45,8 @@
+ #include "readimage.h"
+ #include "xml.h"
+
++extern prefstruct prefs;
++
+ /********************************** makeit ***********************************/
+ void makeit(void)
+ {
+--- a/src/prefs.c
++++ b/src/prefs.c
+@@ -51,6 +51,9 @@
+ #include "prefs.h"
+ #include "preflist.h"
+
++extern int bswapflag;
++prefstruct prefs;
++
+ /********************************* dumpprefs ********************************/
+ /*
+ Print the default preference parameters.
+--- a/src/prefs.h
++++ b/src/prefs.h
+@@ -86,7 +86,7 @@ typedef struct
+ double time_diff; /* Execution time */
+ } prefstruct;
+
+- prefstruct prefs;
++extern prefstruct prefs;
+
+
+ /*-------------------------------- protos -----------------------------------*/
+--- a/src/readimage.c
++++ b/src/readimage.c
+@@ -39,6 +39,7 @@
+ #include "fits/fitscat.h"
+ #include "readimage.h"
+
++extern int bswapflag;
+ /******************************** readdata **********************************/
+ /*
+ read and convert input data stream in PIXTYPE (float) format.
+--- a/src/vector.c
++++ b/src/vector.c
+@@ -46,6 +46,9 @@
+
+ static void chsort(crosstruct *ra, int n);
+
++extern char gstr[MAXCHAR];
++extern prefstruct prefs;
++
+ /********************************** newvec **********************************/
+ /*
+ Returns a pointer to a new polygon, and initialize local context buffer:
+--- a/src/xml.c
++++ b/src/xml.c
+@@ -45,6 +45,7 @@
+ #include "field.h"
+ #include "xml.h"
+
++extern prefstruct prefs;
+ extern time_t thetime,thetime2; /* from makeit.c */
+ extern pkeystruct key[]; /* from preflist.h */
+ extern char keylist[][32]; /* from preflist.h */
diff --git a/sci-astronomy/weightwatcher/weightwatcher-1.12.ebuild b/sci-astronomy/weightwatcher/weightwatcher-1.12.ebuild
index c423074420aa..2aa44a1044b1 100644
--- a/sci-astronomy/weightwatcher/weightwatcher-1.12.ebuild
+++ b/sci-astronomy/weightwatcher/weightwatcher-1.12.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit autotools
DESCRIPTION="Combine weight maps and polygon for astronomical images weighting"
HOMEPAGE="http://www.astromatic.net/software/weightwatcher/"
@@ -12,8 +14,15 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="doc"
-RDEPEND=""
-DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-AR.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_install() {
default