summaryrefslogtreecommitdiff
path: root/sci-astronomy/wcslib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-astronomy/wcslib
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-astronomy/wcslib')
-rw-r--r--sci-astronomy/wcslib/Manifest4
-rw-r--r--sci-astronomy/wcslib/wcslib-7.3.1.ebuild7
-rw-r--r--sci-astronomy/wcslib/wcslib-7.3.ebuild7
3 files changed, 14 insertions, 4 deletions
diff --git a/sci-astronomy/wcslib/Manifest b/sci-astronomy/wcslib/Manifest
index e6e494474fa6..45c9d984d9c4 100644
--- a/sci-astronomy/wcslib/Manifest
+++ b/sci-astronomy/wcslib/Manifest
@@ -1,5 +1,5 @@
DIST wcslib-7.3.1.tar.bz2 2434274 BLAKE2B 9789a8eb34fe37c96b52e20efe3c14368499058e5c46aad4853b2be5f32a31df26525ec2c38d0ce87bcb7891b91a3ec3ac537e3c662c716a7c4381f26cd715e4 SHA512 753e0e202fb4250d321c36a0df9cd45ed88697111a06e108bc3e5397ddecc60d460cda2b4d45b5311dd72b88b66d4c70ff150b03e2da46c834b024f15304779b
DIST wcslib-7.3.tar.bz2 2435669 BLAKE2B c0f641b4c2fdd9d332816195f399eb2ab3c5aa585f08c4857af77bd5ed4074e653663f7cbddc6d7678cd85bed2c0bd95719cd83a5138d21ad24841396d4c11b9 SHA512 8c98c4b575056e2d966b77a4bc951256d02ecee3a11847e140fd38d93afd0f76b3e906d590c952dc9fc58ceeb1ba062b19d8e1e676ee0032f5b7ed13a9dfa892
-EBUILD wcslib-7.3.1.ebuild 1584 BLAKE2B 13e1f4f27200a8ba8b113acb880d91bfda26f8aeb67e5dbc36aff581d45658d2f6e8b438ed7675d9d3de7458a63d293dec69c949a27320dfe25c30aa5fe7f334 SHA512 c7cea572b8e72b746f20dc650ae5928353103992c3cacfdb8c724034ae6fdc2522423317fdbabf6183f9994e6849fe7a1dc81908a53a2352e83991fba3183b22
-EBUILD wcslib-7.3.ebuild 1582 BLAKE2B 4a3cbfc272c544b90ef075596cf1b275e95e7a807aa746d1936a25cc70a8c79561fb274bf60192e3c4690f5bf1824afd9897795d132b45ad7a05e8e3ca761ad6 SHA512 d5f9b2f67b6c22b092f1096646489f873d86f016406eacab3af31a5ea010670687a49a9c95a00099b11bfe2e31aa04a69ee734404a27dc78d6f045fdbade681c
+EBUILD wcslib-7.3.1.ebuild 1693 BLAKE2B e00e09b8e5223ef63eb2c65d626bb5f1e60d5cfa1a490ad9ceca268bec913c23f13d916520ef7b1b5c4e032f5fdc59dff3680e3448f48d0f66ccdfa7a53ed15a SHA512 e69ba5bed4b3acd3fdf871453a0a3f22faadbbaf6858f0806e260b7cb0f45fefd1a922a8f710ee1485bd33114801c03aaa1bc7baebceef0d34febb18729f2ca3
+EBUILD wcslib-7.3.ebuild 1691 BLAKE2B 98f7e1ed446fb03c86419ff096131ddc318a9b11d5d97b8fc484dcdb22e277e2908112839080aa6c9633e1101b2d56ab2d97caf2cc950e18a982ec094efa26a0 SHA512 f16ee1129c6a4c54dbdf1da67e14af94d0eeba5945c164adaa5f187f3e287a721ccb6f9a7a9c989b77f7e5d2545e0d5c2ca2cd01c93e6742e6386cf844716bb4
MISC metadata.xml 1092 BLAKE2B 117c7758257296d911cadb26e55fc50ad6439c4ac69e82e31b4f41e36a3f862270bb88f87533e25dd5f33c9c07a3ce8164715ba460f91c025c12c7cb31a6b509 SHA512 1c6a19945464451f87c365743d4c2a7271feab32bbafe4147abeafc5948bbf207716f3c46a2dd59c9e9fa5fce5d2b4ab8bebc8a1181915f8f81a2b3a353022e3
diff --git a/sci-astronomy/wcslib/wcslib-7.3.1.ebuild b/sci-astronomy/wcslib/wcslib-7.3.1.ebuild
index a7feb7d418e8..c6f97ef59730 100644
--- a/sci-astronomy/wcslib/wcslib-7.3.1.ebuild
+++ b/sci-astronomy/wcslib/wcslib-7.3.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
FORTRAN_NEEDED=fortran
-inherit fortran-2
+inherit fortran-2 flag-o-matic
DESCRIPTION="Astronomical World Coordinate System transformations library"
HOMEPAGE="https://www.atnf.csiro.au/people/mcalabre/WCS/"
@@ -24,12 +24,17 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
+ # GCC 10 workaround
+ # bug #764548
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
local myconf=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}
--htmldir="${EPREFIX}"/usr/share/doc/${PF}
$(use_enable fortran)
$(use_enable tools utils)
)
+
# hacks because cfitsio and pgplot directories are hard-coded
if use fits; then
myconf+=(
diff --git a/sci-astronomy/wcslib/wcslib-7.3.ebuild b/sci-astronomy/wcslib/wcslib-7.3.ebuild
index 9333d9e13c38..a01c6a87494c 100644
--- a/sci-astronomy/wcslib/wcslib-7.3.ebuild
+++ b/sci-astronomy/wcslib/wcslib-7.3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
FORTRAN_NEEDED=fortran
-inherit fortran-2
+inherit fortran-2 flag-o-matic
DESCRIPTION="Astronomical World Coordinate System transformations library"
HOMEPAGE="https://www.atnf.csiro.au/people/mcalabre/WCS/"
@@ -24,12 +24,17 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
+ # GCC 10 workaround
+ # bug #764548
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
local myconf=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}
--htmldir="${EPREFIX}"/usr/share/doc/${PF}
$(use_enable fortran)
$(use_enable tools utils)
)
+
# hacks because cfitsio and pgplot directories are hard-coded
if use fits; then
myconf+=(