summaryrefslogtreecommitdiff
path: root/sci-astronomy/wcslib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sci-astronomy/wcslib
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sci-astronomy/wcslib')
-rw-r--r--sci-astronomy/wcslib/Manifest4
-rw-r--r--sci-astronomy/wcslib/metadata.xml4
-rw-r--r--sci-astronomy/wcslib/wcslib-7.3.ebuild66
3 files changed, 73 insertions, 1 deletions
diff --git a/sci-astronomy/wcslib/Manifest b/sci-astronomy/wcslib/Manifest
index 658f874083c2..92afd63c56d8 100644
--- a/sci-astronomy/wcslib/Manifest
+++ b/sci-astronomy/wcslib/Manifest
@@ -1,3 +1,5 @@
DIST wcslib-5.16.tar.bz2 2222111 BLAKE2B e11da145db6366804321cf415bdac621a930418f09d788c8b94413980710bb43357129a830462339127398082700a9f44f56dc0b8c96ef923d41ea0174dfd07f SHA512 bf7ab586995bdade8b96c77dee891c7d7ab6de82a7e2f94a09d89643e93658063f832efdb66e0bba11ad114b6e0ca555cba9308a84f0f22fb833e3a6303cefe6
+DIST wcslib-7.3.tar.bz2 2435669 BLAKE2B c0f641b4c2fdd9d332816195f399eb2ab3c5aa585f08c4857af77bd5ed4074e653663f7cbddc6d7678cd85bed2c0bd95719cd83a5138d21ad24841396d4c11b9 SHA512 8c98c4b575056e2d966b77a4bc951256d02ecee3a11847e140fd38d93afd0f76b3e906d590c952dc9fc58ceeb1ba062b19d8e1e676ee0032f5b7ed13a9dfa892
EBUILD wcslib-5.16.ebuild 1628 BLAKE2B a782f5f8bfcca41cc1e841debfad393473873cb8b450443d0013d2ed74ae5761b8b9a16a7c30e9d578730d5689b2f15233dc13dea8217312c5e09fbba8bef953 SHA512 d4eaad7b56a6982fcc7dc6e33da27b1a6f2216a4b0c7a85bd328951c95c464000d5464625c74dbdeb356802957741010834a992a8dc7d710c398fcc4b11e6dc5
-MISC metadata.xml 976 BLAKE2B 7507ba6725d4a27888d6bc57c2e6c10bcb4a2bd06a2809228423b40009aa1fbef15303cb8a78a510cca5771f3d7cd3b59501751a0969990130d297fe6b1d7312 SHA512 cd4bc1614ea120e04ced965a92fdd343db9e4d1a6046b57efd503674547cfa45ce6a03bb3a2d34a472dccd885d598cbf3cd3d9d9fe182a2fc067a801e8eb9577
+EBUILD wcslib-7.3.ebuild 1584 BLAKE2B f870dcdcd480abd7ee2bf47a2f04fd1cf9c848a01cce69bf52356b1239b35b3c9eb08b971bb9aff7290a40e075fc1cb8fc84b07b26fee1ea47beee34f4d87e94 SHA512 b1477e023fa28849633669a26de76586ca87c20f2bb60e62236d24a67497eeef09d98ebc80608d55ec23e98835ff3286612dc6748fd463b0634dfe1397a2ef21
+MISC metadata.xml 1092 BLAKE2B 117c7758257296d911cadb26e55fc50ad6439c4ac69e82e31b4f41e36a3f862270bb88f87533e25dd5f33c9c07a3ce8164715ba460f91c025c12c7cb31a6b509 SHA512 1c6a19945464451f87c365743d4c2a7271feab32bbafe4147abeafc5948bbf207716f3c46a2dd59c9e9fa5fce5d2b4ab8bebc8a1181915f8f81a2b3a353022e3
diff --git a/sci-astronomy/wcslib/metadata.xml b/sci-astronomy/wcslib/metadata.xml
index f74e78465e2d..809842b35b0f 100644
--- a/sci-astronomy/wcslib/metadata.xml
+++ b/sci-astronomy/wcslib/metadata.xml
@@ -5,6 +5,10 @@
<email>sci-astronomy@gentoo.org</email>
<name>Gentoo Astronomy Project</name>
</maintainer>
+ <maintainer type="person">
+ <email>davidroman96@gmail.com</email>
+ <name>David Roman</name>
+ </maintainer>
<longdescription lang="en">
WCSLIB is a C library, supplied with a full set of Fortran wrappers,
that implements the "World Coordinate System" (WCS) convention in FITS
diff --git a/sci-astronomy/wcslib/wcslib-7.3.ebuild b/sci-astronomy/wcslib/wcslib-7.3.ebuild
new file mode 100644
index 000000000000..1a490f77abdc
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-7.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_NEEDED=fortran
+
+inherit fortran-2
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="https://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0/7"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran fits pgplot static-libs +tools"
+
+RDEPEND="
+ fits? ( sci-libs/cfitsio:0= )
+ pgplot? ( sci-libs/pgplot:0= )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable fortran)
+ $(use_enable tools utils)
+ )
+ # hacks because cfitsio and pgplot directories are hard-coded
+ if use fits; then
+ myconf+=(
+ --with-cfitsioinc="${EPREFIX}/usr/include"
+ --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-cfitsio )
+ fi
+ if use pgplot; then
+ myconf+=(
+ --with-pgplotinc="${EPREFIX}/usr/include"
+ --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-pgplot )
+ fi
+ econf ${myconf[@]}
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_test() {
+ emake check
+}
+
+src_install () {
+ default
+ # static libs share the same symbols as shared (i.e. compiled with PIC)
+ # so they are not compiled twice
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
+ use doc || rm -r \
+ "${ED}"/usr/share/doc/${PF}/html \
+ "${ED}"/usr/share/doc/${PF}/*.pdf
+}