summaryrefslogtreecommitdiff
path: root/sci-astronomy/stellarium/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-27 21:10:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-27 21:10:49 +0100
commit3ca7a521e79841f7247feb67780a70722c997d55 (patch)
tree30b9afb1b822575d8e6ac4009489795a105a56ce /sci-astronomy/stellarium/files
parentc268590c556cb766e1ca3f55fde8a40cdde19c44 (diff)
gentoo auto-resync : 27:09:2022 - 21:10:48
Diffstat (limited to 'sci-astronomy/stellarium/files')
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.21.2-unbundle-qtcompress.patch207
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.22.1-fix-conv.patch23
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.22.1-fix-star-manager-segfault.patch30
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.22.1-fix-test-x86.patch93
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.22.1-unbundle-qtcompress.patch208
5 files changed, 0 insertions, 561 deletions
diff --git a/sci-astronomy/stellarium/files/stellarium-0.21.2-unbundle-qtcompress.patch b/sci-astronomy/stellarium/files/stellarium-0.21.2-unbundle-qtcompress.patch
deleted file mode 100644
index f5d757b1bb16..000000000000
--- a/sci-astronomy/stellarium/files/stellarium-0.21.2-unbundle-qtcompress.patch
+++ /dev/null
@@ -1,207 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -594,6 +594,7 @@ ELSE(ENABLE_GPS)
- MESSAGE(STATUS "GPS: disabled.")
- ENDIF(ENABLE_GPS)
-
-+find_package(Qt5Compress REQUIRED)
-
- IF(USE_QTOPENGL)
- # QtOpenGL module is deprecated. After merging the QOpenGLWidget branch, we don't use this module directly anymore,
---- a/plugins/Satellites/src/CMakeLists.txt
-+++ b/plugins/Satellites/src/CMakeLists.txt
-@@ -55,7 +55,7 @@ IF(ENABLE_TESTING)
- ENDIF(ENABLE_TESTING)
-
- ADD_LIBRARY(Satellites-static STATIC ${Satellites_SRCS} ${Satellites_RES_CXX} ${SatellitesDialog_UIS_H})
--TARGET_LINK_LIBRARIES(Satellites-static Qt5::Core Qt5::Network Qt5::Widgets)
-+TARGET_LINK_LIBRARIES(Satellites-static Qt5::Core Qt5::Network Qt5::Widgets Qt5::Compress)
- # The library target "Satellites-static" has a default OUTPUT_NAME of "Satellites-static", so change it.
- SET_TARGET_PROPERTIES(Satellites-static PROPERTIES OUTPUT_NAME "Satellites")
- IF(MSVC)
---- a/plugins/Satellites/src/Satellites.cpp
-+++ b/plugins/Satellites/src/Satellites.cpp
-@@ -43,7 +43,7 @@
- #include "StelUtils.hpp"
- #include "StelActionMgr.hpp"
-
--#include "external/qtcompress/qzipreader.h"
-+#include "qzipreader.h"
-
- #include <QNetworkAccessManager>
- #include <QNetworkReply>
-@@ -1549,12 +1549,12 @@ void Satellites::saveDownloadedUpdate(QNetworkReply* reply)
- QString archive = zip.fileName();
- QByteArray data;
-
-- Stel::QZipReader reader(archive);
-- if (reader.status() != Stel::QZipReader::NoError)
-+ QZipReader reader(archive);
-+ if (reader.status() != QZipReader::NoError)
- qWarning() << "[Satellites] Unable to open as a ZIP archive";
- else
- {
-- QList<Stel::QZipReader::FileInfo> infoList = reader.fileInfoList();
-+ QList<QZipReader::FileInfo> infoList = reader.fileInfoList();
- for (const auto& info : qAsConst(infoList))
- {
- // qWarning() << "[Satellites] Processing:" << info.filePath;
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -464,7 +464,7 @@ IF(ENABLE_SPOUT AND SPOUT_LIBRARY_DLL)
- CONFIGURE_FILE(${SPOUT_LIBRARY_DLL} ${CMAKE_CURRENT_BINARY_DIR} COPYONLY)
- ENDIF()
-
--SET(STELMAIN_DEPS ${ZLIB_LIBRARIES} qtcompress_stel glues_stel qcustomplot_stel qxlsx_stel ${STELLARIUM_STATIC_PLUGINS_LIBRARIES} ${STELLARIUM_QT_LIBRARIES} ${SPOUT_LIBRARY})
-+SET(STELMAIN_DEPS ${ZLIB_LIBRARIES} Qt5::Compress glues_stel qcustomplot_stel qxlsx_stel ${STELLARIUM_STATIC_PLUGINS_LIBRARIES} ${STELLARIUM_QT_LIBRARIES} ${SPOUT_LIBRARY})
- IF(ENABLE_LIBGPS)
- SET(STELMAIN_DEPS ${STELMAIN_DEPS} ${GPS_LIBRARY})
- ENDIF()
---- a/src/core/modules/LandscapeMgr.cpp
-+++ b/src/core/modules/LandscapeMgr.cpp
-@@ -1322,8 +1322,8 @@ QString LandscapeMgr::installLandscapeFromArchive(QString sourceFilePath, const
- }
- QDir destinationDir (parentDestinationDir.absoluteFilePath("landscapes"));
-
-- Stel::QZipReader reader(sourceFilePath);
-- if (reader.status() != Stel::QZipReader::NoError)
-+ QZipReader reader(sourceFilePath);
-+ if (reader.status() != QZipReader::NoError)
- {
- qWarning() << "LandscapeMgr: Unable to open as a ZIP archive:" << QDir::toNativeSeparators(sourceFilePath);
- emit errorNotArchive();
-@@ -1332,7 +1332,7 @@ QString LandscapeMgr::installLandscapeFromArchive(QString sourceFilePath, const
-
- //Detect top directory
- QString topDir, iniPath;
-- QList<Stel::QZipReader::FileInfo> infoList = reader.fileInfoList();
-+ QList<QZipReader::FileInfo> infoList = reader.fileInfoList();
- for (const auto& info : infoList)
- {
- QFileInfo fileInfo(info.filePath);
---- a/src/external/CMakeLists.txt
-+++ b/src/external/CMakeLists.txt
-@@ -70,6 +70,7 @@ target_include_directories(zlib_stel PUBLIC zlib)
- set_target_properties(zlib_stel PROPERTIES AUTOMOC 0)
- SET_TARGET_PROPERTIES(zlib_stel PROPERTIES FOLDER "src/external")
-
-+if(0)
- set(qtcompress_SRCS
- qtcompress/qzip.cpp
- qtcompress/qzipreader.h
-@@ -82,6 +83,7 @@ target_link_libraries(qtcompress_stel ${ZLIB_LIBRARIES} Qt5::Core)
- #turn off automoc, not needed here
- set_target_properties(qtcompress_stel PROPERTIES AUTOMOC 0)
- SET_TARGET_PROPERTIES(qtcompress_stel PROPERTIES FOLDER "src/external")
-+endif()
-
- # QCustomPlot should not be unbundled, because upstream uses GPL 3, and
- # Stellarium uses GPL 2. Author of QCustomPlot has agreed for GPL 2+ for this.
-@@ -180,7 +182,7 @@ SET(qxlsx_SRCS
- qxlsx/xlsxcelllocation.h
- )
- add_library(qxlsx_stel STATIC EXCLUDE_FROM_ALL ${qxlsx_SRCS})
--target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui qtcompress_stel)
-+target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui Qt5::Compress)
- set_target_properties(qxlsx_stel PROPERTIES FOLDER "src/external")
-
- ################################# INDI ################################
---- a/src/external/qxlsx/xlsxzipreader.cpp
-+++ b/src/external/qxlsx/xlsxzipreader.cpp
-@@ -5,13 +5,13 @@
- QT_BEGIN_NAMESPACE_XLSX
-
- ZipReader::ZipReader(const QString &filePath) :
-- m_reader(new Stel::QZipReader(filePath))
-+ m_reader(new QZipReader(filePath))
- {
- init();
- }
-
- ZipReader::ZipReader(QIODevice *device) :
-- m_reader(new Stel::QZipReader(device))
-+ m_reader(new QZipReader(device))
- {
- init();
- }
-@@ -23,8 +23,8 @@ ZipReader::~ZipReader()
-
- void ZipReader::init()
- {
-- QList<Stel::QZipReader::FileInfo> allFiles = m_reader->fileInfoList();
-- for (const Stel::QZipReader::FileInfo &fi : allFiles) {
-+ QList<QZipReader::FileInfo> allFiles = m_reader->fileInfoList();
-+ for (const QZipReader::FileInfo &fi : allFiles) {
- if (fi.isFile || (!fi.isDir && !fi.isFile && !fi.isSymLink))
- m_filePaths.append(fi.filePath);
- }
---- a/src/external/qxlsx/xlsxzipreader_p.h
-+++ b/src/external/qxlsx/xlsxzipreader_p.h
-@@ -8,7 +8,7 @@
- #include <QIODevice>
-
- #include "xlsxglobal.h"
--#include "external/qtcompress/qzipreader.h"
-+#include "qzipreader.h"
-
- #if QT_VERSION >= 0x050600
- #include <QVector>
-@@ -31,7 +31,7 @@ public:
- private:
- Q_DISABLE_COPY(ZipReader)
- void init();
-- QScopedPointer<Stel::QZipReader> m_reader;
-+ QScopedPointer<QZipReader> m_reader;
- QStringList m_filePaths;
- };
-
---- a/src/external/qxlsx/xlsxzipwriter.cpp
-+++ b/src/external/qxlsx/xlsxzipwriter.cpp
-@@ -10,14 +10,14 @@ QT_BEGIN_NAMESPACE_XLSX
-
- ZipWriter::ZipWriter(const QString &filePath)
- {
-- m_writer = new Stel::QZipWriter(filePath, QIODevice::WriteOnly);
-- m_writer->setCompressionPolicy(Stel::QZipWriter::AutoCompress);
-+ m_writer = new QZipWriter(filePath, QIODevice::WriteOnly);
-+ m_writer->setCompressionPolicy(QZipWriter::AutoCompress);
- }
-
- ZipWriter::ZipWriter(QIODevice *device)
- {
-- m_writer = new Stel::QZipWriter(device);
-- m_writer->setCompressionPolicy(Stel::QZipWriter::AutoCompress);
-+ m_writer = new QZipWriter(device);
-+ m_writer->setCompressionPolicy(QZipWriter::AutoCompress);
- }
-
- ZipWriter::~ZipWriter()
-@@ -27,7 +27,7 @@ ZipWriter::~ZipWriter()
-
- bool ZipWriter::error() const
- {
-- return m_writer->status() != Stel::QZipWriter::NoError;
-+ return m_writer->status() != QZipWriter::NoError;
- }
-
- void ZipWriter::addFile(const QString &filePath, QIODevice *device)
---- a/src/external/qxlsx/xlsxzipwriter_p.h
-+++ b/src/external/qxlsx/xlsxzipwriter_p.h
-@@ -8,7 +8,7 @@
- #include <QIODevice>
-
- #include "xlsxglobal.h"
--#include "external/qtcompress/qzipwriter.h"
-+#include "qzipwriter.h"
-
- class QZipWriter;
-
-@@ -27,7 +27,7 @@ public:
- void close();
-
- private:
-- Stel::QZipWriter *m_writer;
-+ QZipWriter *m_writer;
- };
-
- QT_END_NAMESPACE_XLSX
diff --git a/sci-astronomy/stellarium/files/stellarium-0.22.1-fix-conv.patch b/sci-astronomy/stellarium/files/stellarium-0.22.1-fix-conv.patch
deleted file mode 100644
index 5187837fbb61..000000000000
--- a/sci-astronomy/stellarium/files/stellarium-0.22.1-fix-conv.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From dd65fdf5a332d62834ac1cfe9639e220ea635c55 Mon Sep 17 00:00:00 2001
-From: "Alexander V. Wolf" <alex.v.wolf@gmail.com>
-Date: Wed, 25 May 2022 20:55:15 +0700
-Subject: [PATCH] Fixed conversion tool radToHms(): avoiding possible negative
- zero for value of seconds (see #2460)
-
----
- src/core/StelUtils.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/core/StelUtils.cpp b/src/core/StelUtils.cpp
-index 93a55ebb957..b03f55a68ec 100644
---- a/src/core/StelUtils.cpp
-+++ b/src/core/StelUtils.cpp
-@@ -140,7 +140,7 @@ void radToHms(double angle, unsigned int& h, unsigned int& m, double& s)
-
- h = static_cast<unsigned int>(angle);
- m = static_cast<unsigned int>((angle-h)*60);
-- s = (angle-h)*3600.-60.*m;
-+ s = qAbs((angle-h)*3600.-60.*m);
- }
-
- /*************************************************************************
diff --git a/sci-astronomy/stellarium/files/stellarium-0.22.1-fix-star-manager-segfault.patch b/sci-astronomy/stellarium/files/stellarium-0.22.1-fix-star-manager-segfault.patch
deleted file mode 100644
index 7f8981a006e2..000000000000
--- a/sci-astronomy/stellarium/files/stellarium-0.22.1-fix-star-manager-segfault.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-This patch is required to fix a segfault on startup in <=0.22.1 if star catalogue files are
-added or removed (USE=stars)
-
-Refer: https://github.com/Stellarium/stellarium/issues/2404
-
-This patch may be safely removed for 0.22.2 - it has been patched upstream.
-
---- a/src/core/modules/StarMgr.cpp
-+++ b/src/core/modules/StarMgr.cpp
-@@ -592,13 +592,13 @@ void StarMgr::setCheckFlag(const QString& catId, bool b)
- return;
- m["checked"]=b;
- catalogsDescription[idx-1]=m;
-- starSettings["catalogs"]=catalogsDescription;
-- QFile tmp(starConfigFileFullPath);
-- if(tmp.open(QIODevice::WriteOnly))
-- {
-- StelJsonParser::write(starSettings, &tmp);
-- tmp.close();
-- }
-+ }
-+ starSettings["catalogs"]=catalogsDescription;
-+ QFile tmp(starConfigFileFullPath);
-+ if(tmp.open(QIODevice::WriteOnly))
-+ {
-+ StelJsonParser::write(starSettings, &tmp);
-+ tmp.close();
- }
- }
-
diff --git a/sci-astronomy/stellarium/files/stellarium-0.22.1-fix-test-x86.patch b/sci-astronomy/stellarium/files/stellarium-0.22.1-fix-test-x86.patch
deleted file mode 100644
index 784b388b2534..000000000000
--- a/sci-astronomy/stellarium/files/stellarium-0.22.1-fix-test-x86.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From 802065e025c8b435dc39b4fdd9262efdc1dcd2a8 Mon Sep 17 00:00:00 2001
-From: "Alexander V. Wolf" <alex.v.wolf@gmail.com>
-Date: Tue, 24 May 2022 14:47:50 +0700
-Subject: [PATCH] Fixed something strange in radToHMSStr and radToHMSStrAdapt
- convertors
-
-probably ancient bug (?), maybe related to issue #2460
----
- src/core/StelUtils.cpp | 6 +++---
- src/tests/testConversions.cpp | 16 ++++++----------
- 2 files changed, 9 insertions(+), 13 deletions(-)
-
-diff --git a/src/core/StelUtils.cpp b/src/core/StelUtils.cpp
-index 521d538315e..93a55ebb957 100644
---- a/src/core/StelUtils.cpp
-+++ b/src/core/StelUtils.cpp
-@@ -225,9 +225,9 @@ QString radToHmsStr(const double angle, const bool decimal)
- {
- unsigned int h,m;
- double s;
-- StelUtils::radToHms(angle+0.005*M_PI/12/(60*60), h, m, s);
-+ StelUtils::radToHms(angle, h, m, s);
- int width, precision;
-- QString carry, r;
-+ QString carry;
- if (decimal)
- {
- width=5;
-@@ -268,7 +268,7 @@ QString radToDmsStrAdapt(const double angle, const bool useD)
- bool sign;
- unsigned int d,m;
- double s;
-- StelUtils::radToDms(angle+0.005*M_PI/180/(60*60)*(angle<0?-1.:1.), sign, d, m, s); // NOTE: WTF???
-+ StelUtils::radToDms(angle, sign, d, m, s);
- QString str;
- QTextStream os(&str);
-
-diff --git a/src/tests/testConversions.cpp b/src/tests/testConversions.cpp
-index a37db14307c..6e8a4c6f04c 100644
---- a/src/tests/testConversions.cpp
-+++ b/src/tests/testConversions.cpp
-@@ -248,12 +248,12 @@ void TestConversions::testRadToDMSStrAdapt()
- data << 61*M_PI/360 << "+30°30'" << false;
- data << M_PI/648000 << "+0°0'1\"" << false;
- data << 1213*M_PI/2400 << "+90°58'30\"" << false;
-- data << 39599*M_PI/648000 << "+10°59'59\"" << false;
-+ data << 39599*M_PI/648000 << "+10°59'59.00\"" << false;
- data << -M_PI/36 << "-5°" << false;
- data << -7*M_PI/8 << "-157°30'" << false;
- data << -2*M_PI/5 << "-72°" << false;
- data << -M_PI << "-180°" << false;
-- data << -10*M_PI/648 << "-2°46'40\"" << false;
-+ data << -10*M_PI/648 << "-2°46'40.00\"" << false;
-
- data << 0. << "+0d" << true;
- data << M_PI/6 << "+30d" << true;
-@@ -268,12 +268,12 @@ void TestConversions::testRadToDMSStrAdapt()
- data << 61*M_PI/360 << "+30d30'" << true;
- data << M_PI/648000 << "+0d0'1\"" << true;
- data << 1213*M_PI/2400 << "+90d58'30\"" << true;
-- data << 39599*M_PI/648000 << "+10d59'59\"" << true;
-+ data << 39599*M_PI/648000 << "+10d59'59.00\"" << true;
- data << -M_PI/36 << "-5d" << true;
- data << -7*M_PI/8 << "-157d30'" << true;
- data << -2*M_PI/5 << "-72d" << true;
- data << -M_PI << "-180d" << true;
-- data << -10*M_PI/648 << "-2d46'40\"" << true;
-+ data << -10*M_PI/648 << "-2d46'40.00\"" << true;
-
- while (data.count()>=3)
- {
-@@ -282,9 +282,7 @@ void TestConversions::testRadToDMSStrAdapt()
- bool flag = data.takeFirst().toBool();
- QString rdms = StelUtils::radToDmsStrAdapt(rad, flag);
- QVERIFY2(rdms==edms, qPrintable(QString("%1 radians = %2 (expected %3) [flag: %4]")
-- .arg(QString::number(rad, 'f', 5))
-- .arg(rdms)
-- .arg(edms)
-+ .arg(QString::number(rad, 'f', 5), rdms, edms)
- .arg(flag)));
- }
- }
-@@ -381,9 +379,7 @@ void TestConversions::testRadToDMSStr()
- bool useDF = data.takeFirst().toBool();
- QString rdms = StelUtils::radToDmsStr(rad, decimalF, useDF);
- QVERIFY2(rdms==edms, qPrintable(QString("%1 radians = %2 (expected %3) [flags: %4, %5]")
-- .arg(QString::number(rad, 'f', 5))
-- .arg(rdms)
-- .arg(edms)
-+ .arg(QString::number(rad, 'f', 5), rdms, edms)
- .arg(decimalF)
- .arg(useDF)));
- }
diff --git a/sci-astronomy/stellarium/files/stellarium-0.22.1-unbundle-qtcompress.patch b/sci-astronomy/stellarium/files/stellarium-0.22.1-unbundle-qtcompress.patch
deleted file mode 100644
index 41721046ed03..000000000000
--- a/sci-astronomy/stellarium/files/stellarium-0.22.1-unbundle-qtcompress.patch
+++ /dev/null
@@ -1,208 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -614,6 +614,8 @@ ELSE(ENABLE_GPS)
- MESSAGE(STATUS "GPS: disabled.")
- ENDIF(ENABLE_GPS)
-
-+find_package(Qt5Compress REQUIRED)
-+
- IF(USE_QTOPENGL)
- # QtOpenGL module is deprecated. After merging the QOpenGLWidget branch, we don't use this module directly anymore,
- # but the QtMultimediaWidgets module requires it internally, so we still have to package it.
---- a/plugins/Satellites/src/CMakeLists.txt
-+++ b/plugins/Satellites/src/CMakeLists.txt
-@@ -55,7 +55,7 @@ IF(ENABLE_TESTING)
- ENDIF(ENABLE_TESTING)
-
- ADD_LIBRARY(Satellites-static STATIC ${Satellites_SRCS} ${Satellites_RES_CXX} ${SatellitesDialog_UIS_H})
--TARGET_LINK_LIBRARIES(Satellites-static Qt5::Core Qt5::Network Qt5::Widgets)
-+TARGET_LINK_LIBRARIES(Satellites-static Qt5::Core Qt5::Network Qt5::Widgets Qt5::Compress)
- # The library target "Satellites-static" has a default OUTPUT_NAME of "Satellites-static", so change it.
- SET_TARGET_PROPERTIES(Satellites-static PROPERTIES OUTPUT_NAME "Satellites")
- IF(MSVC)
---- a/plugins/Satellites/src/Satellites.cpp
-+++ b/plugins/Satellites/src/Satellites.cpp
-@@ -43,7 +43,7 @@
- #include "StelUtils.hpp"
- #include "StelActionMgr.hpp"
-
--#include "external/qtcompress/qzipreader.h"
-+#include "qzipreader.h"
-
- #include <QNetworkAccessManager>
- #include <QNetworkReply>
-@@ -1639,12 +1639,12 @@ void Satellites::saveDownloadedUpdate(QNetworkReply* reply)
- QString archive = zip.fileName();
- QByteArray data;
-
-- Stel::QZipReader reader(archive);
-- if (reader.status() != Stel::QZipReader::NoError)
-+ QZipReader reader(archive);
-+ if (reader.status() != QZipReader::NoError)
- qWarning() << "[Satellites] Unable to open as a ZIP archive";
- else
- {
-- QList<Stel::QZipReader::FileInfo> infoList = reader.fileInfoList();
-+ QList<QZipReader::FileInfo> infoList = reader.fileInfoList();
- for (const auto& info : qAsConst(infoList))
- {
- // qWarning() << "[Satellites] Processing:" << info.filePath;
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -479,7 +479,7 @@ IF(ENABLE_SPOUT AND SPOUT_LIBRARY_DLL)
- CONFIGURE_FILE(${SPOUT_LIBRARY_DLL} ${CMAKE_CURRENT_BINARY_DIR} COPYONLY)
- ENDIF()
-
--SET(STELMAIN_DEPS ${ZLIB_LIBRARIES} qtcompress_stel glues_stel qcustomplot_stel qxlsx_stel ${STELLARIUM_STATIC_PLUGINS_LIBRARIES} ${STELLARIUM_QT_LIBRARIES} ${SPOUT_LIBRARY})
-+SET(STELMAIN_DEPS ${ZLIB_LIBRARIES} Qt5::Compress glues_stel qcustomplot_stel qxlsx_stel ${STELLARIUM_STATIC_PLUGINS_LIBRARIES} ${STELLARIUM_QT_LIBRARIES} ${SPOUT_LIBRARY})
- IF(ENABLE_LIBGPS)
- SET(STELMAIN_DEPS ${STELMAIN_DEPS} ${GPS_LIBRARY})
- ENDIF()
---- a/src/core/modules/LandscapeMgr.cpp
-+++ b/src/core/modules/LandscapeMgr.cpp
-@@ -1331,8 +1331,8 @@ QString LandscapeMgr::installLandscapeFromArchive(QString sourceFilePath, const
- }
- QDir destinationDir (parentDestinationDir.absoluteFilePath("landscapes"));
-
-- Stel::QZipReader reader(sourceFilePath);
-- if (reader.status() != Stel::QZipReader::NoError)
-+ QZipReader reader(sourceFilePath);
-+ if (reader.status() != QZipReader::NoError)
- {
- qWarning() << "LandscapeMgr: Unable to open as a ZIP archive:" << QDir::toNativeSeparators(sourceFilePath);
- emit errorNotArchive();
-@@ -1341,7 +1341,7 @@ QString LandscapeMgr::installLandscapeFromArchive(QString sourceFilePath, const
-
- //Detect top directory
- QString topDir, iniPath;
-- const QList<Stel::QZipReader::FileInfo> infoList = reader.fileInfoList();
-+ const QList<QZipReader::FileInfo> infoList = reader.fileInfoList();
- for (const auto& info : infoList)
- {
- QFileInfo fileInfo(info.filePath);
---- a/src/external/CMakeLists.txt
-+++ b/src/external/CMakeLists.txt
-@@ -70,6 +70,7 @@ target_include_directories(zlib_stel PUBLIC zlib)
- set_target_properties(zlib_stel PROPERTIES AUTOMOC 0)
- SET_TARGET_PROPERTIES(zlib_stel PROPERTIES FOLDER "src/external")
-
-+if(0)
- set(qtcompress_SRCS
- qtcompress/qzip.cpp
- qtcompress/qzipreader.h
-@@ -82,6 +83,7 @@ target_link_libraries(qtcompress_stel ${ZLIB_LIBRARIES} Qt5::Core)
- #turn off automoc, not needed here
- set_target_properties(qtcompress_stel PROPERTIES AUTOMOC 0)
- SET_TARGET_PROPERTIES(qtcompress_stel PROPERTIES FOLDER "src/external")
-+endif()
-
- # QCustomPlot should not be unbundled, because upstream uses GPL 3, and
- # Stellarium uses GPL 2. Author of QCustomPlot has agreed for GPL 2+ for this.
-@@ -180,7 +182,7 @@ SET(qxlsx_SRCS
- qxlsx/xlsxcelllocation.h
- )
- add_library(qxlsx_stel STATIC EXCLUDE_FROM_ALL ${qxlsx_SRCS})
--target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui qtcompress_stel)
-+target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui Qt5::Compress)
- set_target_properties(qxlsx_stel PROPERTIES FOLDER "src/external")
-
- ################################# INDI ################################
---- a/src/external/qxlsx/xlsxzipreader.cpp
-+++ b/src/external/qxlsx/xlsxzipreader.cpp
-@@ -5,13 +5,13 @@
- QT_BEGIN_NAMESPACE_XLSX
-
- ZipReader::ZipReader(const QString &filePath) :
-- m_reader(new Stel::QZipReader(filePath))
-+ m_reader(new QZipReader(filePath))
- {
- init();
- }
-
- ZipReader::ZipReader(QIODevice *device) :
-- m_reader(new Stel::QZipReader(device))
-+ m_reader(new QZipReader(device))
- {
- init();
- }
-@@ -23,8 +23,8 @@ ZipReader::~ZipReader()
-
- void ZipReader::init()
- {
-- QList<Stel::QZipReader::FileInfo> allFiles = m_reader->fileInfoList();
-- for (const Stel::QZipReader::FileInfo &fi : allFiles) {
-+ QList<QZipReader::FileInfo> allFiles = m_reader->fileInfoList();
-+ for (const QZipReader::FileInfo &fi : allFiles) {
- if (fi.isFile || (!fi.isDir && !fi.isFile && !fi.isSymLink))
- m_filePaths.append(fi.filePath);
- }
---- a/src/external/qxlsx/xlsxzipreader_p.h
-+++ b/src/external/qxlsx/xlsxzipreader_p.h
-@@ -8,7 +8,7 @@
- #include <QIODevice>
-
- #include "xlsxglobal.h"
--#include "external/qtcompress/qzipreader.h"
-+#include "qzipreader.h"
-
- #if QT_VERSION >= 0x050600
- #include <QVector>
-@@ -31,7 +31,7 @@ public:
- private:
- Q_DISABLE_COPY(ZipReader)
- void init();
-- QScopedPointer<Stel::QZipReader> m_reader;
-+ QScopedPointer<QZipReader> m_reader;
- QStringList m_filePaths;
- };
-
---- a/src/external/qxlsx/xlsxzipwriter.cpp
-+++ b/src/external/qxlsx/xlsxzipwriter.cpp
-@@ -10,14 +10,14 @@ QT_BEGIN_NAMESPACE_XLSX
-
- ZipWriter::ZipWriter(const QString &filePath)
- {
-- m_writer = new Stel::QZipWriter(filePath, QIODevice::WriteOnly);
-- m_writer->setCompressionPolicy(Stel::QZipWriter::AutoCompress);
-+ m_writer = new QZipWriter(filePath, QIODevice::WriteOnly);
-+ m_writer->setCompressionPolicy(QZipWriter::AutoCompress);
- }
-
- ZipWriter::ZipWriter(QIODevice *device)
- {
-- m_writer = new Stel::QZipWriter(device);
-- m_writer->setCompressionPolicy(Stel::QZipWriter::AutoCompress);
-+ m_writer = new QZipWriter(device);
-+ m_writer->setCompressionPolicy(QZipWriter::AutoCompress);
- }
-
- ZipWriter::~ZipWriter()
-@@ -27,7 +27,7 @@ ZipWriter::~ZipWriter()
-
- bool ZipWriter::error() const
- {
-- return m_writer->status() != Stel::QZipWriter::NoError;
-+ return m_writer->status() != QZipWriter::NoError;
- }
-
- void ZipWriter::addFile(const QString &filePath, QIODevice *device)
---- a/src/external/qxlsx/xlsxzipwriter_p.h
-+++ b/src/external/qxlsx/xlsxzipwriter_p.h
-@@ -8,7 +8,7 @@
- #include <QIODevice>
-
- #include "xlsxglobal.h"
--#include "external/qtcompress/qzipwriter.h"
-+#include "qzipwriter.h"
-
- class QZipWriter;
-
-@@ -27,7 +27,7 @@ public:
- void close();
-
- private:
-- Stel::QZipWriter *m_writer;
-+ QZipWriter *m_writer;
- };
-
- QT_END_NAMESPACE_XLSX