summaryrefslogtreecommitdiff
path: root/sci-astronomy/pyephem
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /sci-astronomy/pyephem
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'sci-astronomy/pyephem')
-rw-r--r--sci-astronomy/pyephem/Manifest2
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.7.1.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-astronomy/pyephem/Manifest b/sci-astronomy/pyephem/Manifest
index fb5cf5e8317c..92a284b74358 100644
--- a/sci-astronomy/pyephem/Manifest
+++ b/sci-astronomy/pyephem/Manifest
@@ -1,3 +1,5 @@
DIST pyephem-3.7.6.0.tar.gz 739561 BLAKE2B a8129632514940e6d786dcc50d2dd0bd1fff2b76b9d59f88820c93cce3400f9b15c4f7418bc778ee5ad60a8909a970aaea5df62c5192fcb71f822b97abc0dc4f SHA512 c3013ef943c0e1e2c30bba6f72912efb100b4c8c45904b7d6d7ba73d8b741564793a6e538117eb88abb824c93c874e2c955de734418ebd2370888718a149c9a8
+DIST pyephem-3.7.7.1.tar.gz 1622306 BLAKE2B aefdd7b7e4471140f1c2b5c065f663dfb1095d8d8325e23d4b5b9c683ff7a91020151429a992ad78be897ab738d9bc207afa337b7806fb244d6d6c8a1c680b7f SHA512 ae0d9562f33ee25065b33ea3d4b24a74e32259bebb07edf37deacaa77e6d24b3a7a49e4602393b45a3c7cfc7d8088f038e68e96ec3576a796b5486fc2946ac5a
EBUILD pyephem-3.7.6.0-r1.ebuild 1027 BLAKE2B 8fb798eeafdad0a010ca277dd9af71a9c8110d45f536ad8e58ee11e0665b4906c5923cc80bc83734fbfead7bd38b40f41cda3afe103f1d95694e6ec6c22d17e4 SHA512 627d88cdba0ac29680eb72b5538d12f88d7b121ede7802e3cca7ff805ed48255cb0344ea6694bc4d8d7acc484ade25d571f901eadb2e900250fda31adc8bce7a
+EBUILD pyephem-3.7.7.1.ebuild 1069 BLAKE2B b6dc6ca165f57ffc39dbfd431c0d3fad50c816514d2be590b9e16d85d8aa92cd90d6e21a14829a5c12a381f295474372cbb062a238906f98361a117eb053881b SHA512 5731f4bb16f10bb202da13a2ae62af31ee30fe88198ade5b87c7281717a1ae873e3acc365697e06c2c73ed01213478673a9f5f9d7f3327c20ab422703ba29160
MISC metadata.xml 947 BLAKE2B 0e586f2e978bb31b9ca757d2192a41e5a6e3414c7c29ceabddfb0ace9c9eb31ade32424701a9370665d69dd7cbeba567cdc9288cada621eb1d66b5a8a680c36d SHA512 f41c27b07f211b09dd72e316d02c46206dea0ff368e2ad1a8d116df49a2ce2a74137b2647572e295bcde34792d4ee15fb2d3f9e1a883c6cb306f6ef2a43d5c53
diff --git a/sci-astronomy/pyephem/pyephem-3.7.7.1.ebuild b/sci-astronomy/pyephem/pyephem-3.7.7.1.ebuild
new file mode 100644
index 000000000000..4bd9bd962eea
--- /dev/null
+++ b/sci-astronomy/pyephem/pyephem-3.7.7.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Astronomical routines for the python programming language"
+HOMEPAGE="https://rhodesmill.org/pyephem/"
+SRC_URI="https://github.com/brandon-rhodes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ # Don't install rst files by dfefault
+ sed -i -e "s:'doc/\*\.rst',::" setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc; then
+ PYTHONPATH=. emake -C ephem/doc html
+ fi
+}
+
+python_test() {
+ PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" unit2 discover -s ephem
+}
+
+src_install() {
+ use doc && HTML_DOCS=( ephem/doc/_build/html/. )
+ distutils-r1_src_install
+
+ delete_tests() {
+ rm -r "${D}$(python_get_sitedir)/ephem/tests" || die
+ }
+ python_foreach_impl delete_tests
+}