summaryrefslogtreecommitdiff
path: root/sci-astronomy/pyephem
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-astronomy/pyephem
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-astronomy/pyephem')
-rw-r--r--sci-astronomy/pyephem/Manifest2
-rw-r--r--sci-astronomy/pyephem/pyephem-4.1.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sci-astronomy/pyephem/Manifest b/sci-astronomy/pyephem/Manifest
index d95d9ce340ca..8faf72b402cb 100644
--- a/sci-astronomy/pyephem/Manifest
+++ b/sci-astronomy/pyephem/Manifest
@@ -1,3 +1,5 @@
DIST pyephem-3.7.7.1.tar.gz 1622306 BLAKE2B aefdd7b7e4471140f1c2b5c065f663dfb1095d8d8325e23d4b5b9c683ff7a91020151429a992ad78be897ab738d9bc207afa337b7806fb244d6d6c8a1c680b7f SHA512 ae0d9562f33ee25065b33ea3d4b24a74e32259bebb07edf37deacaa77e6d24b3a7a49e4602393b45a3c7cfc7d8088f038e68e96ec3576a796b5486fc2946ac5a
+DIST pyephem-4.1.1.gh.tar.gz 2659977 BLAKE2B e373857d3fb66e742f9db992165dbd1d50afbb6b91588f2cfcd299409d491ef1174c54a182dd59b5a8e298a07312899c8f8b5a8aaa63e6b31deb5f8b1cd3131e SHA512 2539f36b7110cacd6cf95e9ba0be26ca837a66ba81f092d4be01405029adf22478184861f46ecf09d6cd35927140874e0f0d228b06537d05f3e2eddbcb35da85
EBUILD pyephem-3.7.7.1.ebuild 1067 BLAKE2B 45c390e9a9e361bc8c817b83c07b240c1706a182e47f3455f75cf0e6559207c6d177cd170f902c08c287df40308df7fe73ca666b5c802a192549673b46f164c2 SHA512 d4555ab691276a8e5557f34ad36f0fdc541b4029e89a1be166730dc7987fe1cf3644fea30d182d19067b2d19bff56032457d16981921307bd4583d4f2443f324
+EBUILD pyephem-4.1.1.ebuild 1075 BLAKE2B 3b522a577ae1e8346259e8cfcaa49fab5781a94c9a642713c9a9e864a9f8812329265c94edc914b0e421562eec27da2cf5708b76b7770450632a54b6937b097b SHA512 767a093155f3b4253e6a0cca525780f4c9a5b8c7ad835eede3b9dc8a08d16efb2aecbbf703fc4a91431c2f42da4595563e5ab8a7ed049cd8092f250305835f43
MISC metadata.xml 948 BLAKE2B f59f025e5ef3d44d0d7b53a82cbbe217b16a1fcf8ffad27e8c00a7faf705aa9d61434b0bc732bdb8b13917ea68532584809aac031f6884252c456fe025d3b07e SHA512 7f0a1edc80a06ac1ef41a18adfa0237700b4b2aef1d8ca48c51242ff8b2ef0d4bc983b7a2419d5f6033fdbaf5a7d8e3a53b57e40b315b8e1a5717572c2811c24
diff --git a/sci-astronomy/pyephem/pyephem-4.1.1.ebuild b/sci-astronomy/pyephem/pyephem-4.1.1.ebuild
new file mode 100644
index 000000000000..2e6565b7f7e9
--- /dev/null
+++ b/sci-astronomy/pyephem/pyephem-4.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Astronomical routines for the Python programming language"
+HOMEPAGE="https://rhodesmill.org/pyephem/"
+SRC_URI="https://github.com/brandon-rhodes/pyephem/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="doc? ( dev-python/sphinx )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Don't install rst files by default
+ sed -i -e "s:'doc/\*\.rst',::" setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc; then
+ PYTHONPATH=. emake -C ephem/doc html
+ fi
+}
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs ephem
+}
+
+src_install() {
+ use doc && HTML_DOCS=( ephem/doc/_build/html/. )
+ distutils-r1_src_install
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ rm -r "${D}$(python_get_sitedir)/ephem/tests" || die
+}