summaryrefslogtreecommitdiff
path: root/sci-astronomy/predict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /sci-astronomy/predict
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'sci-astronomy/predict')
-rw-r--r--sci-astronomy/predict/Manifest2
-rw-r--r--sci-astronomy/predict/predict-2.2.3-r2.ebuild12
2 files changed, 8 insertions, 6 deletions
diff --git a/sci-astronomy/predict/Manifest b/sci-astronomy/predict/Manifest
index fc9de48c89ca..100683129f78 100644
--- a/sci-astronomy/predict/Manifest
+++ b/sci-astronomy/predict/Manifest
@@ -2,5 +2,5 @@ AUX predict-2.2.3-earthtrack.patch 1175 BLAKE2B 17e1327695b12321abce6cb01e821141
AUX predict-update 4039 BLAKE2B 856aea796dcd612d17cdcc8d9aa7015e59faaa42a66caf42bd01c3e51c4193119208eb2c9015d215a014e2c08511c6ebbd13b78d4a4a0f86b7b133e4363d0ed2 SHA512 8bcc89babe25f44ca985776b994265a12be8e3d6390e4301594f7a8d1402d7d42aa66f6ae1ab6f51c2d8d910d9f012920382928c0238fce4e1707cb8843a739a
DIST predict_2.2.3-3.1.diff.gz 78624 BLAKE2B c80ffcf2b624a36e919d0f659c4cb46dbb4d00c83dd7c0e900d052a7258be92a4435a8de7ff319d16169373eab1061bed61a2311c5344eb5fc2f43183c0b8b46 SHA512 9fe2e3ffd931be7ab85f10db4cd35a2091a459c3fd0c48e9ecf8a4482c20400c267b38d31f72d28270d50b7305bc49418fefe35ff013ac9be1627d853205bd5f
DIST predict_2.2.3.orig.tar.gz 1444530 BLAKE2B 0bcca42aa0b7294d5276d5f9db2e321b1d47afdcb5194eeeb90d6912bd6f38c02a21036638febc45a72e304b9ae4737840f6ee3f4550eccf557e830272ef3956 SHA512 260f7f4dbc72cca4b0b5f7bc9dcf612b8a7e3ef12ab6f34afa3c06b1ac24427435af1c4bae9d39e7cbcdff6cccad72e3235dd191605464642f014207651d8c11
-EBUILD predict-2.2.3-r2.ebuild 5683 BLAKE2B 8bcff5670e63eff9873df322793a6dd2ac47d9b4ffd50c4670ba296eda5124b68adc538e9bb8abeda3fd65306228edafaa390fa3885a35c363bff174481495d0 SHA512 e065d462ab30032f694861906726007f50fc1ed40a602c493aacbac1c35b5f7b0920a572cc99352a0db31831403743b4b430b4a4cbfc71d05d520f12605fbf39
+EBUILD predict-2.2.3-r2.ebuild 5722 BLAKE2B 6f36c4c25a2f5ec74c4e667a170430faa2c994fd30c3662135ed1a7f38978caaac858fc1718ff13d98aedf074ec8650544adb47d549ef7201a8589d2262c45c6 SHA512 40150061ddae17c0d08f0ee61ed18489574fad5dd16dc1fbb224e5a31466b5d81596390a87643c8921eb67cfa0786345f2052420aa8394813e88395dcb3d642e
MISC metadata.xml 836 BLAKE2B 2e0a9b729afaa130e43c2f0375c7bef313cf061b454a1d8f8a1acb3662b9ed364f0af9ff81b0f96400c77ec21042af1e7d745385f0317355f3dd1ac4894fe033 SHA512 7e67a924a0b385cb051848bd1dd73d6a93ae60d13a10db785e96ead08df289137f06c67f17d519055b85aa228c1eca79db6da97494a532759c7c06c95e9c51d8
diff --git a/sci-astronomy/predict/predict-2.2.3-r2.ebuild b/sci-astronomy/predict/predict-2.2.3-r2.ebuild
index df1044cfeb9e..a56e5e83ba46 100644
--- a/sci-astronomy/predict/predict-2.2.3-r2.ebuild
+++ b/sci-astronomy/predict/predict-2.2.3-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
-DEB_P=${PN}_${PV}
+DEB_P="${PN}_${PV}"
DEB_PR=3.1
DESCRIPTION="Satellite tracking and orbital prediction"
@@ -18,14 +18,15 @@ SLOT="0"
IUSE="doc gtk nls xforms xplanet"
KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
-RDEPEND="sys-libs/ncurses:0=
+RDEPEND="
+ sys-libs/ncurses:0=
gtk? ( x11-libs/gtk+:2 )
xforms? ( x11-libs/xforms )
xplanet? ( x11-misc/xplanet[truetype] )"
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/"${P}"-earthtrack.patch
+ "${FILESDIR}"/${P}-earthtrack.patch
"${WORKDIR}"/${DEB_P}-${DEB_PR}.diff
)
@@ -74,6 +75,7 @@ AC_SEARCH_LIBS([dlclose], [dl])' \
}
src_configure() {
+ append-cflags -fcommon
if use gtk; then
cd "${S}"/clients/gsat-* || die
econf $(use_enable nls)