summaryrefslogtreecommitdiff
path: root/sci-astronomy/montage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-astronomy/montage
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-astronomy/montage')
-rw-r--r--sci-astronomy/montage/Manifest2
-rw-r--r--sci-astronomy/montage/montage-5.0.ebuild15
2 files changed, 9 insertions, 8 deletions
diff --git a/sci-astronomy/montage/Manifest b/sci-astronomy/montage/Manifest
index 4d6f39801eae..c8f17eb6314e 100644
--- a/sci-astronomy/montage/Manifest
+++ b/sci-astronomy/montage/Manifest
@@ -2,5 +2,5 @@ AUX montage-4.1-fix_format_errors.patch 705 BLAKE2B 8eed539374451d5124adb3d32ca9
AUX montage-4.1-initdistdata.patch 619 BLAKE2B 62093c780263c8b70f2df0de459c8a6b420d187ea9921b4ffc84435fbffb4f6de100a926ce56a5f2cf7897e2a6c9f93ef9bbffb2b5f6bfcaffcf317d6bf0d2da SHA512 6b4b195f804fb16dd3acdfb53288800ac07af9b05749ad8e8305fe415488e921a65ffb6ce19632da420dea6235eb3ed28826a437a8b7ad22869065a916422ea5
AUX montage-5.0-fix_freetype_incude.patch 1164 BLAKE2B 94d791eb684d9a6a725a90b9361f1ef29d6654c59bfe4b0620a1af4412a49ade15fae9f6e0ff5b63134574e73a7ff75190f40df4bc3883cfc6e9c286e9d63573 SHA512 1ca955f06765fc90164190a090ec177a06c9cb359fe93b43b8553af06b8eb4a06c8d2685d76fbee0fc70dad525a184b9a4dfde8acef4f4d9703610fb69b73ad5
DIST Montage_v5.0.tar.gz 14663443 BLAKE2B b7dea04a0b9650b3e32bc425891c1221d60123c29663013b4af860efc238dee7552a2b55514ad7eda3be659873e3f14d2039b2e6eea20f565d64c7b8bd055069 SHA512 1396c7f846db4844d2e861622d152f2115ad4c684da02bb14116dfe3d01b559feaf29572663d0dfd234aa50843afaca3bb072d9127fbb2b539a14327c48499ae
-EBUILD montage-5.0.ebuild 1579 BLAKE2B d8b259012ec97de6a64ce368e064f5b3413d701c5c38ce0e8c77cb2da9c375dc44afd2e1e19514f9af0f6a3fda9b13d63dbb68ef7077c593ff471a443fdae7b0 SHA512 5a5db36e9a6585950a1426eb8e56648cb37c0188d2f2c42f0008f51875e49b18c174a3627da0691abcfc2c91d253bc556bcffad287cedcf73d8c3b1fe5cf06ba
+EBUILD montage-5.0.ebuild 1623 BLAKE2B 18c348121c787bb243803bea91c25427d53696f8369cd30c43f07ffd6f3d9ff2a65e2a29595b84813064686a756e0adffe4ffc9fca6efde1b8b032dbb27a384f SHA512 7152e777abf35c575737cc51a5e59990618a591cda95ad75bf2e8bdc671b8661ce50d74c0f12b091b3e78e8a77b18ccb882ccf1da330c1d047a7bab1b34261d5
MISC metadata.xml 1031 BLAKE2B 18029f74d04a1668a4bc23bc7053c77ebd5abda4b033bf8e827209e772e59fe49124ad99f5e9b7d7b0be30dd8504e3b61913a3224d0b61a5ea9d766571e00f96 SHA512 b14dfef57d629cce61fda07b98a6dd375f2827d93da714bbd4eb359650d44b726c1cf3d6af181e280b913a8a80ee4a24c6e4e6b83a3219a59400a1257e517b53
diff --git a/sci-astronomy/montage/montage-5.0.ebuild b/sci-astronomy/montage/montage-5.0.ebuild
index d426c00c3c12..850a2ff98dc4 100644
--- a/sci-astronomy/montage/montage-5.0.ebuild
+++ b/sci-astronomy/montage/montage-5.0.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs flag-o-matic
MYPN=Montage
-
DESCRIPTION="Toolkit for assembling FITS images into mosaics"
HOMEPAGE="http://montage.ipac.caltech.edu/"
SRC_URI="http://montage.ipac.caltech.edu/download/${MYPN}_v${PV}.tar.gz"
+S="${WORKDIR}/${MYPN}"
LICENSE="BSD GPL-2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
-
IUSE="doc mpi"
RDEPEND="
@@ -31,10 +30,9 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.0-fix_freetype_incude.patch
)
-S="${WORKDIR}/${MYPN}"
-
src_prepare() {
default
+
sed -e '/cfitsio/d' \
-e '/wcssubs/d' \
-e '/jpeg/d' \
@@ -43,6 +41,9 @@ src_prepare() {
tc-export CC AR
+ # bug #708396
+ append-cflags -fcommon
+
find . -name Makefile\* | xargs sed -i \
-e "/^CC.*=/s:\(gcc\|cc\):$(tc-getCC):g" \
-e "/^CFLAGS.*=/s:-g:${CFLAGS} $($(tc-getPKG_CONFIG) --cflags wcstools):g" \