summaryrefslogtreecommitdiff
path: root/sci-astronomy/gnuastro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-astronomy/gnuastro
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-astronomy/gnuastro')
-rw-r--r--sci-astronomy/gnuastro/Manifest2
-rw-r--r--sci-astronomy/gnuastro/gnuastro-0.16.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-astronomy/gnuastro/Manifest b/sci-astronomy/gnuastro/Manifest
index 5ee440dcc6f8..3fdbc6cf76f3 100644
--- a/sci-astronomy/gnuastro/Manifest
+++ b/sci-astronomy/gnuastro/Manifest
@@ -1,3 +1,5 @@
+DIST gnuastro-0.16.tar.gz 6089988 BLAKE2B be85152e6638a3462cf00555748a6be8d8c9d30b7c43332f1a16140bd22af2d7e948e1e089045b51b22db1541645dc82668cf2cb8c73abf3b07418343f1c02d9 SHA512 8848528b1a117aaebed854db2e8e4586d3b3f860f25f07a1362b7cd1ffd4f0f7ef214fc0b91b3bfc4aaf1ba9c8bbeaf9dec82979665db1c6fe3703f39354a867
DIST gnuastro-0.3.tar.gz 4525361 BLAKE2B 432078bf330fc8e6886246e4aec767c86b9c19c0c438a3c37b1912e3433e82c68db1090351b0e2e8e4fbb8a7906aa3ac031db8abd5e8c15380e1e8c349b9ebe5 SHA512 08556fd0de196c331cfd68e4b385fbef5c130fa9c914889367f4e3637b8dc6270a2424ef92c6641ec803c355d0577cebf3ace5ad76a7024f0414bb516338beac
+EBUILD gnuastro-0.16.ebuild 971 BLAKE2B f794a4b527e64bcf8f7ec6d8abf4a25f9a52ac56e49f02f5ea98bfa07b20c0924d1a40115a9b7796037d1e64744312a815c2b31fd463eb86e2c7177c5d35c1f1 SHA512 8217f6e40c27cad7b1899c3f14951106867588fefbb597a4fcf4d4868972c672265a282ef8658693d7ddbf79edc702b72c70ad95fda8badbbe7f65f3789f2a2b
EBUILD gnuastro-0.3.ebuild 949 BLAKE2B 8f71ad2a919b593733eefe87e5b0a45db1ccdb6f3da396ebdd679c91af9d686c79a47601aa278fa30569f979ac97311eeff075b1eb57025e6a8b04a9fa0c144e SHA512 bb517dad64778f4a94f64d5aa505cf4d48b2af727044318865f6101434bcb6536e3fce61cdc8a6c2933220d0f73b60cac49ffd8d0fb920a82534db83a67a072b
MISC metadata.xml 989 BLAKE2B 83d339b77fe4307a2eafa2976c0524c15f1d234ed812d1a20eb1ee8f102248afc554126ea7d201360fe88e1191a15311505544058ea27522750e66981accd003 SHA512 b1162526b9c8e4d19d0c30f0ce7b3cfbb7cbf2888063416fedfc7d9335a364599557f02657491b135640e4cc10b43529e595cc7d18a8553cda8b212d491dedd6
diff --git a/sci-astronomy/gnuastro/gnuastro-0.16.ebuild b/sci-astronomy/gnuastro/gnuastro-0.16.ebuild
new file mode 100644
index 000000000000..ca9adb3bb97c
--- /dev/null
+++ b/sci-astronomy/gnuastro/gnuastro-0.16.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="GNU Astronomy Utilities"
+HOMEPAGE="https://www.gnu.org/software/gnuastro"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="static-libs threads"
+
+# jpeg, pdf, and libgit2 are forced deps
+# because they are automagically detected.
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ dev-libs/libgit2:=
+ media-libs/tiff
+ net-misc/curl
+ sci-astronomy/wcslib:0=
+ sci-libs/cfitsio:0=
+ sci-libs/gsl:0=
+ sys-libs/zlib:=
+ virtual/jpeg:0=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e 's/-O3//' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ )
+ econf ${myeconfargs[@]}
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}