summaryrefslogtreecommitdiff
path: root/sci-astronomy/celestia/celestia-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-15 13:19:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-15 13:19:56 +0100
commitd302a5d7fc9caafba5c8a404f2891bb6ccdec311 (patch)
tree2a3ee43f080d1d0086964de8c29ccf1021fdfda7 /sci-astronomy/celestia/celestia-9999.ebuild
parentea31ad0ed5501d0bf92267c35beaf06ac016bad2 (diff)
gentoo resync : 15.05.2018
Diffstat (limited to 'sci-astronomy/celestia/celestia-9999.ebuild')
-rw-r--r--sci-astronomy/celestia/celestia-9999.ebuild73
1 files changed, 15 insertions, 58 deletions
diff --git a/sci-astronomy/celestia/celestia-9999.ebuild b/sci-astronomy/celestia/celestia-9999.ebuild
index afec84fc2292..23ad6bc99f7c 100644
--- a/sci-astronomy/celestia/celestia-9999.ebuild
+++ b/sci-astronomy/celestia/celestia-9999.ebuild
@@ -3,15 +3,13 @@
EAPI=6
-inherit autotools flag-o-matic gnome2 xdg-utils
+inherit autotools flag-o-matic xdg-utils
DESCRIPTION="OpenGL 3D space simulator"
HOMEPAGE="https://celestia.space"
if [[ "${PV}" = 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/CelestiaProject/Celestia.git"
- # Necessary because of gnome2 eclass
- SRC_URI=""
else
# Old URI! Please update once we have a release > v1.6.1
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -20,7 +18,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="cairo gnome gtk nls pch theora threads"
+IUSE="cairo gtk nls pch theora threads"
RDEPEND="
virtual/opengl
@@ -31,56 +29,31 @@ RDEPEND="
x11-libs/gtk+:2
>=x11-libs/gtkglext-1.0
)
- gnome? (
- >=gnome-base/libgnomeui-2.0
- )
- !gtk? ( !gnome? ( media-libs/freeglut ) )
+ !gtk? ( media-libs/freeglut )
cairo? ( x11-libs/cairo )
theora? ( media-libs/libtheora )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-REQUIRED_USE="gnome? ( gtk )"
-
PATCHES=(
# make better desktop files
"${FILESDIR}"/${PN}-1.5.0-desktop.patch
# add a ~/.celestia for extra directories
"${FILESDIR}"/${PN}-1.6.99-cfg.patch
- # missing zlib.h include with libpng15
- "${FILESDIR}"/${PN}-1.6.1-libpng15.patch
- "${FILESDIR}"/${PN}-1.6.99-linking.patch
-
- # gcc-47, #414015
- "${FILESDIR}"/${PN}-1.6.99-gcc47.patch
-
- # libpng16 #464764
- "${FILESDIR}"/${PN}-1.6.1-libpng16.patch
- # Patches from upstream PRs
-
- # https://github.com/CelestiaProject/Celestia/pull/35
- #"${FILESDIR}/${PN}-1.6.99-automake.patch"
- "${FILESDIR}/${PN}-1.6.99-models_makefile.patch"
- "${FILESDIR}/${PN}-1.6.99-default_source.patch"
- "${FILESDIR}/${PN}-1.6.99-symlink.patch"
-
- # https://github.com/CelestiaProject/Celestia/pull/37
- "${FILESDIR}/${PN}-1.6.99-compiler_warnings.patch"
+ # https://github.com/CelestiaProject/Celestia/pull/48
+ "${FILESDIR}"/${PN}-1.6.99-gtk_libs.patch
+ "${FILESDIR}"/${PN}-1.6.99-glew_linking.patch
)
pkg_setup() {
# Check for one for the following use flags to be set.
- if use gnome; then
- einfo "USE=\"gnome\" detected."
- USE_DESTDIR="1"
- CELESTIA_GUI="gnome"
- elif use gtk; then
+ if use gtk; then
einfo "USE=\"gtk\" detected."
CELESTIA_GUI="gtk"
else
- ewarn "If you want to use the full gui, set USE=\"{gnome|gtk}\""
+ ewarn "If you want to use the full gui, set USE=\"gtk\""
ewarn "Defaulting to glut support (no GUI)."
CELESTIA_GUI="glut"
fi
@@ -89,14 +62,8 @@ pkg_setup() {
src_prepare() {
default
- if [[ -f configure.in ]] ; then
- mv configure.{in,ac} || die
- else
- elog "configure.in file is gone. Clean up the ebuild!"
- fi
-
# remove flags to let the user decide
- local
+ local cf
for cf in -O2 -ffast-math \
-fexpensive-optimizations \
-fomit-frame-pointer; do
@@ -104,13 +71,6 @@ src_prepare() {
-e "s/${cf}//g" \
configure.ac admin/* || die "sed failed"
done
- # remove an unused gconf macro killing autoconf when no gnome
- # (not needed without eautoreconf)
- if ! use gnome; then
- sed -i \
- -e '/AM_GCONF_SOURCE_2/d' \
- configure.ac || die "sed failed"
- fi
eautoreconf
filter-flags "-funroll-loops -frerun-loop-opt"
@@ -136,15 +96,12 @@ src_configure() {
}
src_install() {
- if [[ ${CELESTIA_GUI} == gnome ]]; then
- gnome2_src_install
- else
- emake DESTDIR="${D}" MKDIR_P="mkdir -p" install
- local size
- for size in 16 22 32 48 ; do
- newicon "${S}"/src/celestia/kde/data/hi${size}-app-${PN}.png ${PN}.png
- done
- fi
+ emake DESTDIR="${D}" install
+ local size
+ for size in 16 22 32 48 ; do
+ newicon "${S}"/src/celestia/kde/data/hi${size}-app-${PN}.png ${PN}.png
+ done
+
[[ ${CELESTIA_GUI} == glut ]] && domenu celestia.desktop
dodoc AUTHORS README TRANSLATORS *.txt
}