summaryrefslogtreecommitdiff
path: root/sci-astronomy/celestia/celestia-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /sci-astronomy/celestia/celestia-9999.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'sci-astronomy/celestia/celestia-9999.ebuild')
-rw-r--r--sci-astronomy/celestia/celestia-9999.ebuild23
1 files changed, 7 insertions, 16 deletions
diff --git a/sci-astronomy/celestia/celestia-9999.ebuild b/sci-astronomy/celestia/celestia-9999.ebuild
index dd539877e827..44ee4d4b3d16 100644
--- a/sci-astronomy/celestia/celestia-9999.ebuild
+++ b/sci-astronomy/celestia/celestia-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -59,8 +59,6 @@ DEPEND="
RDEPEND="${DEPEND}"
PATCHES=(
- # make better desktop files
- "${FILESDIR}"/${PN}-1.5.0-desktop.patch
# add a ~/.celestia for extra directories
"${FILESDIR}"/${PN}-1.6.99-cfg.patch
# allow forcing CMake to look for a specific Lua version instead of the newest branch installed
@@ -88,7 +86,7 @@ src_configure() {
)
# Upstream always looks for LuaJIT first unless stopped, and we only need
# the version specification when linking against PUC Lua
- if use lua && ! use lua_single_target_luajit; then
+ if use lua && ! use lua_single_target_luajit ; then
mycmakeargs+=(
-DCMAKE_DISABLE_FIND_PACKAGE_LuaJIT=ON
-DLUA_VERSION=$(lua_get_version)
@@ -100,20 +98,13 @@ src_configure() {
src_install() {
cmake_src_install
- local size
- for size in 16 22 32 48 ; do
- newicon -s ${size} "${S}"/src/celestia/kde/data/hi${size}-app-${PN}.png ${PN}.png
- done
newicon -s 128 "${S}"/src/celestia/gtk/data/${PN}-logo.png ${PN}.png
doicon -s scalable "${S}"/src/celestia/gtk/data/${PN}.svg
- use glut && domenu ${PN}.desktop
- if use qt5 ; then
- sed \
- -e "/^Name/s@\$@ (qt5 interface)@" \
- -e "/^Exec/s@${PN}@${PN}-qt@" \
- ${PN}.desktop > "${T}"/${PN}-qt5.desktop || die
- domenu "${T}"/${PN}-qt5.desktop
- fi
+ local backend
+ for backend in glut qt5 ; do
+ use ${backend} && domenu debian/celestia-${backend/qt5/qt}.desktop
+ done
+
dodoc AUTHORS README TRANSLATORS *.txt
}