summaryrefslogtreecommitdiff
path: root/sci-astronomy/celestia/celestia-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /sci-astronomy/celestia/celestia-9999.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'sci-astronomy/celestia/celestia-9999.ebuild')
-rw-r--r--sci-astronomy/celestia/celestia-9999.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/sci-astronomy/celestia/celestia-9999.ebuild b/sci-astronomy/celestia/celestia-9999.ebuild
index 000dfa8ba2e2..b6b90597e450 100644
--- a/sci-astronomy/celestia/celestia-9999.ebuild
+++ b/sci-astronomy/celestia/celestia-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,34 +26,38 @@ HOMEPAGE="https://celestia.space"
LICENSE="GPL-2+"
SLOT="0"
-IUSE="glut lua nls +qt5 theora"
+IUSE="ffmpeg glut lua nls +qt5"
REQUIRED_USE="|| ( glut qt5 )
lua? ( ${LUA_REQUIRED_USE} )"
BDEPEND="
dev-cpp/eigen
virtual/pkgconfig
- nls? ( sys-devel/gettext )
+ nls? (
+ sys-devel/gettext
+ virtual/libintl
+ )
"
DEPEND="
dev-libs/libfmt:=
+ media-libs/freetype
media-libs/glew:0=
+ media-libs/libepoxy
+ media-libs/libglvnd
media-libs/libpng:0=
sys-libs/zlib:=
virtual/glu
virtual/jpeg:0
virtual/opengl
+ ffmpeg? ( media-video/ffmpeg )
glut? ( media-libs/freeglut )
lua? ( ${LUA_DEPS} )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtopengl:5
dev-qt/qtwidgets:5
)
- theora? (
- media-libs/libogg
- media-libs/libtheora
- )
"
RDEPEND="${DEPEND}"
@@ -81,7 +85,7 @@ src_configure() {
-DENABLE_GTK=OFF
-DENABLE_QT="$(usex qt5)"
-DENABLE_WIN=OFF
- -DENABLE_THEORA="$(usex theora)"
+ -DENABLE_FFMPEG="$(usex ffmpeg)"
)
# Upstream always looks for LuaJIT first unless stopped, and we only need
# the version specification when linking against PUC Lua