summaryrefslogtreecommitdiff
path: root/sci-astronomy/calcmysky
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-05 03:17:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-05 03:17:06 +0000
commita8b01fd62375e0df65d5f8f20c5ee142ec6739b6 (patch)
tree20346875d32349138564dc9fa82d43acd8d85da4 /sci-astronomy/calcmysky
parentf932718a139f93e19a6883c061f81b365a408592 (diff)
gentoo auto-resync : 05:11:2022 - 03:17:06
Diffstat (limited to 'sci-astronomy/calcmysky')
-rw-r--r--sci-astronomy/calcmysky/Manifest3
-rw-r--r--sci-astronomy/calcmysky/calcmysky-0.2.1.ebuild65
-rw-r--r--sci-astronomy/calcmysky/metadata.xml19
3 files changed, 87 insertions, 0 deletions
diff --git a/sci-astronomy/calcmysky/Manifest b/sci-astronomy/calcmysky/Manifest
new file mode 100644
index 000000000000..41084953bc2d
--- /dev/null
+++ b/sci-astronomy/calcmysky/Manifest
@@ -0,0 +1,3 @@
+DIST calcmysky-0.2.1.tar.gz 2161314 BLAKE2B b0aa1abc75f59c9c16429749bb8669e49e17e3dc7716bb78f472a9181c7d77a2c82c2f3800529f620604f233f88855908b0b55d824bf259d0912e157b9537faf SHA512 3915b965ee656b259ce7f158dfdd3c9c11a6c3ff907307899ae55e88ad6c1ccfbec8e0a1f784f5232fb0cb2c8300422fa25b8b1d4d11639d3ebb8c76d67059e5
+EBUILD calcmysky-0.2.1.ebuild 1193 BLAKE2B e12fb400bcf40d90fb612685b8eb6d7c257ca6e0140bb6159fd9c3ee7735701665be8667252c423cf67486e8eebb0c1ca8caee4cffb1a7afbab0f89eb0e2b1f8 SHA512 535c0a08f7ce74159dc19e8c47ebef10d92114dcc1578c54e5e718850218c8dcfdf1e8698745e0853ff83c37204432dfffdb539daccb90b35f1189f8a94e5ba8
+MISC metadata.xml 582 BLAKE2B dbfe97e6d7c27ec436cd080f0d9c7969f4a13a174db9637970dc19d9ca3c6387e3de1f97093fb8699e22f77927daa49e10709bfe14b91ade50e3d8bc449bfcb2 SHA512 ec397bf939ac6935284ae74ceca2cd253b9558d963ab627153cd5360bff6f506a8cfe53cbf49a38a59a71fd3013f25138c44d1034aed134f0d1995d021ad7408
diff --git a/sci-astronomy/calcmysky/calcmysky-0.2.1.ebuild b/sci-astronomy/calcmysky/calcmysky-0.2.1.ebuild
new file mode 100644
index 000000000000..47c8b4a34689
--- /dev/null
+++ b/sci-astronomy/calcmysky/calcmysky-0.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multibuild cmake
+
+DESCRIPTION="Simulator of light scattering by planetary atmospheres"
+HOMEPAGE="https://github.com/10110111/CalcMySky"
+SRC_URI="
+ https://github.com/10110111/CalcMySky/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3"
+# subslot is soversion
+SLOT="0/14"
+KEYWORDS="~amd64"
+
+IUSE="qt5 qt6"
+REQUIRED_USE="|| ( qt5 qt6 )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ media-libs/glm
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ qt6? (
+ dev-qt/qtbase:6[gui,opengl,widgets,-gles2-only]
+ )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/CalcMySky-${PV}"
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt5) $(usev qt6) )
+}
+
+src_configure() {
+ my_src_configure() {
+ local mycmakeargs=(
+ -DQT_VERSION="${MULTIBUILD_VARIANT/qt/}"
+ )
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_test() {
+ multibuild_foreach_variant cmake_build check
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+}
diff --git a/sci-astronomy/calcmysky/metadata.xml b/sci-astronomy/calcmysky/metadata.xml
new file mode 100644
index 000000000000..ef26156cdf6d
--- /dev/null
+++ b/sci-astronomy/calcmysky/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexey+gentoo@asokolov.org</email>
+ <name>Alexey Sokolov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">10110111/CalcMySky</remote-id>
+ </upstream>
+</pkgmetadata>