summaryrefslogtreecommitdiff
path: root/ros-meta/vision_visp/vision_visp-0.12.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /ros-meta/vision_visp/vision_visp-0.12.1.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'ros-meta/vision_visp/vision_visp-0.12.1.ebuild')
-rw-r--r--ros-meta/vision_visp/vision_visp-0.12.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/ros-meta/vision_visp/vision_visp-0.12.1.ebuild b/ros-meta/vision_visp/vision_visp-0.12.1.ebuild
new file mode 100644
index 000000000000..a820bd65f573
--- /dev/null
+++ b/ros-meta/vision_visp/vision_visp-0.12.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="noetic-"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Virtual package providing ViSP related packages"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/visp_auto_tracker
+ dev-ros/visp_bridge
+ dev-ros/visp_camera_calibration
+ dev-ros/visp_hand2eye_calibration
+ dev-ros/visp_tracker
+"
+DEPEND=""
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-noetic-${PV}/${ROS_SUBDIR}"
+fi