summaryrefslogtreecommitdiff
path: root/ros-meta/desktop/desktop-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /ros-meta/desktop/desktop-1.5.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'ros-meta/desktop/desktop-1.5.0.ebuild')
-rw-r--r--ros-meta/desktop/desktop-1.5.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/ros-meta/desktop/desktop-1.5.0.ebuild b/ros-meta/desktop/desktop-1.5.0.ebuild
new file mode 100644
index 000000000000..7d18ab59b224
--- /dev/null
+++ b/ros-meta/desktop/desktop-1.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage for a basic ROS desktop install"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ ros-meta/robot
+ ros-meta/viz
+ dev-ros/angles
+ ros-meta/common_tutorials
+ ros-meta/geometry_tutorials
+ dev-ros/joint_state_publisher_gui
+ ros-meta/ros_tutorials
+ dev-ros/roslint
+ dev-ros/urdf_tutorial
+ ros-meta/visualization_tutorials
+"
+DEPEND="${RDEPEND}"