summaryrefslogtreecommitdiff
path: root/perl-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 11:08:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 11:08:38 +0100
commit66d92fc8569d87a09ac014780528dcad2a12b6c6 (patch)
treec2add83cecf7705c1634a143fe36eebd8c7f2805 /perl-core
parentca517256fa4afe5b579e64e267ebbc7beb8a888f (diff)
gentoo auto-resync : 19:09:2023 - 11:08:38
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Manifest.gzbin2092 -> 2264 bytes
-rw-r--r--perl-core/Math-BigInt/Manifest3
-rw-r--r--perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild36
-rw-r--r--perl-core/Math-BigInt/metadata.xml16
4 files changed, 55 insertions, 0 deletions
diff --git a/perl-core/Manifest.gz b/perl-core/Manifest.gz
index 150a9b934834..75ea9ec1eff6 100644
--- a/perl-core/Manifest.gz
+++ b/perl-core/Manifest.gz
Binary files differ
diff --git a/perl-core/Math-BigInt/Manifest b/perl-core/Math-BigInt/Manifest
new file mode 100644
index 000000000000..0b14a4655006
--- /dev/null
+++ b/perl-core/Math-BigInt/Manifest
@@ -0,0 +1,3 @@
+DIST Math-BigInt-1.999838.tar.gz 2870131 BLAKE2B 749e0b04175070a571dd749c99b3558ce7bce442ee800eb227d952723bfd09b588c8ce6f3ddd2d2b71e8c89dbd2be80ac1272f9725a7bc435db77fa2f4ffac15 SHA512 33beb52f3e952d78e637336e61522416256029cdd106bab1a8b7d26a0b0f6aee16b779819b6922e99ccd3d67b14766ed661b2dec39dd9b31da4608df4fbe548f
+EBUILD Math-BigInt-1.999.838.ebuild 918 BLAKE2B f974f089daabfc0d3dcfd25e9121736ddb1d129013f95af46e1cf6439913007ad125ffe9667b82144a44970dd03694eef904d04c15b6bdf29761aea4b1978f37 SHA512 6c1d41c00ef3d9f5d8015ff1476ad8efa09ecd3a99d7b5f42175deb8d6d1c50d543441fde59b2c019f5a6656184ff844bfabbd7c8bfd08cce49941555e4e82ad
+MISC metadata.xml 653 BLAKE2B 44ab5b2e8f2597c4b61cdce4fe9fe35480737e7aa9e494a201a6bf74a15d58802fa01ff7dcc2994e221fba64ae7be1c7dccf95b2e6ab49cab7faffa87fd52df2 SHA512 4e2d2b17e1fcae288d50006ebc72852c9618a56dbc2ec752dc5114990fa133797750551100e1016275656f9216a8938ceadb8cd954903af66b1af5073377af61
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild
new file mode 100644
index 000000000000..6fe0c305a5e8
--- /dev/null
+++ b/perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=1.999838
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Arbitrary size floating point math package"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Carp-1.220.0
+ >=virtual/perl-Math-Complex-1.390.0
+"
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+# TODO: where does this come from?
+PDEPEND="
+ >=virtual/perl-Math-BigInt-FastCalc-0.500.600
+ >=virtual/perl-bignum-0.220.0
+ >=virtual/perl-Math-BigRat-0.260.200
+"
+
+src_test() {
+ perl_rm_files t/author-*.t t/03podcov.t t/00sig.t t/02pod.t
+ perl-module_src_test
+}
diff --git a/perl-core/Math-BigInt/metadata.xml b/perl-core/Math-BigInt/metadata.xml
new file mode 100644
index 000000000000..36405a484b9b
--- /dev/null
+++ b/perl-core/Math-BigInt/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Math-BigInt</remote-id>
+ <remote-id type="cpan-module">Math::BigFloat</remote-id>
+ <remote-id type="cpan-module">Math::BigInt</remote-id>
+ <remote-id type="cpan-module">Math::BigInt::Calc</remote-id>
+ <remote-id type="cpan-module">Math::BigInt::CalcEmu</remote-id>
+ <remote-id type="cpan-module">Math::BigInt::Lib</remote-id>
+ </upstream>
+</pkgmetadata>