summaryrefslogtreecommitdiff
path: root/net-wireless/urh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-02 03:06:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-02 03:06:27 +0000
commitc8273339188289fe8571e5a8cb9e00e59a46aaaf (patch)
tree793a97e856b00e8c923cb6b505ea175f89b35cf2 /net-wireless/urh
parent60f657b5e6155f26601c7def7baa11cee72246d0 (diff)
gentoo auto-resync : 02:02:2023 - 03:06:27
Diffstat (limited to 'net-wireless/urh')
-rw-r--r--net-wireless/urh/Manifest6
-rw-r--r--net-wireless/urh/urh-2.9.4.ebuild (renamed from net-wireless/urh/urh-2.9.3.ebuild)27
-rw-r--r--net-wireless/urh/urh-9999.ebuild27
3 files changed, 53 insertions, 7 deletions
diff --git a/net-wireless/urh/Manifest b/net-wireless/urh/Manifest
index 074fb46d76d7..16f93f4ff893 100644
--- a/net-wireless/urh/Manifest
+++ b/net-wireless/urh/Manifest
@@ -1,4 +1,4 @@
-DIST urh-2.9.3.tar.gz 13408355 BLAKE2B d856f482a2228fcc3e2aa421a3f7bd601fd10848c65abe2dafde921c12aa5b4fb540dee68a76adb79f0cd83b60bd9a19cba4101afbe8a0cf75b445a01d811e6a SHA512 5d166d6895271a6f2c5cc09f80fef2b7780f4ceec030fdfe229abafa76d77718bc5ca6d0b462c3745e71a28f2172534e756a795c3ec95f4f0f23efab8bd69e82
-EBUILD urh-2.9.3.ebuild 1483 BLAKE2B 12b5d7ea97d4e272b4a8ec7384941b20f74009d20c16524e33880bd141ea9cf4af50e5e38f01e4769849687aad031e3ef40d56ec0b79d157f8c8c7ec58926251 SHA512 b873a5c8a0b56c5296113f61d6eac37417636c96571b7d91b1c349f91416149cc8105c65d4cf17bdaee9d339f815acf421aa2f4fc98bf1e6d54680f3d582def7
-EBUILD urh-9999.ebuild 1483 BLAKE2B 12b5d7ea97d4e272b4a8ec7384941b20f74009d20c16524e33880bd141ea9cf4af50e5e38f01e4769849687aad031e3ef40d56ec0b79d157f8c8c7ec58926251 SHA512 b873a5c8a0b56c5296113f61d6eac37417636c96571b7d91b1c349f91416149cc8105c65d4cf17bdaee9d339f815acf421aa2f4fc98bf1e6d54680f3d582def7
+DIST urh-2.9.4.tar.gz 13415656 BLAKE2B 504cb073540f614eea070a7aaa83ac62f81c6a115a01f935cfc39baec37bc1deb5b56035100700825f41b21ec0937d6014f0d0b73debcbf9ca951e238805d64b SHA512 a888c20a4d2f349960e41defdb5cce6590d4523f8a1a655e21e4caaf7dd98a6f51936fa5a038787cb5935bc42e8863d2940059130dc9982caeea4b80e431aeeb
+EBUILD urh-2.9.4.ebuild 2493 BLAKE2B 80c8389d14741ea45bd551a20ff283d38617c2a9b2ea4af7a87fbd18987f33fcfb9f452bc3dfdc58c161d71a3dbe37329c19b3dfafe706f155e10ac92ee8d434 SHA512 ea5dba924ba5a6d7cfb613db31c55cb389c6baa38291af6519517946d0e9d4352dc615ce231acf7b8dc70dab681621b32c213f590ff3d57adc06beae6a4427bf
+EBUILD urh-9999.ebuild 2493 BLAKE2B 80c8389d14741ea45bd551a20ff283d38617c2a9b2ea4af7a87fbd18987f33fcfb9f452bc3dfdc58c161d71a3dbe37329c19b3dfafe706f155e10ac92ee8d434 SHA512 ea5dba924ba5a6d7cfb613db31c55cb389c6baa38291af6519517946d0e9d4352dc615ce231acf7b8dc70dab681621b32c213f590ff3d57adc06beae6a4427bf
MISC metadata.xml 1291 BLAKE2B ac1d540ddc87f3331c498b62d35204ce179cb3e329602e50f440d9bb0511a9096b7a1a40ac06a182716d32ede54cbcd2137e17ab76553cf58991623e343ec9dd SHA512 879febeeae3cef3a1ffd9e84fb65a70042c6a95fc0524d57a7fb5ad7d5a041371f041e2d804ed24d835911d41fcff5d42ac4a30a4b903ffddcefbb770123336b
diff --git a/net-wireless/urh/urh-2.9.3.ebuild b/net-wireless/urh/urh-2.9.4.ebuild
index 83c8cfc93afb..2a91a1e6cf95 100644
--- a/net-wireless/urh/urh-2.9.3.ebuild
+++ b/net-wireless/urh/urh-2.9.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{9..10} )
-inherit distutils-r1
+inherit distutils-r1 virtualx
DESCRIPTION="Universal Radio Hacker: investigate wireless protocols like a boss"
HOMEPAGE="https://github.com/jopohl/urh"
@@ -40,6 +40,8 @@ RDEPEND="${DEPEND}
dev-python/PyQt5[${PYTHON_USEDEP},testlib]
net-wireless/gr-osmosdr"
+distutils_enable_tests pytest
+
python_configure_all() {
DISTUTILS_ARGS=(
$(use_with airspy)
@@ -52,3 +54,24 @@ python_configure_all() {
$(use_with uhd usrp)
)
}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # Why are these disabled?
+ # import errors AND hangs forever after 'tests/test_spectrogram.py::TestSpectrogram::test_cancel_filtering'
+ # import errors 'tests/test_continuous_modulator.py::TestContinuousModulator::test_modulate_continuously'
+ # import errors 'tests/test_send_recv_dialog_gui.py::TestSendRecvDialog::test_continuous_send_dialog'
+ # import errors 'tests/test_spectrogram.py::TestSpectrogram::test_channel_separation_with_negative_frequency'
+ local EPYTEST_DESELECT=(
+ 'tests/test_spectrogram.py::TestSpectrogram::test_cancel_filtering'
+ 'tests/test_continuous_modulator.py::TestContinuousModulator::test_modulate_continuously'
+ 'tests/test_send_recv_dialog_gui.py::TestSendRecvDialog::test_continuous_send_dialog'
+ 'tests/test_spectrogram.py::TestSpectrogram::test_channel_separation_with_negative_frequency'
+
+ )
+ cd "${T}" || die
+ epytest -s --pyargs urh.cythonext "${S}/tests" || die
+}
diff --git a/net-wireless/urh/urh-9999.ebuild b/net-wireless/urh/urh-9999.ebuild
index 83c8cfc93afb..2a91a1e6cf95 100644
--- a/net-wireless/urh/urh-9999.ebuild
+++ b/net-wireless/urh/urh-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{9..10} )
-inherit distutils-r1
+inherit distutils-r1 virtualx
DESCRIPTION="Universal Radio Hacker: investigate wireless protocols like a boss"
HOMEPAGE="https://github.com/jopohl/urh"
@@ -40,6 +40,8 @@ RDEPEND="${DEPEND}
dev-python/PyQt5[${PYTHON_USEDEP},testlib]
net-wireless/gr-osmosdr"
+distutils_enable_tests pytest
+
python_configure_all() {
DISTUTILS_ARGS=(
$(use_with airspy)
@@ -52,3 +54,24 @@ python_configure_all() {
$(use_with uhd usrp)
)
}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # Why are these disabled?
+ # import errors AND hangs forever after 'tests/test_spectrogram.py::TestSpectrogram::test_cancel_filtering'
+ # import errors 'tests/test_continuous_modulator.py::TestContinuousModulator::test_modulate_continuously'
+ # import errors 'tests/test_send_recv_dialog_gui.py::TestSendRecvDialog::test_continuous_send_dialog'
+ # import errors 'tests/test_spectrogram.py::TestSpectrogram::test_channel_separation_with_negative_frequency'
+ local EPYTEST_DESELECT=(
+ 'tests/test_spectrogram.py::TestSpectrogram::test_cancel_filtering'
+ 'tests/test_continuous_modulator.py::TestContinuousModulator::test_modulate_continuously'
+ 'tests/test_send_recv_dialog_gui.py::TestSendRecvDialog::test_continuous_send_dialog'
+ 'tests/test_spectrogram.py::TestSpectrogram::test_channel_separation_with_negative_frequency'
+
+ )
+ cd "${T}" || die
+ epytest -s --pyargs urh.cythonext "${S}/tests" || die
+}