summaryrefslogtreecommitdiff
path: root/net-wireless/uhd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /net-wireless/uhd/files
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'net-wireless/uhd/files')
-rw-r--r--net-wireless/uhd/files/uhd-4.0.0.0-tinfo.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-wireless/uhd/files/uhd-4.0.0.0-tinfo.patch b/net-wireless/uhd/files/uhd-4.0.0.0-tinfo.patch
new file mode 100644
index 000000000000..484aa1f9c2f5
--- /dev/null
+++ b/net-wireless/uhd/files/uhd-4.0.0.0-tinfo.patch
@@ -0,0 +1,42 @@
+diff -Naur host/CMakeLists.txt uhd-4.0.0.0-patched/host/CMakeLists.txt
+--- host/CMakeLists.txt 2020-09-13 15:14:04.000000000 -0400
++++ host/CMakeLists.txt 2020-09-16 10:11:52.266933094 -0400
+@@ -506,6 +506,9 @@
+ if(ENABLE_USB)
+ list(APPEND UHD_LINK_LIST_STATIC "usb-1.0")
+ endif(ENABLE_USB)
++
++LIST(APPEND UHD_LINK_LIST_STATIC "tinfo")
++
+ set(UHD_RFNOC_FOUND "TRUE")
+
+ configure_file(
+diff -Naur host/examples/CMakeLists.txt uhd-4.0.0.0-patched/host/examples/CMakeLists.txt
+--- host/examples/CMakeLists.txt 2020-09-13 15:14:04.000000000 -0400
++++ host/examples/CMakeLists.txt 2020-09-16 10:12:49.082935381 -0400
+@@ -55,11 +55,11 @@
+ if(CURSES_FOUND)
+ include_directories(${CURSES_INCLUDE_DIR})
+ add_executable(rx_ascii_art_dft rx_ascii_art_dft.cpp)
+- target_link_libraries(rx_ascii_art_dft uhd ${CURSES_LIBRARIES} ${Boost_LIBRARIES})
++ target_link_libraries(rx_ascii_art_dft uhd ${CURSES_LIBRARIES} tinfo ${Boost_LIBRARIES})
+ UHD_INSTALL(TARGETS rx_ascii_art_dft RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
+
+ add_executable(twinrx_freq_hopping twinrx_freq_hopping.cpp)
+- target_link_libraries(twinrx_freq_hopping uhd ${CURSES_LIBRARIES} ${Boost_LIBRARIES})
++ target_link_libraries(twinrx_freq_hopping uhd ${CURSES_LIBRARIES} tinfo ${Boost_LIBRARIES})
+ UHD_INSTALL(TARGETS twinrx_freq_hopping RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
+ endif(CURSES_FOUND)
+
+diff -Naur host/utils/latency/CMakeLists.txt uhd-4.0.0.0-patched/host/utils/latency/CMakeLists.txt
+--- host/utils/latency/CMakeLists.txt 2020-09-13 15:14:04.000000000 -0400
++++ host/utils/latency/CMakeLists.txt 2020-09-16 10:13:55.994938074 -0400
+@@ -25,7 +25,7 @@
+ get_filename_component(name ${source} NAME_WE)
+ add_executable(${name} ${source} ${latency_lib_path})
+ LIBUHD_APPEND_SOURCES(${name})
+- target_link_libraries(${name} uhd ${Boost_LIBRARIES} ${CURSES_LIBRARIES})
++ target_link_libraries(${name} uhd ${Boost_LIBRARIES} tinfo ${CURSES_LIBRARIES})
+ UHD_INSTALL(TARGETS ${name} RUNTIME DESTINATION ${latency_comp_dest} COMPONENT ${latency_comp_name})
+ endforeach(source)
+