summaryrefslogtreecommitdiff
path: root/net-wireless/soapyuhd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /net-wireless/soapyuhd
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'net-wireless/soapyuhd')
-rw-r--r--net-wireless/soapyuhd/Manifest4
-rw-r--r--net-wireless/soapyuhd/metadata.xml15
-rw-r--r--net-wireless/soapyuhd/soapyuhd-0.3.4.ebuild27
-rw-r--r--net-wireless/soapyuhd/soapyuhd-9999.ebuild27
4 files changed, 73 insertions, 0 deletions
diff --git a/net-wireless/soapyuhd/Manifest b/net-wireless/soapyuhd/Manifest
new file mode 100644
index 000000000000..403cb6313849
--- /dev/null
+++ b/net-wireless/soapyuhd/Manifest
@@ -0,0 +1,4 @@
+DIST soapyuhd-0.3.4.tar.gz 32111 BLAKE2B 77e976f0d5ba671fb7ff2f9822b62ab6de9b6992dc57e7824fbf7972fa52e864a33673c3620094871117a33008cf86e834d7401b2ddd060a96662d2caa48d6e4 SHA512 2eda4d0ed65d86e915ad24c5221c41716ad838ea444d92ade5eb19959bc6992132dc208ceafe994cd14e4c4a429a21341c7c5d67d354999b85e96f388cb3aa4e
+EBUILD soapyuhd-0.3.4.ebuild 658 BLAKE2B e05b377afed6538a8fd5488247d9668ae66f303a237322360263f1460eab2a42c329e488bdf2dfc5c35abab264a0b95d57b3cae0135e7753fb83e085de3777a2 SHA512 697240e82561c0a3918b2275515704888d43736340c8011f9b7eb35e8e27634f0960ff0dbecd4660f51ca6259431b316784ec194ef6f9ae6f450dd35f618cd8c
+EBUILD soapyuhd-9999.ebuild 658 BLAKE2B e05b377afed6538a8fd5488247d9668ae66f303a237322360263f1460eab2a42c329e488bdf2dfc5c35abab264a0b95d57b3cae0135e7753fb83e085de3777a2 SHA512 697240e82561c0a3918b2275515704888d43736340c8011f9b7eb35e8e27634f0960ff0dbecd4660f51ca6259431b316784ec194ef6f9ae6f450dd35f618cd8c
+MISC metadata.xml 430 BLAKE2B 583986bcf088a9cfcda635a68fef35c98ad5d5504be93f03b1034936930b38a81f3a952f1a33409a71406b3178cccb98afac8c3dafef670cbda3383830d1c22d SHA512 31ca3b4aff913064ad156b644b1598cc3412d818cf0b67607b222770852e98fc1e4d5e164d053088bd53bdffe9f394a279a1525dabfa3f22db972bc5099101f6
diff --git a/net-wireless/soapyuhd/metadata.xml b/net-wireless/soapyuhd/metadata.xml
new file mode 100644
index 000000000000..711cc176e00b
--- /dev/null
+++ b/net-wireless/soapyuhd/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>radio@gentoo.org</email>
+ <name>Radio</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pothosware/SoapyUHD</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-wireless/soapyuhd/soapyuhd-0.3.4.ebuild b/net-wireless/soapyuhd/soapyuhd-0.3.4.ebuild
new file mode 100644
index 000000000000..626e9029a89c
--- /dev/null
+++ b/net-wireless/soapyuhd/soapyuhd-0.3.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR plugins for UHD supported SDR devices "
+HOMEPAGE="https://github.com/pothosware/SoapyUHD"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyUHD.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyUHD/archive/soapy-uhd-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyUHD-soapy-uhd-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr
+ net-wireless/uhd:=
+ dev-libs/boost:="
+DEPEND="${RDEPEND}"
diff --git a/net-wireless/soapyuhd/soapyuhd-9999.ebuild b/net-wireless/soapyuhd/soapyuhd-9999.ebuild
new file mode 100644
index 000000000000..626e9029a89c
--- /dev/null
+++ b/net-wireless/soapyuhd/soapyuhd-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR plugins for UHD supported SDR devices "
+HOMEPAGE="https://github.com/pothosware/SoapyUHD"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyUHD.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyUHD/archive/soapy-uhd-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyUHD-soapy-uhd-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr
+ net-wireless/uhd:=
+ dev-libs/boost:="
+DEPEND="${RDEPEND}"