summaryrefslogtreecommitdiff
path: root/net-wireless/soapysdrplay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-29 20:19:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-29 20:19:23 +0100
commit12bb627384ddfd47382b9f1b6464481a58d01ebb (patch)
treef9760c04ccd4fcd7de214e2acd5b0e43fb530aa9 /net-wireless/soapysdrplay
parent5fdd950c7ae03e12746a45c86d85861beaacc846 (diff)
gentoo resync : 29.08.2018
Diffstat (limited to 'net-wireless/soapysdrplay')
-rw-r--r--net-wireless/soapysdrplay/Manifest4
-rw-r--r--net-wireless/soapysdrplay/metadata.xml11
-rw-r--r--net-wireless/soapysdrplay/soapysdrplay-0.1.0.ebuild30
-rw-r--r--net-wireless/soapysdrplay/soapysdrplay-9999.ebuild30
4 files changed, 75 insertions, 0 deletions
diff --git a/net-wireless/soapysdrplay/Manifest b/net-wireless/soapysdrplay/Manifest
new file mode 100644
index 000000000000..f5995a20e823
--- /dev/null
+++ b/net-wireless/soapysdrplay/Manifest
@@ -0,0 +1,4 @@
+DIST soapysdrplay-0.1.0.tar.gz 11736 BLAKE2B 746e01092d094cedb6b15b9c11ec0b828e18cd3c814e46cbe5cb9473cfd494d8342ab9618d8c5d945429b2b62178b02b81c2b000e20c53a7cb027d4b2a25c789 SHA512 28382b4ac79e27a0b84ed6edb4abeca99b90222ad2890041e1585cac21177518ca3fcea0a3e14f8502091d47e7b2a223913dd77c53b6c0360f0f3875328613da
+EBUILD soapysdrplay-0.1.0.ebuild 702 BLAKE2B 34b4faee3609e75c1f12315a2a879bd9e6b71f889ba9278492abd76d36dd27d296658108c5bd941f67d6869edef72c0fa5363489975389038b397d1b9a63c05f SHA512 622061029d0773c9bb0a7df6dd5bd280a27cdb30387aca1404311bb80d19097b7fdd0b5a82a2fe6268314fc41038d98ee29c11b29dee592e7cc039ed1b63ca7c
+EBUILD soapysdrplay-9999.ebuild 702 BLAKE2B 34b4faee3609e75c1f12315a2a879bd9e6b71f889ba9278492abd76d36dd27d296658108c5bd941f67d6869edef72c0fa5363489975389038b397d1b9a63c05f SHA512 622061029d0773c9bb0a7df6dd5bd280a27cdb30387aca1404311bb80d19097b7fdd0b5a82a2fe6268314fc41038d98ee29c11b29dee592e7cc039ed1b63ca7c
+MISC metadata.xml 337 BLAKE2B 6dc787bbdb327227a07da5497daaf4ae0e00855ce4f6114fd911b7ca063d3464a3c68d5cb74c1ff223ecba129af0e1a1fb9cd7b546f19315e03e9c4e4710d0da SHA512 f4eda418b6bd4dba31d1429cc0837ee53946132c9d4e95063a671c5a98e20f25dd0505f1bc63ee90849676d2bef1a6fb9cb87824b3c696bc1d952d50f74777e6
diff --git a/net-wireless/soapysdrplay/metadata.xml b/net-wireless/soapysdrplay/metadata.xml
new file mode 100644
index 000000000000..1ea917b38743
--- /dev/null
+++ b/net-wireless/soapysdrplay/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pothosware/SoapySDRPlay</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-wireless/soapysdrplay/soapysdrplay-0.1.0.ebuild b/net-wireless/soapysdrplay/soapysdrplay-0.1.0.ebuild
new file mode 100644
index 000000000000..cd6b8ca15cb8
--- /dev/null
+++ b/net-wireless/soapysdrplay/soapysdrplay-0.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR plugin for SDRPlay"
+HOMEPAGE="https://github.com/pothosware/SoapySDRPlay"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapySDRPlay.git"
+ EGIT_CLONE_TYPE="shallow"
+ KEYWORDS=""
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapySDRPlay/archive/soapy-sdrplay-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapySDRPlay-soapy-sdrplay-"${PV}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE=""
+REQUIRED_USE=""
+
+RDEPEND="net-wireless/soapysdr
+ net-wireless/sdrplay"
+DEPEND="${RDEPEND}"
diff --git a/net-wireless/soapysdrplay/soapysdrplay-9999.ebuild b/net-wireless/soapysdrplay/soapysdrplay-9999.ebuild
new file mode 100644
index 000000000000..cd6b8ca15cb8
--- /dev/null
+++ b/net-wireless/soapysdrplay/soapysdrplay-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR plugin for SDRPlay"
+HOMEPAGE="https://github.com/pothosware/SoapySDRPlay"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapySDRPlay.git"
+ EGIT_CLONE_TYPE="shallow"
+ KEYWORDS=""
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapySDRPlay/archive/soapy-sdrplay-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapySDRPlay-soapy-sdrplay-"${PV}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE=""
+REQUIRED_USE=""
+
+RDEPEND="net-wireless/soapysdr
+ net-wireless/sdrplay"
+DEPEND="${RDEPEND}"