summaryrefslogtreecommitdiff
path: root/net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild')
-rw-r--r--net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild b/net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild
index 148e9614dedc..f8ab9250ade2 100644
--- a/net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild
+++ b/net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils flag-o-matic linux-info udev
+inherit cmake flag-o-matic linux-info udev
DESCRIPTION="turns FL2000-based USB 3.0 to VGA adapters into low cost DACs"
-
HOMEPAGE="https://osmocom.org/projects/osmo-fl2k/wiki"
if [[ ${PV} == "9999" ]]; then
@@ -24,9 +23,9 @@ SLOT="0"
IUSE="udev"
DEPEND="virtual/libusb:1"
-RDEPEND="${DEPEND}"
-PDEPEND="media-sound/sox
- sys-apps/pv"
+RDEPEND="${DEPEND}
+ media-sound/sox
+ sys-apps/pv"
# continguous memory allocator can optionally be used for zero-copy transfer
# TODO: tell users to set CONFIG_CMA_SIZE_MBYTES or boot with cma=... parameter
@@ -41,12 +40,15 @@ src_configure() {
#https://gcc.gnu.org/bugzilla/show_bug.cgi?id=49653
replace-flags -O0 -O2
replace-flags -Os -O2
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
if use udev; then
udev_newrules ${PN}.rules 99-${PN}.rules
fi
- cmake-utils_src_install
+ cmake_src_install
+ # https://bugs.gentoo.org/727984
+ # No obvious way to prevent build
+ find "${ED}" -name libosmo-fl2k.a -delete
}