summaryrefslogtreecommitdiff
path: root/net-wireless/lorcon/lorcon-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
commitf70601e0934acd62f6c5d06c5ede4cc607179514 (patch)
tree0b337390375de04b950fc4b45edc0f895a4701a4 /net-wireless/lorcon/lorcon-9999.ebuild
parentb2be182d49eea46686b5cf2680d457df61e89dc4 (diff)
gentoo resync : 07.07.2018
Diffstat (limited to 'net-wireless/lorcon/lorcon-9999.ebuild')
-rw-r--r--net-wireless/lorcon/lorcon-9999.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/net-wireless/lorcon/lorcon-9999.ebuild b/net-wireless/lorcon/lorcon-9999.ebuild
index f0502097ecd1..0348df635401 100644
--- a/net-wireless/lorcon/lorcon-9999.ebuild
+++ b/net-wireless/lorcon/lorcon-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
DISTUTILS_OPTIONAL=1
@@ -9,14 +9,18 @@ DISTUTILS_OPTIONAL=1
inherit distutils-r1
DESCRIPTION="A generic library for injecting 802.11 frames"
-HOMEPAGE="http://802.11ninja.net/lorcon"
+HOMEPAGE="https://github.com/kismetwireless/lorcon"
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://code.google.com/p/lorcon/"
+ #EGIT_REPO_URI="https://www.kismetwireless.net/lorcon.git"
+ EGIT_REPO_URI="https://github.com/kismetwireless/lorcon.git"
inherit git-r3
KEYWORDS=""
+ S="${WORKDIR}"/${P}
else
- SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+ GIT_HASH="d8637792f2e857f31849f29759c1022eb0518c83"
+ SRC_URI="https://github.com/kismetwireless/lorcon/archive/${GIT_HASH}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/"${PN}-${GIT_HASH}"
KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
fi
@@ -32,8 +36,6 @@ RDEPEND="${DEPEND}"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-S="${WORKDIR}"/${P}
-
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
git-r3_src_unpack
@@ -44,6 +46,12 @@ src_unpack() {
src_prepare() {
sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' pylorcon2/PyLorcon2.c
+ sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' pylorcon2/PyLorcon2.h
+ sed -i 's#<lorcon2/lorcon_packet.h>#"../lorcon_packet.h"#' pylorcon2/PyLorcon2.c
+ sed -i 's#<lorcon2/lorcon_packet.h>#"../lorcon_packet.h"#' pylorcon2/PyLorcon2.h
+ sed -i 's#<lorcon2/lorcon_multi.h>#"../lorcon_multi.h"#' pylorcon2/PyLorcon2.c
+ sed -i 's#<lorcon2/lorcon_multi.h>#"../lorcon_multi.h"#' pylorcon2/PyLorcon2.h
+ default
use python && distutils-r1_src_prepare
}