summaryrefslogtreecommitdiff
path: root/net-wireless/kismetmobiledashboard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /net-wireless/kismetmobiledashboard
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'net-wireless/kismetmobiledashboard')
-rw-r--r--net-wireless/kismetmobiledashboard/Manifest4
-rw-r--r--net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1.ebuild33
-rw-r--r--net-wireless/kismetmobiledashboard/kismetmobiledashboard-9999.ebuild14
3 files changed, 45 insertions, 6 deletions
diff --git a/net-wireless/kismetmobiledashboard/Manifest b/net-wireless/kismetmobiledashboard/Manifest
index 78575c6dfb9d..5e7aa462a44e 100644
--- a/net-wireless/kismetmobiledashboard/Manifest
+++ b/net-wireless/kismetmobiledashboard/Manifest
@@ -1,2 +1,4 @@
-EBUILD kismetmobiledashboard-9999.ebuild 573 BLAKE2B 33abe1b6de426b8f1660d0e7e13db31c4c65a33cb40c8b18e1d33bd1d4879f3a96a06da83ea44eecf2117bd1bbc7c87efd21f03d9104411185da0a81d3325fb9 SHA512 4b8aaa569006a5d491ceff41c5cef4be1305b4494533709bf9ec3a090ba36455fcdf5515527300deb6f66c4f966783a15c6118ec64ddefca399d5b29e7e440b5
+DIST kismetmobiledashboard-1.5_beta1.tar.gz 2305979 BLAKE2B 05e1f41b02688d2d432ff805b454fc948d387111ab2cf45a7ef72e9421a410a2fe479eca5a9f7eb56f58c807aeb47c1cc0a75c135ee3fb6faee2b979cc89894b SHA512 6abb5bd89b80ed4012d119d7111128bca2625d63f1cb36ab50b79e68b14f355b4c788b1290a720bb51268903b428a42dfffcb4373a2170a3d32aef5c140a9e91
+EBUILD kismetmobiledashboard-1.5_beta1.ebuild 803 BLAKE2B 9423436a7b961d54151017eb0c871a877440917e16e6b12b21dc2e1a36b1196767039ce6f583cc90f05bb8ab8905fcd336dc10b43d7449b8111744ea42294706 SHA512 7f139b38cf7abb13a479fb855bafd877ab939fe27edfbbed74ee39816d8d8743d43e4136d4e0fa7b1f5004596a2dff149f6f98293d2e56b9d6130c8e5021e37b
+EBUILD kismetmobiledashboard-9999.ebuild 803 BLAKE2B 9423436a7b961d54151017eb0c871a877440917e16e6b12b21dc2e1a36b1196767039ce6f583cc90f05bb8ab8905fcd336dc10b43d7449b8111744ea42294706 SHA512 7f139b38cf7abb13a479fb855bafd877ab939fe27edfbbed74ee39816d8d8743d43e4136d4e0fa7b1f5004596a2dff149f6f98293d2e56b9d6130c8e5021e37b
MISC metadata.xml 247 BLAKE2B 0aa7491a8e9a68ed7ad1c53c8442fd44a9dbdfbd7ef0662e838195b44ce72a77f5dc3b846cf9951bb61de78e05aac37649b78dd4c27e304780e1223d607a4252 SHA512 3344e220b20caad7bc32141ad5d51630ff0738ab14608334576638297fdd2a48d5169ef54fb33e36d27bd448d92f8ef9e41880df388521efd4a2c58d102c7c69
diff --git a/net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1.ebuild b/net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1.ebuild
new file mode 100644
index 000000000000..5e92f7f7e0e6
--- /dev/null
+++ b/net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
+DESCRIPTION="Mobile UI for kismet"
+HOMEPAGE="https://github.com/elkentaro/KismetMobileDashboard"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/elkentaro/KismetMobileDashboard.git"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+ SRC_URI="https://github.com/elkentaro/KismetMobileDashboard/archive/V1.5-beta.1.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/KismetMobileDashboard-1.5-beta.1"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="net-wireless/kismet"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+ KIS_SRC_DIR="/usr/share/kismet" emake
+}
+
+src_install() {
+ DESTDIR="${ED}" KIS_SRC_DIR="/usr/share/kismet" emake install
+}
diff --git a/net-wireless/kismetmobiledashboard/kismetmobiledashboard-9999.ebuild b/net-wireless/kismetmobiledashboard/kismetmobiledashboard-9999.ebuild
index 12e0b4cc7b3e..5e92f7f7e0e6 100644
--- a/net-wireless/kismetmobiledashboard/kismetmobiledashboard-9999.ebuild
+++ b/net-wireless/kismetmobiledashboard/kismetmobiledashboard-9999.ebuild
@@ -4,19 +4,23 @@
EAPI=7
PYTHON_COMPAT=( python2_7 python3_{6,7} )
-inherit git-r3
DESCRIPTION="Mobile UI for kismet"
HOMEPAGE="https://github.com/elkentaro/KismetMobileDashboard"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/elkentaro/KismetMobileDashboard.git"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/elkentaro/KismetMobileDashboard.git"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+ SRC_URI="https://github.com/elkentaro/KismetMobileDashboard/archive/V1.5-beta.1.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/KismetMobileDashboard-1.5-beta.1"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE=""
-DEPEND=""
+DEPEND="net-wireless/kismet"
RDEPEND="${DEPEND}"
BDEPEND=""