summaryrefslogtreecommitdiff
path: root/net-wireless/kismet/kismet-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /net-wireless/kismet/kismet-9999.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'net-wireless/kismet/kismet-9999.ebuild')
-rw-r--r--net-wireless/kismet/kismet-9999.ebuild96
1 files changed, 17 insertions, 79 deletions
diff --git a/net-wireless/kismet/kismet-9999.ebuild b/net-wireless/kismet/kismet-9999.ebuild
index 2a6321ed5126..ddf8e2e5e783 100644
--- a/net-wireless/kismet/kismet-9999.ebuild
+++ b/net-wireless/kismet/kismet-9999.ebuild
@@ -8,6 +8,7 @@ PYTHON_COMPAT=( python2_7 )
inherit autotools eutils multilib user python-single-r1
MY_P=${P/\./-}
+MY_P=${MY_P/_beta/-BETA}
MY_P=${MY_P/./-R}
S=${WORKDIR}/${MY_P}
@@ -27,7 +28,7 @@ HOMEPAGE="https://www.kismetwireless.net"
LICENSE="GPL-2"
SLOT="0/${PV}"
-IUSE="+pcre speech selinux +suid"
+IUSE="lm_sensors networkmanager +pcre selinux +suid"
CDEPEND="
${PYTHON_DEPS}
@@ -43,13 +44,10 @@ CDEPEND="
)
dev-libs/protobuf-c:=
sys-libs/ncurses:=
+ lm_sensors? ( sys-apps/lm_sensors )
pcre? ( dev-libs/libpcre )
suid? ( sys-libs/libcap )
- !arm? ( speech? ( app-accessibility/flite ) )
"
- #plugin-btscan? ( net-wireless/bluez )
- #plugin-dot15d4? ( virtual/libusb:0 )
- #plugin-spectools? ( net-wireless/spectools )
DEPEND="${CDEPEND}
virtual/pkgconfig
@@ -69,95 +67,35 @@ src_prepare() {
epatch "${FILESDIR}"/fix-setuptools.patch
eapply_user
- eautoreconf
+
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+
+ if ! use lm_sensors; then
+ sed -i "s#HAVE_LMSENSORS_H=1#HAVE_LMSENSORS_H=0#" configure
+ fi
+ if use networkmanager; then
+ sed -i "s#havelibnm\=no#havelibnm\=yes#" configure
+ else
+ sed -i "s#havelibnm\=yes#havelibnm\=no#" configure
+ fi
+ sed -i 's#-O3##' configure
}
src_configure() {
econf \
$(use_enable pcre)
- #--disable-python-tools
-}
-
-src_compile() {
- emake
-
- #if use plugin-autowep; then
- # cd "${S}"/restricted-plugin-autowep
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-btscan; then
- # cd "${S}"/plugin-btscan
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-dot15d4; then
- # cd "${S}"/plugin-dot15d4
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-ptw; then
- # cd "${S}"/restricted-plugin-ptw
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-spectools; then
- # cd "${S}"/plugin-spectools
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-syslog; then
- # cd "${S}"/plugin-syslog
- # KIS_SRC_DIR="${S}" emake
- #fi
}
src_install() {
- #if use plugin-autowep; then
- # cd "${S}"/restricted-plugin-autowep
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-btscan; then
- # cd "${S}"/plugin-btscan
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-dot15d4; then
- # cd "${S}"/plugin-dot15d4
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-ptw; then
- # cd "${S}"/restricted-plugin-ptw
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-spectools; then
- # cd "${S}"/plugin-spectools
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-syslog; then
- # cd "${S}"/plugin-syslog
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use ruby; then
- # cd "${S}"/ruby
- # dobin *.rb
- #fi
-
- #cd "${S}"
emake DESTDIR="${D}" commoninstall
emake DESTDIR="${D}" forceconfigs
- ##dragorn would prefer I set fire to my head than do this, but it works
- ##all external kismet plugins (read: kismet-ubertooth) must be rebuilt when kismet is
- ##is there an automatic way to force this?
- # install headers for external plugins
- insinto /usr/include/kismet
- doins *.h
- doins Makefile.inc
- #todo write a plugin finder that tells you what needs to be rebuilt when kismet is updated, etc
-
#dodoc CHANGELOG RELEASENOTES.txt README* docs/DEVEL.client docs/README.newcore
dodoc CHANGELOG README*
newinitd "${FILESDIR}"/${PN}.initd kismet
newconfd "${FILESDIR}"/${PN}.confd kismet
-
- #if use suid; then
- # dobin kismet_capture
- #fi
}
pkg_preinst() {