summaryrefslogtreecommitdiff
path: root/net-wireless/kismet/kismet-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-wireless/kismet/kismet-9999.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-wireless/kismet/kismet-9999.ebuild')
-rw-r--r--net-wireless/kismet/kismet-9999.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/net-wireless/kismet/kismet-9999.ebuild b/net-wireless/kismet/kismet-9999.ebuild
index 01ac8b25a826..2a02da5e4246 100644
--- a/net-wireless/kismet/kismet-9999.ebuild
+++ b/net-wireless/kismet/kismet-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,7 +25,7 @@ else
#SRC_URI="https://github.com/kismetwireless/kismet/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
#S="${WORKDIR}/${PN}-${COMMIT}"
- KEYWORDS="amd64 arm ~arm64 ~ppc x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
fi
DESCRIPTION="IEEE 802.11 wireless LAN sniffer"
@@ -33,8 +33,8 @@ HOMEPAGE="https://www.kismetwireless.net"
LICENSE="GPL-2"
SLOT="0/${PV}"
-IUSE="lm-sensors mousejack networkmanager +pcre selinux +suid"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
+IUSE="libusb lm-sensors networkmanager +pcre rtlsdr selinux +suid ubertooth"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
CDEPEND="
${PYTHON_DEPS}
@@ -48,7 +48,7 @@ CDEPEND="
dev-libs/libnl:3
net-libs/libpcap
)
- mousejack? ( virtual/libusb:1 )
+ libusb? ( virtual/libusb:1 )
dev-libs/protobuf-c:=
dev-libs/protobuf:=
dev-python/protobuf-python[${PYTHON_USEDEP}]
@@ -56,6 +56,7 @@ CDEPEND="
lm-sensors? ( sys-apps/lm-sensors )
pcre? ( dev-libs/libpcre )
suid? ( sys-libs/libcap )
+ ubertooth? ( net-wireless/ubertooth:= )
"
DEPEND="${CDEPEND}
@@ -66,6 +67,8 @@ RDEPEND="${CDEPEND}
dev-python/pyserial[${PYTHON_USEDEP}]
selinux? ( sec-policy/selinux-kismet )
"
+PDEPEND="rtlsdr? ( dev-python/numpy[${PYTHON_USEDEP}]
+ net-wireless/rtl-sdr )"
src_prepare() {
sed -i -e "s:^\(logtemplate\)=\(.*\):\1=/tmp/\2:" \
@@ -88,10 +91,11 @@ src_prepare() {
src_configure() {
econf \
+ $(use_enable libusb libusb) \
$(use_enable pcre) \
$(use_enable lm-sensors lmsensors) \
- $(use_enable mousejack libusb) \
$(use_enable networkmanager libnm) \
+ $(use_enable ubertooth) \
--sysconfdir=/etc/kismet \
--disable-optimization
}
@@ -133,9 +137,9 @@ pkg_preinst() {
migrate_config() {
einfo "Kismet Configuration files are now read from /etc/kismet/"
- if [ -n "$(ls ${EROOT}/etc/kismet_*.conf)" ]; then
+ ewarn "Please keep user specific settings in /etc/kismet/kismet_site.conf"
+ if [ -n "$(ls ${EROOT}/etc/kismet_*.conf 2> /dev/null)" ]; then
ewarn "Files at /etc/kismet_*.conf will not be read and should be removed"
- ewarn "Please keep user specific settings in /etc/kismet/kismet_site.conf"
fi
if [ -f "${EROOT}/etc/kismet_site.conf" ] && [ ! -f "${EROOT}/etc/kismet/kismet_site.conf" ]; then
mv /etc/kismet_site.conf /etc/kismet/kismet_site.conf || die "Failed to migrate kismet_site.conf to new location"