summaryrefslogtreecommitdiff
path: root/net-wireless/gr-scopy/gr-scopy-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-20 13:02:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-20 13:02:32 +0000
commit65c1a6f8d7210639cbdc1565ccee4758f45dfc45 (patch)
treed7bea8e8d228e76b177eccb0ffc1f45a58a1e2f7 /net-wireless/gr-scopy/gr-scopy-9999.ebuild
parentc4f077d9f57bf57fcded75904bf512075191d2d2 (diff)
gentoo auto-resync : 20:11:2022 - 13:02:32
Diffstat (limited to 'net-wireless/gr-scopy/gr-scopy-9999.ebuild')
-rw-r--r--net-wireless/gr-scopy/gr-scopy-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/net-wireless/gr-scopy/gr-scopy-9999.ebuild b/net-wireless/gr-scopy/gr-scopy-9999.ebuild
index f633fe307051..0ad510927c21 100644
--- a/net-wireless/gr-scopy/gr-scopy-9999.ebuild
+++ b/net-wireless/gr-scopy/gr-scopy-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-single-r1
@@ -11,9 +11,10 @@ DESCRIPTION="Scopy IIO blocks for GNU Radio"
HOMEPAGE="https://github.com/analogdevicesinc/gr-scopy"
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/analogdevicesinc/gr-scopy.git"
+ EGIT_BRANCH="3.10"
inherit git-r3
else
- COMMIT="f48b45cabe2a81f491137dbc220032ea65f080c3"
+ COMMIT="a69ccb22578621a69acc187fc0d006b5a030a744"
SRC_URI="https://github.com/analogdevicesinc/gr-scopy/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"
KEYWORDS="~amd64 ~x86"
@@ -23,13 +24,13 @@ SLOT="0"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
RDEPEND="${PYTHON_DEPS}
- =net-wireless/gnuradio-3.8*:=
+ >=net-wireless/gnuradio-3.9.0.0:=[analog]
sci-libs/volk:=
- dev-libs/log4cpp:=
"
DEPEND="${RDEPEND}"
src_install() {
cmake_src_install
python_optimize
+ mv "${ED}/usr/share/doc/${PN}" "${ED}/usr/share/doc/${P}"
}