summaryrefslogtreecommitdiff
path: root/net-wireless/gr-rds
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /net-wireless/gr-rds
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'net-wireless/gr-rds')
-rw-r--r--net-wireless/gr-rds/Manifest2
-rw-r--r--net-wireless/gr-rds/gr-rds-9999.ebuild42
2 files changed, 23 insertions, 21 deletions
diff --git a/net-wireless/gr-rds/Manifest b/net-wireless/gr-rds/Manifest
index f5364d0378b1..dab672fbd635 100644
--- a/net-wireless/gr-rds/Manifest
+++ b/net-wireless/gr-rds/Manifest
@@ -1,2 +1,2 @@
-EBUILD gr-rds-9999.ebuild 1086 BLAKE2B 443adb1063b0fb018e63b07371249ef725d08253ee9e451f073202f17fecedf905d4052d18c93964db8a2d377d16db75ba6aeb8fbbd22b6d54c8985324a3cc75 SHA512 520131d597d81f24f5f3c29cedeafef1c7a6cb3aec61db8a9fa036c6a5272ace4b5a98c115dbaf0762a4b72b2f2a2a89e382da395deaecb00f426404c0fc5194
+EBUILD gr-rds-9999.ebuild 1121 BLAKE2B 1e99aa7d84a20395e619fa2bacf0a9b0ae5ec7631eb63c6961cc9faea51bc15e235dc11b4dc8fff287e4a69a97733d0652356f014395d357a4463622811f26c8 SHA512 0756b8aaf8a8a653fe4f676396c686315886784aa4551951f7699ef9fbcd9967a84fc7f7c44b98d708a3c167f38adcfa50f2e91a324ef931e791eea50fb0d82f
MISC metadata.xml 317 BLAKE2B 38ab4417f4befdeb7d9912a3712a259653e223aac63528287493cde0094efbe7c985f1cd93e871a10fb1a99b8add72f20d6b31a93d06017171a85a276f4b9840 SHA512 a5cb2c2182d2c0a2afbb3ebc9ac175af13be57ea5ca28abd3cb59d25a562484f8dc01b08da9e0644929a6cbd63f2c850eb6169f574dbed838180e5a5e89ad510
diff --git a/net-wireless/gr-rds/gr-rds-9999.ebuild b/net-wireless/gr-rds/gr-rds-9999.ebuild
index 39a3b5f3f6f7..7a3bffd7a3f4 100644
--- a/net-wireless/gr-rds/gr-rds-9999.ebuild
+++ b/net-wireless/gr-rds/gr-rds-9999.ebuild
@@ -1,44 +1,46 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-single-r1
+EAPI=7
-DESCRIPTION="gnuradio FM RDS Receiver"
-HOMEPAGE="https://github.com/bastibl/gr-rds"
+PYTHON_COMPAT=( python2_7 )
if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/bastibl/${PN}"
+else
KEYWORDS=""
-#else
-# SRC_URI=""
-# KEYWORDS=""
fi
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="GNU Radio FM RDS Receiver"
+HOMEPAGE="https://github.com/bastibl/gr-rds"
LICENSE="GPL-3"
SLOT="0/${PV}"
-RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
dev-libs/boost:=[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- dev-lang/swig:0"
+ >=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/swig:0
+"
#cppunit is listed in cmake, but only needed for tests and there are no tests
# dev-util/cppunit"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
src_prepare() {
+ cmake-utils_src_prepare
#although cppunit is not used, it fails if it isn't there, fix it
- sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt
- sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt
- sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt
+ sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt || die
+ sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt || die
+ sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt || die
}
src_configure() {
- mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
+ local mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
cmake-utils_src_configure
}