summaryrefslogtreecommitdiff
path: root/net-wireless/gr-rds
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /net-wireless/gr-rds
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'net-wireless/gr-rds')
-rw-r--r--net-wireless/gr-rds/Manifest4
-rw-r--r--net-wireless/gr-rds/gr-rds-0.0_p20200807.ebuild57
-rw-r--r--net-wireless/gr-rds/gr-rds-9999.ebuild21
3 files changed, 75 insertions, 7 deletions
diff --git a/net-wireless/gr-rds/Manifest b/net-wireless/gr-rds/Manifest
index b89f56c89ebb..254f1f68c0a9 100644
--- a/net-wireless/gr-rds/Manifest
+++ b/net-wireless/gr-rds/Manifest
@@ -1,2 +1,4 @@
-EBUILD gr-rds-9999.ebuild 1164 BLAKE2B 84b1858c4c791de99615269e68abb270137d376c597b51c45571cdab542314fc4ba38ac7323b657c44beae50fa6f1f24a20b239a6adf276aecf85fde76edb08a SHA512 a7e3c647c67c62c89b061c1d9c8ec44fa7f58e0f8d47b7bfc8ff8b1ba8198d2d7a0e662a40a50ba7ba928a14869cfcdaf7ed0234a9221d8f8321f26596f2116b
+DIST gr-rds-0.0_p20200807.tar.gz 210730 BLAKE2B be2ded79a744d97572f754458fbab6c4091eb9096fa01238e09cfb1703d50fc1f228000b973826456fe4fae7577ef4dcc871edb4f72bd4e2daacdf3d01330d03 SHA512 d04944db7c02d3a004beae5be96a42274dcc4503d94bd22b726c664fb49103c41479ce49f7b4f2e6fb86d7b6bdd01873375fd6a7a7cc4b04ec9bf033235743a2
+EBUILD gr-rds-0.0_p20200807.ebuild 1406 BLAKE2B 1b3ebaca58bbf8bfadcfa326ddc8b01f6947e06192d04ad66651169d20edab1229e70ea3b144f8b36a29ac2194a1bb75817683e32ad75434a11f45ceeb0e948b SHA512 e7c0334948256d669ff63c4bcae410c8f3b85cf2c26ce6e301504f02d9fec44dfe88d55bc3dfef9c29a1a68d722ff57c805cae9316630cfe0bf24a836e4d1c88
+EBUILD gr-rds-9999.ebuild 1406 BLAKE2B 1b3ebaca58bbf8bfadcfa326ddc8b01f6947e06192d04ad66651169d20edab1229e70ea3b144f8b36a29ac2194a1bb75817683e32ad75434a11f45ceeb0e948b SHA512 e7c0334948256d669ff63c4bcae410c8f3b85cf2c26ce6e301504f02d9fec44dfe88d55bc3dfef9c29a1a68d722ff57c805cae9316630cfe0bf24a836e4d1c88
MISC metadata.xml 317 BLAKE2B 38ab4417f4befdeb7d9912a3712a259653e223aac63528287493cde0094efbe7c985f1cd93e871a10fb1a99b8add72f20d6b31a93d06017171a85a276f4b9840 SHA512 a5cb2c2182d2c0a2afbb3ebc9ac175af13be57ea5ca28abd3cb59d25a562484f8dc01b08da9e0644929a6cbd63f2c850eb6169f574dbed838180e5a5e89ad510
diff --git a/net-wireless/gr-rds/gr-rds-0.0_p20200807.ebuild b/net-wireless/gr-rds/gr-rds-0.0_p20200807.ebuild
new file mode 100644
index 000000000000..e4b42b14c552
--- /dev/null
+++ b/net-wireless/gr-rds/gr-rds-0.0_p20200807.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bastibl/${PN}"
+ EGIT_BRANCH="maint-3.8"
+else
+ KEYWORDS="~amd64 ~x86"
+ COMMIT="ffbe3ea302c32a621f14329b7fcc09e868305e78"
+ SRC_URI="https://github.com/bastibl/gr-rds/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+fi
+inherit cmake python-single-r1
+
+DESCRIPTION="GNU Radio FM RDS Receiver"
+HOMEPAGE="https://github.com/bastibl/gr-rds"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
+ ')
+ =net-wireless/gnuradio-3.8*:0=[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/swig:0
+"
+#cppunit is listed in cmake, but only needed for tests and there are no tests
+# dev-util/cppunit"
+
+src_prepare() {
+ cmake_src_prepare
+ #although cppunit is not used, it fails if it isn't there, fix it
+ sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt || die
+ sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt || die
+ sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+}
diff --git a/net-wireless/gr-rds/gr-rds-9999.ebuild b/net-wireless/gr-rds/gr-rds-9999.ebuild
index 10e9f43865de..e4b42b14c552 100644
--- a/net-wireless/gr-rds/gr-rds-9999.ebuild
+++ b/net-wireless/gr-rds/gr-rds-9999.ebuild
@@ -3,15 +3,19 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{7,8} )
if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/bastibl/${PN}"
+ EGIT_BRANCH="maint-3.8"
else
- KEYWORDS=""
+ KEYWORDS="~amd64 ~x86"
+ COMMIT="ffbe3ea302c32a621f14329b7fcc09e868305e78"
+ SRC_URI="https://github.com/bastibl/gr-rds/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
fi
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
DESCRIPTION="GNU Radio FM RDS Receiver"
HOMEPAGE="https://github.com/bastibl/gr-rds"
@@ -25,7 +29,7 @@ RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
')
- >=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_SINGLE_USEDEP}]
+ =net-wireless/gnuradio-3.8*:0=[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -35,7 +39,7 @@ BDEPEND="
# dev-util/cppunit"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
#although cppunit is not used, it fails if it isn't there, fix it
sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt || die
sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt || die
@@ -44,5 +48,10 @@ src_prepare() {
src_configure() {
local mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
- cmake-utils_src_configure
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
}