summaryrefslogtreecommitdiff
path: root/net-wireless/gr-rds/gr-rds-0.0_p20250404.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-05 01:34:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-05 01:34:33 +0100
commit8bcae5a5a332db9dc28c20b7a5f28337d8335254 (patch)
treef5e955d5d9283743bda70a7d99a915db594b8a50 /net-wireless/gr-rds/gr-rds-0.0_p20250404.ebuild
parent74dcbf5a63cafe2678e2a397e1002dd691425200 (diff)
gentoo auto-resync : 05:04:2025 - 01:34:33HEADmaster
Diffstat (limited to 'net-wireless/gr-rds/gr-rds-0.0_p20250404.ebuild')
-rw-r--r--net-wireless/gr-rds/gr-rds-0.0_p20250404.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-wireless/gr-rds/gr-rds-0.0_p20250404.ebuild b/net-wireless/gr-rds/gr-rds-0.0_p20250404.ebuild
new file mode 100644
index 000000000000..6d91ed065435
--- /dev/null
+++ b/net-wireless/gr-rds/gr-rds-0.0_p20250404.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..13} )
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bastibl/${PN}"
+ EGIT_BRANCH="maint-3.10"
+else
+ KEYWORDS="~amd64 ~x86"
+ COMMIT="c1cba54dfac0661c088c44a120eeb38c300f6c01"
+ SRC_URI="https://github.com/bastibl/gr-rds/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+fi
+inherit cmake python-single-r1
+
+DESCRIPTION="GNU Radio FM RDS Receiver"
+HOMEPAGE="https://github.com/bastibl/gr-rds"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ ')
+ net-wireless/gnuradio:0=[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/swig:0
+"
+
+src_configure() {
+ local mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+}