summaryrefslogtreecommitdiff
path: root/net-wireless/gr-paint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /net-wireless/gr-paint
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'net-wireless/gr-paint')
-rw-r--r--net-wireless/gr-paint/Manifest6
-rw-r--r--net-wireless/gr-paint/gr-paint-0.0_p20200418.ebuild50
-rw-r--r--net-wireless/gr-paint/gr-paint-0.0_p20200517.ebuild59
-rw-r--r--net-wireless/gr-paint/gr-paint-9999.ebuild20
4 files changed, 130 insertions, 5 deletions
diff --git a/net-wireless/gr-paint/Manifest b/net-wireless/gr-paint/Manifest
index aa9f2d43f7b2..35b24c2c72ff 100644
--- a/net-wireless/gr-paint/Manifest
+++ b/net-wireless/gr-paint/Manifest
@@ -1,2 +1,6 @@
-EBUILD gr-paint-9999.ebuild 917 BLAKE2B 03c173165eedabead625e867712e792f48bd99b0fe7a39b0760bebc699458866e1ca7836a063c995a4e3556aff20ee74cf0c7e493a82692d5a3331dbc97561dd SHA512 128a122b5ebd7782a6cf693554730f53931dbc9d0288be192149a06300a56fefb01f4d46610df41c1bb2739ffec6a13a4e7eeaa1a675db22ac30b1c50efc9f16
+DIST gr-paint-0.0_p20200418.tar.gz 2129751 BLAKE2B 8767ff1ec791352dc701d0f7f68bbbd4088073379b4116ff2dbf2120b5e6e9b1a87ba0b0554a8489dc9b93cdb2ea5e3a8596b09482512fd1b10ea25d5b5c0fe9 SHA512 5f52e2baa090ed80d8a5b75846821b47163dcc055b94201fb59788bd85769a4e3f8c18654de45e68cb4088681b2db8b2327b5d14f176872bfe8bb2e01d7b6bfb
+DIST gr-paint-0.0_p20200517.tar.gz 1588114 BLAKE2B dffae6fdd6832ef7a39911b5f20d385e1691021e49659c36244c4aa1086fa74f4f59aceb4f208a24dd76854455183644c8f7db7e6ed0600664dc02f08e6682c5 SHA512 00b508b08baafd02e69197028a6408da81f5d1bf3dfe6d3229f248d60503ccec48f3fa0491bb785ed1ece40ea90d34544bc3b62e4506459488d56540b9d519c2
+EBUILD gr-paint-0.0_p20200418.ebuild 1098 BLAKE2B 1578dfee76801a9d4c8896794771cd913d25e6e700e89b3adfe4acfa72f4c16ea56827e61bb94949f1b50da968ffbe6df544a142d99c1b62b21e4a404ce1d90a SHA512 7fbd7d8090c1bf535702245e15eaaf0192dd9098657e4f918250d5f6957ddda066ea62a028a70df1e184161929802392fb3ea3a0913a3d99e7fcebac2e93287f
+EBUILD gr-paint-0.0_p20200517.ebuild 1239 BLAKE2B 064df4e230b2fba16170e10b2802d61d0bd72ebea664d8a8eb4d4fda7bf00362198f28dee6edca2eef9c6c5e2b3ed9dcfc6f2a3b2630ded73b7106899e28a860 SHA512 a4da87078dd0297af87953bac720f160d92f58e33dedc669e150a5c3acf6af87ab1cb0692a246123bf5bd06b9e726e3f1b8cea938bcb7e64008563a0bb900c23
+EBUILD gr-paint-9999.ebuild 1239 BLAKE2B 064df4e230b2fba16170e10b2802d61d0bd72ebea664d8a8eb4d4fda7bf00362198f28dee6edca2eef9c6c5e2b3ed9dcfc6f2a3b2630ded73b7106899e28a860 SHA512 a4da87078dd0297af87953bac720f160d92f58e33dedc669e150a5c3acf6af87ab1cb0692a246123bf5bd06b9e726e3f1b8cea938bcb7e64008563a0bb900c23
MISC metadata.xml 426 BLAKE2B c0655dfe4af8bc17dc267dcadf37625b86e4830bc565044fe43b0911d166a19d6ab56dc73d2ad37890e5d0f83ca52fd078034fd6675310447361cebd2730b704 SHA512 10082af73f8e1acbf8a97062d4802b8ae6a3f187034933c7a14fe932aac3e654b3dde399ec33b3cf174c528ac77d41f2ab75969e39cb6e2f9c343ce52f7d0b64
diff --git a/net-wireless/gr-paint/gr-paint-0.0_p20200418.ebuild b/net-wireless/gr-paint/gr-paint-0.0_p20200418.ebuild
new file mode 100644
index 000000000000..d8339979c4e2
--- /dev/null
+++ b/net-wireless/gr-paint/gr-paint-0.0_p20200418.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
+else
+ COMMIT="e36b2c638061d14f1b3c3bf3e889a8c99c273930"
+ SRC_URI="https://github.com/drmpeg/gr-paint/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64"
+fi
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Paints monochrome images into the waterfall of a receiver"
+HOMEPAGE="https://github.com/drmpeg/gr-paint"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
+ ')
+ =net-wireless/gnuradio-3.7*:=[${PYTHON_SINGLE_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ media-gfx/imagemagick
+"
+BDEPEND="
+ dev-lang/swig
+ dev-util/cppunit
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DOXYGEN=$(usex doc)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-wireless/gr-paint/gr-paint-0.0_p20200517.ebuild b/net-wireless/gr-paint/gr-paint-0.0_p20200517.ebuild
new file mode 100644
index 000000000000..132442bd9f33
--- /dev/null
+++ b/net-wireless/gr-paint/gr-paint-0.0_p20200517.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/drmpeg/gr-paint38.git"
+else
+ COMMIT="9cb4eabe3b570ccd1f53837681607d73501b5c1e"
+ SRC_URI="https://github.com/drmpeg/gr-paint38/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}38-${COMMIT}"
+ KEYWORDS="~amd64"
+fi
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Paints monochrome images into the waterfall of a receiver"
+HOMEPAGE="https://github.com/drmpeg/gr-paint"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+#< drmpeg> What tests?
+RESTRICT="test"
+
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
+ ')
+ dev-libs/gmp
+ sci-libs/volk
+ =net-wireless/gnuradio-3.8*:=[${PYTHON_SINGLE_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ media-gfx/imagemagick
+"
+BDEPEND="
+ dev-lang/swig
+ dev-util/cppunit
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DOXYGEN=$(usex doc)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_optimize
+}
diff --git a/net-wireless/gr-paint/gr-paint-9999.ebuild b/net-wireless/gr-paint/gr-paint-9999.ebuild
index 7f891f888a4e..132442bd9f33 100644
--- a/net-wireless/gr-paint/gr-paint-9999.ebuild
+++ b/net-wireless/gr-paint/gr-paint-9999.ebuild
@@ -3,13 +3,16 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6,7,8} )
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
+ EGIT_REPO_URI="https://github.com/drmpeg/gr-paint38.git"
else
- KEYWORDS=""
+ COMMIT="9cb4eabe3b570ccd1f53837681607d73501b5c1e"
+ SRC_URI="https://github.com/drmpeg/gr-paint38/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}38-${COMMIT}"
+ KEYWORDS="~amd64"
fi
inherit cmake-utils python-single-r1
@@ -21,12 +24,16 @@ SLOT="0"
IUSE="doc"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+#< drmpeg> What tests?
+RESTRICT="test"
DEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
')
- net-wireless/gnuradio:=[${PYTHON_SINGLE_USEDEP}]
+ dev-libs/gmp
+ sci-libs/volk
+ =net-wireless/gnuradio-3.8*:=[${PYTHON_SINGLE_USEDEP}]
"
RDEPEND="${DEPEND}
media-gfx/imagemagick
@@ -45,3 +52,8 @@ src_configure() {
)
cmake-utils_src_configure
}
+
+src_install() {
+ cmake-utils_src_install
+ python_optimize
+}