summaryrefslogtreecommitdiff
path: root/net-wireless/gr-foo/gr-foo-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /net-wireless/gr-foo/gr-foo-9999.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'net-wireless/gr-foo/gr-foo-9999.ebuild')
-rw-r--r--net-wireless/gr-foo/gr-foo-9999.ebuild39
1 files changed, 20 insertions, 19 deletions
diff --git a/net-wireless/gr-foo/gr-foo-9999.ebuild b/net-wireless/gr-foo/gr-foo-9999.ebuild
index 79a25cbde951..b54cc9402c9a 100644
--- a/net-wireless/gr-foo/gr-foo-9999.ebuild
+++ b/net-wireless/gr-foo/gr-foo-9999.ebuild
@@ -1,45 +1,46 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-single-r1
+EAPI=7
-DESCRIPTION="Some GNU Radio blocks that bastianbl uses"
-HOMEPAGE="https://github.com/rftap/gr-rftap"
+PYTHON_COMPAT=( python2_7 )
if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/bastibl/gr-foo.git"
+else
KEYWORDS=""
-#else
-# SRC_URI=""
-# KEYWORDS=""
fi
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Some GNU Radio blocks that bastianbl uses"
+HOMEPAGE="https://github.com/rftap/gr-rftap"
LICENSE="GPL-3"
SLOT="0/${PV}"
-RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
dev-libs/boost:=[${PYTHON_USEDEP}]
+ >=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
net-wireless/uhd:=[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}"
+"
DEPEND="${RDEPEND}
- dev-lang/swig:0"
+ dev-lang/swig:0
+"
#cppunit is listed in cmake, but only needed for tests and there are no tests
# dev-util/cppunit"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
src_prepare() {
+ cmake-utils_src_prepare
#although cppunit is not used, it fails if it isn't there, fix it
- sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt
- sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt
- sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt
+ sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt || die
+ sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt || die
+ sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt || die
}
src_configure() {
- mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
+ local mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
cmake-utils_src_configure
}