summaryrefslogtreecommitdiff
path: root/net-wireless/gqrx/gqrx-2.15.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-19 19:49:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-19 19:49:08 +0000
commitf287ecad888abdeb38e617d0485de282cd6819db (patch)
tree874d56500040734c4dbb9e437e0d5ed80a0a1886 /net-wireless/gqrx/gqrx-2.15.8.ebuild
parent844ae757702c53a56ee57056873a8204d256d47e (diff)
gentoo auto-resync : 19:12:2022 - 19:49:08
Diffstat (limited to 'net-wireless/gqrx/gqrx-2.15.8.ebuild')
-rw-r--r--net-wireless/gqrx/gqrx-2.15.8.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/net-wireless/gqrx/gqrx-2.15.8.ebuild b/net-wireless/gqrx/gqrx-2.15.8.ebuild
deleted file mode 100644
index ec213fc9569c..000000000000
--- a/net-wireless/gqrx/gqrx-2.15.8.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Software defined radio receiver powered by GNU Radio and Qt"
-HOMEPAGE="https://gqrx.dk/"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/csete/gqrx.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/csete/gqrx/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~riscv ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="gr-audio portaudio pulseaudio"
-REQUIRED_USE="^^ ( pulseaudio portaudio gr-audio )"
-
-DEPEND=">=net-wireless/gnuradio-3.7_rc:=[audio,analog,filter]
- >=net-wireless/gr-osmosdr-0.1.0:=
- dev-libs/boost:=
- dev-libs/log4cpp:=
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- sci-libs/volk:=
- pulseaudio? ( media-sound/pulseaudio:= )
- portaudio? ( media-libs/portaudio:= )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- if use pulseaudio; then
- LINUX_AUDIO_BACKEND=Pulseaudio
- elif use portaudio; then
- LINUX_AUDIO_BACKEND=Portaudio
- elif use gr-audio; then
- LINUX_AUDIO_BACKEND=Gr-audio
- fi
-
- local mycmakeargs=(
- "-DLINUX_AUDIO_BACKEND=${LINUX_AUDIO_BACKEND}"
- )
- cmake_src_configure
-}
-
-src_install() {
- dobin "${BUILD_DIR}"/src/gqrx
-}