summaryrefslogtreecommitdiff
path: root/net-wireless/gnome-bluetooth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /net-wireless/gnome-bluetooth
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'net-wireless/gnome-bluetooth')
-rw-r--r--net-wireless/gnome-bluetooth/Manifest2
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index 3fc4816d40f5..41b6a79b29bc 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1,4 +1,6 @@
AUX 61-gnome-bluetooth.rules 399 BLAKE2B ba3dd9fdc3834ce6a3460d8abff179d08c1258f7ba43e2350ed2c7e88aaf6fef4b06c51b6212650523c4de577cb3a85946bae9b955cf6c17a0c984431abd5d2b SHA512 74fd95e2afb3d3f13df72bb593ae6644a3a4975e43f5f50c622f14f756861596ef92aa331200d9fce6ff3976e8a1ed57e4053186b7a9716039ace971a6dfed0d
DIST gnome-bluetooth-3.20.1.tar.xz 615880 BLAKE2B 4b578bc7d1bf1d700f57117202e5f6461e1ace972f6922425a012eb1bcf96c7e511222a1dbd344469e0db96142d4da99face54e07d7359e28e20234d7766a70c SHA512 945dde99c6531e369702dea22e60f5b05759d751b16b091fc67c256e949cee8153f60ac7ad616c086366a0141b263b068fad28bab4b50b84356d59b4e464d88a
+DIST gnome-bluetooth-3.28.2.tar.xz 349456 BLAKE2B 24a8adbbd37a6a7338a10bb84fd113c3a65bb9c5ef277c9df082f10f52b9d9dc2bc3ff6182993fd85fb5f5f8269a965f0aba864f73ed8595a700a51e59242fc1 SHA512 03f66f8c5c195b10cf2c13dc93191b9f2f79adae099ddb8037ef1277731f37b8f0a42b603e8aacbe2fb108be6abf7a77a823d86d5fac62a42a53e3498d53d87e
EBUILD gnome-bluetooth-3.20.1.ebuild 1814 BLAKE2B 50ef84c4fb645b7ce89c58ad638e8673fd4c0751be865b230adc71889c035ad9a7e7ae27651a7ec26dd35ba0a75b82296b9be32db3f0d07c66c82748753b8f7c SHA512 e29abfa818fe10a19a6680210901a80cf92d0ae4c054ccdd1f2d0756265990368442647970234e3b869929ebe6052a62a3f17b3fe1fc7915a46f49f990cd9258
+EBUILD gnome-bluetooth-3.28.2.ebuild 1527 BLAKE2B 10e582ef510728c60a01cdf25f3832cf10664c5dbbe877ec6211dc1d07e6f4b0cdbb92af6a23b90cc7329b817884a7b9796b072a0bb7a6364616ffcf405785da SHA512 ce24b9403a4fa9ff3dba87c4c8717b9dbde8ffa315adb16d6eb29da6e58aa8e5510928e9fe549d5624b28e50f9f8a130efc45b122d221b6833a9614729a84ad9
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild
new file mode 100644
index 000000000000..3d98bbae7f45
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson udev user xdg
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="2/13" # subslot = libgnome-bluetooth soname version
+IUSE="gtk-doc +introspection"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+COMMON_DEPEND="
+ >=x11-libs/gtk+-3.12:3[introspection?]
+ media-libs/libcanberra[gtk3]
+ >=x11-libs/libnotify-0.7.0
+ virtual/libudev
+ >=dev-libs/glib-2.38:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/udev
+ >=net-wireless/bluez-5
+"
+DEPEND="${COMMON_DEPEND}
+ !net-wireless/bluez-gnome
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.9 )
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dicon_update=false
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ udev_dorules "${FILESDIR}"/61-${PN}.rules
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ if ! has_version sys-auth/consolekit[acl] && ! has_version sys-apps/systemd[acl] ; then
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}