summaryrefslogtreecommitdiff
path: root/net-wireless/gnome-bluetooth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-18 04:04:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-18 04:04:23 +0100
commit483d7c056fba15727fe24545f93627a1d1e1e2eb (patch)
tree80d144b60f8e1dc0d14c15cb3e5950da12c80074 /net-wireless/gnome-bluetooth
parent8796aaedb3257bbe4d80b0033408b2210b2259d6 (diff)
gentoo auto-resync : 18:10:2024 - 04:04:23
Diffstat (limited to 'net-wireless/gnome-bluetooth')
-rw-r--r--net-wireless/gnome-bluetooth/Manifest2
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-46.2.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index 96a8671f2d8e..c9ac07f86502 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1,5 +1,7 @@
DIST gnome-bluetooth-42.8.tar.xz 304908 BLAKE2B c487e0c278b316ecdcbdd39421389ce95024b06bf0e350d59dcac06d7a7e8b982da12b1088701e479d0b5c64b123899a5351a00c477208946bb1f44f3c8f30a6 SHA512 1c3d1db874b54ebae3cf59e526db8ff71131daea0c994abeefd95b51abf590bbba0baa8314ebbd1d3efe7973021327c7b8257163ed8f0567fe610b4e0c3dba88
DIST gnome-bluetooth-46.0.tar.xz 306148 BLAKE2B cc2ecb80b69bab74f878eb640f8b65505b0a5e12d4c661bd2491cbb70c4020db7f191e604805df788e3bd45c46de38c8069434a8615874006368e027dd5608b6 SHA512 48ed8aeaa59aba1997991a6ae6113a4d3c9e286aa4e34f3f2611e33582ffa53f9f3f5a81052320292ccb576904d0f3cf8074c0fff6d0f56995266188441e6f7b
+DIST gnome-bluetooth-46.2.tar.xz 306076 BLAKE2B 5696ec06cde737d833f02edd89f265172a3b8c4e3486cbb09b3e2e046ead445e6a3aac23a92223dada9f8a6cadd7969755bed661b3a95161fb3874f545172f38 SHA512 e0745ae67e5c30000ace8161c114caecc1f3b8e99b824b961ed695ba78a088247d797ad3cb284fc7cf91dd7c37b94c5ce0bdc4c1118b9bf059039effeb79313a
EBUILD gnome-bluetooth-42.8.ebuild 1875 BLAKE2B e03b1111eb8fad8b7b3db08b409aa3255de139bdbc970c1e0f50dde212538af66aad9f6c5a0fe42b6de9681070b72c9627a529bd8f32c50d4b7a19fd63575ca3 SHA512 c7cdd4def3ff2630b63af4502382fe164cfdfad9a18ebef6ded0339781712c57377dca2b4012c1465f8e37cbe761857245ecd85c0b421aa80a70b96430ac2779
EBUILD gnome-bluetooth-46.0.ebuild 1878 BLAKE2B d5e5e6a771fb2f80561b16282a8b980162b41d48777fc57321dc0940ab40ac661fd6897cc29ff16b0323dfc7fcade6e9bc4eac288c62c475a91ea32ea2133848 SHA512 8f31d6a9ee695192277c1b1a1d9d519378c5bc420788cf7a3b5be9698af8dc19ddbd36dee788c612ce3efbf89f4833aa4ad4c3d89e93d143bce6e821f80f8df3
+EBUILD gnome-bluetooth-46.2.ebuild 1879 BLAKE2B 8dcb33e8ec362417a6f816727c89609eba8a94ecd28a1c44986175541f621fb901f28e12dade4e81f01c6ee244fa49d53e8f479b0b647784d396290668a25fda SHA512 ad7cf7f4276c7b82cc96a68f08a3d15e5fd7e0034c7d8ab21f74922646949bde246dbff50de534707e26d2a0550798505d493e55a5557492c515934d483443d7
MISC metadata.xml 486 BLAKE2B f7080e058845d3931203b7912dfe5c31ecf36573241f33878cba7ca2ae240d62d067ea470845f6dfbb261631550916d430656040b8efcaec20123eb2be9ad5e4 SHA512 7b7f53d1648ad533caa02a18b859a3498e62a964f24a0e321f7661feecf95c02516f0ec65f23891a375a834d625dba7222c8e0919bc721558e747d582b6a4197
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-46.2.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-46.2.ebuild
new file mode 100644
index 000000000000..1d6cca82ab38
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-46.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-bluetooth"
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="3/13" # subslot = libgnome-bluetooth-3 soname version
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="gtk-doc +introspection sendto test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2
+ >=gui-libs/gtk-4.4:4[introspection?]
+ media-libs/gsound
+ >=gui-libs/libadwaita-1.1:1
+ >=x11-libs/libnotify-0.7.0
+ virtual/libudev:=
+ >=sys-power/upower-0.99.14:=
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ acct-group/plugdev
+ virtual/udev
+ >=net-wireless/bluez-5
+ sendto? ( !net-wireless/gnome-bluetooth:2 )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.9 )
+ virtual/pkgconfig
+ test? (
+ $(python_gen_any_dep '
+ >=dev-python/python-dbusmock-0.26.0[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ if use test; then
+ python_has_version ">=dev-python/python-dbusmock-0.26.0[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/dbus-python[${PYTHON_USEDEP}]"
+ fi
+}
+
+pkg_setup() {
+ # Check for python is unconditional
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use sendto)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # Workaround test failures caused by flatpak being installed that adds to XDG_DATA_DIRS
+ gnome2_environment_reset
+ export XDG_DATA_DIRS="${EPREFIX}"/usr/share
+
+ meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}