summaryrefslogtreecommitdiff
path: root/net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild')
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild
index 67dc1ab5ae02..9cbfd6f8efd0 100644
--- a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit gnome.org gnome2-utils meson udev xdg
+inherit gnome.org gnome2-utils meson udev user xdg
DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
@@ -21,7 +21,6 @@ COMMON_DEPEND="
introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
"
RDEPEND="${COMMON_DEPEND}
- acct-group/plugdev
virtual/udev
>=net-wireless/bluez-5
"
@@ -34,6 +33,10 @@ DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
"
+pkg_setup() {
+ enewgroup plugdev
+}
+
src_configure() {
local emesonargs=(
-Dicon_update=false
@@ -50,7 +53,7 @@ src_install() {
pkg_postinst() {
xdg_pkg_postinst
- if ! has_version 'sys-auth/consolekit[acl]' && ! has_version 'sys-apps/systemd[acl]' ; then
+ if ! has_version sys-auth/consolekit[acl] && ! has_version sys-apps/systemd[acl] ; then
elog "Don't forget to add yourself to the plugdev group "
elog "if you want to be able to control bluetooth transmitter."
fi