summaryrefslogtreecommitdiff
path: root/net-wireless/dump1090/dump1090-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /net-wireless/dump1090/dump1090-9999.ebuild
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'net-wireless/dump1090/dump1090-9999.ebuild')
-rw-r--r--net-wireless/dump1090/dump1090-9999.ebuild37
1 files changed, 22 insertions, 15 deletions
diff --git a/net-wireless/dump1090/dump1090-9999.ebuild b/net-wireless/dump1090/dump1090-9999.ebuild
index 556e4a14a698..e4ab4ba0cfe8 100644
--- a/net-wireless/dump1090/dump1090-9999.ebuild
+++ b/net-wireless/dump1090/dump1090-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,34 +9,42 @@ DESCRIPTION="simple Mode S decoder for RTLSDR devices"
#Original repo
#HOMEPAGE="https://github.com/antirez/dump1090"
#Repo that has actually been touched recenly
-HOMEPAGE="https://github.com/mutability/dump1090"
+#HOMEPAGE="https://github.com/mutability/dump1090"
+#And now we move to the next one in line
+HOMEPAGE="https://github.com/flightaware/dump1090"
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/mutability/${PN}.git"
+ EGIT_REPO_URI="https://github.com/flightaware/${PN}.git"
KEYWORDS=""
else
KEYWORDS="~amd64 ~x86"
- COMMIT="fb5942dba6505a21cbafc7905a5a7c513b214dc9"
- SRC_URI="https://github.com/mutability/dump1090/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${COMMIT}"
+ #COMMIT="fb5942dba6505a21cbafc7905a5a7c513b214dc9"
+ #SRC_URI="https://github.com/flightaware/dump1090/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ #S="${WORKDIR}/${PN}-${COMMIT}"
+ SRC_URI="https://github.com/flightaware/dump1090/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="BSD"
SLOT="0"
-IUSE=""
+IUSE="bladerf +rtlsdr"
-RDEPEND="net-wireless/rtl-sdr
+RDEPEND="bladerf? ( net-wireless/bladerf:= )
+ rtlsdr? ( net-wireless/rtl-sdr:= )
+ sys-libs/ncurses:=
virtual/libusb:1"
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ sed -i 's#-O2 -g -Wall -Werror -W##' Makefile
+ sed -i "s#-lncurses#$($(tc-getPKG_CONFIG) --libs ncurses)#" Makefile
+}
+
src_compile() {
emake CC="$(tc-getCC)" \
- UNAME="Linux" \
- DUMP1090_VERSION=${PV} \
- CFLAGS="$($(tc-getPKG_CONFIG) --cflags librtlsdr) ${CFLAGS}" \
- EXTRACFLAGS="-DHTMLPATH=\\\"/usr/share/dump1090/html\\\"" \
- LIBS="${LDFLAGS} $($(tc-getPKG_CONFIG) --libs librtlsdr) -lm -lpthread"
+ BLADERF=$(usex bladerf) \
+ RTLSDR=$(usex rtlsdr)
}
src_install() {
@@ -50,6 +58,5 @@ src_install() {
insinto /usr/share/${PN}/tools
doins -r tools/*
- newdoc debian/lighttpd/89-dump1090.conf lighttpd.conf
- newdoc debian/nginx/dump1090-mutability nginx.conf
+ newdoc debian/lighttpd/89-dump1090-fa.conf lighttpd.conf
}