summaryrefslogtreecommitdiff
path: root/net-wireless/dump1090/dump1090-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /net-wireless/dump1090/dump1090-9999.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'net-wireless/dump1090/dump1090-9999.ebuild')
-rw-r--r--net-wireless/dump1090/dump1090-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/net-wireless/dump1090/dump1090-9999.ebuild b/net-wireless/dump1090/dump1090-9999.ebuild
index be0c0e5e59cf..556e4a14a698 100644
--- a/net-wireless/dump1090/dump1090-9999.ebuild
+++ b/net-wireless/dump1090/dump1090-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,8 +17,9 @@ if [[ ${PV} == "9999" ]] ; then
KEYWORDS=""
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
- S="${WORKDIR}/${PN}"
+ COMMIT="fb5942dba6505a21cbafc7905a5a7c513b214dc9"
+ SRC_URI="https://github.com/mutability/dump1090/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
fi
LICENSE="BSD"
@@ -31,9 +32,10 @@ DEPEND="${RDEPEND}"
src_compile() {
emake CC="$(tc-getCC)" \
- UNAME="Linux"
+ UNAME="Linux" \
+ DUMP1090_VERSION=${PV} \
CFLAGS="$($(tc-getPKG_CONFIG) --cflags librtlsdr) ${CFLAGS}" \
- EXTRACFLAGS="-DHTMLPATH='/usr/share/dump1090/html'" \
+ EXTRACFLAGS="-DHTMLPATH=\\\"/usr/share/dump1090/html\\\"" \
LIBS="${LDFLAGS} $($(tc-getPKG_CONFIG) --libs librtlsdr) -lm -lpthread"
}
@@ -47,4 +49,7 @@ src_install() {
insinto /usr/share/${PN}/tools
doins -r tools/*
+
+ newdoc debian/lighttpd/89-dump1090.conf lighttpd.conf
+ newdoc debian/nginx/dump1090-mutability nginx.conf
}