summaryrefslogtreecommitdiff
path: root/net-wireless/bluez-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /net-wireless/bluez-tools
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'net-wireless/bluez-tools')
-rw-r--r--net-wireless/bluez-tools/Manifest3
-rw-r--r--net-wireless/bluez-tools/bluez-tools-0_p20161212.ebuild8
-rw-r--r--net-wireless/bluez-tools/files/bluez-tools-0_p20161212-gcc-10.patch29
3 files changed, 36 insertions, 4 deletions
diff --git a/net-wireless/bluez-tools/Manifest b/net-wireless/bluez-tools/Manifest
index e1d96636d934..b6f992818934 100644
--- a/net-wireless/bluez-tools/Manifest
+++ b/net-wireless/bluez-tools/Manifest
@@ -1,3 +1,4 @@
+AUX bluez-tools-0_p20161212-gcc-10.patch 2377 BLAKE2B 80aeefa71c6096f6c6e61e326f67b5f727c4d262ab9daa9c501069bbb2caf89c651850fcf3ab226a026a9b079135ac99dac3e5b9f3056556dba9fc549abe07a4 SHA512 2b91be22769660c57d50a1269e03c05e5489550f5dcdce5b29bada4074f6ffeeb9ee3074ce4935b6684ab37ec132f2dbf6ecba056d1e860eebc586f65573c208
DIST bluez-tools-0_p20161212.tar.gz 126613 BLAKE2B 474393862049a893280eeb0b7f466a1b1165a14d0ab33cbd9d3ca805a15eef237761aa3038423de85280bcaaf1385c3c7ab313d4cc3199f284aba86d8e5ed16e SHA512 ab5dd4a223348aab29fae22f552afae989b74d56c3fa46fd5587c100d63309649a10a87591bc040082545f45b7bb95360fcf6a48812012edbdb93570b0e166f7
-EBUILD bluez-tools-0_p20161212.ebuild 681 BLAKE2B c0d9628b1eb304c73a781fe981c07df5fc7ed58f3965b51665beaf2d921507b769a5fb05cc9854a45047d2cefe03e34de92e7cf50c55a273686defaaa5f37b1d SHA512 262701d6bcd971afc361d4dab7789897768dff8bf6a4b1c8fe39a04a540a465014d62aec980c42cee532f166878a22fb72912b3d68407652185727b0d98b224f
+EBUILD bluez-tools-0_p20161212.ebuild 707 BLAKE2B 22ab18908817f92803bb305857bab3a629a8250e022afb219571807d63aefdce8a788f576671e4b226b9d7ac14920e02abe401a22545f41e5413d103aa5af9fd SHA512 adfd3b1a3137020fc9f2f59e8164073ed68891472d9f881d0d4da736828c0ff57ccff44482ac7fe3a85c28374e4edb10383d339e88d43c6f1baeb8c3017abac5
MISC metadata.xml 575 BLAKE2B c0ef09b4f032bb7ae6cc0315789ff198eb81f91f3334140a23538e158278918f9b68e2f4a24e4d1f549ffeeecc525bbcca883ef891eb4d9171a4bcb6468c5ba9 SHA512 73b71c957ac6247f7f42644c3b7ae90bcd628eeb3eda210a2488dcafb88d99dc22c7b9426593d4e095d8a18931333434756cde9e6d987d948094acf1de418c7a
diff --git a/net-wireless/bluez-tools/bluez-tools-0_p20161212.ebuild b/net-wireless/bluez-tools/bluez-tools-0_p20161212.ebuild
index 4e777054b46e..87c36ffc4986 100644
--- a/net-wireless/bluez-tools/bluez-tools-0_p20161212.ebuild
+++ b/net-wireless/bluez-tools/bluez-tools-0_p20161212.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools eutils
+inherit autotools
DESCRIPTION="A set of tools to manage bluetooth devices for linux"
HOMEPAGE="https://github.com/khvzak/bluez-tools"
@@ -23,9 +23,11 @@ DEPEND="${RDEPEND}"
DOCS=( AUTHORS README )
+PATCHES=( "${FILESDIR}/${P}-gcc-10.patch" )
+
S="${WORKDIR}/${PN}-${COMMIT}"
src_prepare() {
+ default
eautoreconf
- default_src_prepare
}
diff --git a/net-wireless/bluez-tools/files/bluez-tools-0_p20161212-gcc-10.patch b/net-wireless/bluez-tools/files/bluez-tools-0_p20161212-gcc-10.patch
new file mode 100644
index 000000000000..6bfaa57fa19a
--- /dev/null
+++ b/net-wireless/bluez-tools/files/bluez-tools-0_p20161212-gcc-10.patch
@@ -0,0 +1,29 @@
+--- a/src/lib/agent-helper.c 2016-12-12 09:18:08.000000000 +0100
++++ b/src/lib/agent-helper.c 2020-01-30 22:23:27.555951515 +0100
+@@ -33,6 +33,8 @@
+
+ #include "agent-helper.h"
+
++gboolean agent_need_unregister;
++
+ static const gchar *_bt_agent_introspect_xml = "<node name=\"/org/blueztools\">\n\t<interface name=\"org.bluez.Agent1\">\n\t\t<method name=\"Release\">\n\t\t</method>\n\t\t<method name=\"RequestPinCode\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t\t<arg name=\"pincode\" direction=\"out\" type=\"s\"/>\n\t\t</method>\n\t\t<method name=\"DisplayPinCode\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t\t<arg name=\"pincode\" direction=\"in\" type=\"s\"/>\n\t\t</method>\n\t\t<method name=\"RequestPasskey\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t\t<arg name=\"passkey\" direction=\"out\" type=\"u\"/>\n\t\t</method>\n\t\t<method name=\"DisplayPasskey\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t\t<arg name=\"passkey\" direction=\"in\" type=\"u\"/>\n\t\t\t<arg name=\"entered\" direction=\"in\" type=\"q\"/>\n\t\t</method>\n\t\t<method name=\"RequestConfirmation\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t\t<arg name=\"passkey\" direction=\"in\" type=\"u\"/>\n\t\t</method>\n\t\t<method name=\"RequestAuthorization\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t</method>\n\t\t<method name=\"AuthorizeService\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t\t<arg name=\"uuid\" direction=\"in\" type=\"s\"/>\n\t\t</method>\n\t\t<method name=\"Cancel\">\n\t\t</method>\n\t</interface>\n</node>\n";
+ static guint _bt_agent_registration_id = 0;
+ static GHashTable *_pin_hash_table = NULL;
+--- a/src/lib/agent-helper.h 2016-12-12 09:18:08.000000000 +0100
++++ b/src/lib/agent-helper.h 2020-01-30 22:22:15.463751152 +0100
+@@ -35,7 +35,7 @@
+ #define AGENT_DBUS_INTERFACE "org.bluez.Agent1"
+ #define AGENT_PATH "/org/blueztools"
+
+-gboolean agent_need_unregister;
++extern gboolean agent_need_unregister;
+
+ void register_agent_callbacks(gboolean interactive_console, GHashTable *pin_dictonary, gpointer main_loop_object, GError **error);
+ void unregister_agent_callbacks(GError **error);
+@@ -44,4 +44,4 @@
+ }
+ #endif
+
+-#endif /* __AGENT_HELPER_H */
+\ Pas de fin de ligne à la fin du fichier
++#endif /* __AGENT_HELPER_H */