summaryrefslogtreecommitdiff
path: root/net-vpn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-27 15:57:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-27 15:57:47 +0100
commit3cafd803b6d89f6e823358a8d7f4a97e6d0629e1 (patch)
tree0cec79ef55ddf2fcd790270ae08081a3e158f6e8 /net-vpn
parentc70685892bc3f0b09aea1216ff278f6095f21281 (diff)
gentoo auto-resync : 27:10:2022 - 15:57:47
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/Manifest.gzbin7050 -> 7054 bytes
-rw-r--r--net-vpn/openfortivpn/Manifest2
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.18.0.ebuild40
3 files changed, 42 insertions, 0 deletions
diff --git a/net-vpn/Manifest.gz b/net-vpn/Manifest.gz
index 98b577df0c88..4a9a4dfc7569 100644
--- a/net-vpn/Manifest.gz
+++ b/net-vpn/Manifest.gz
Binary files differ
diff --git a/net-vpn/openfortivpn/Manifest b/net-vpn/openfortivpn/Manifest
index 01a8bdc14561..6ed85197a7d0 100644
--- a/net-vpn/openfortivpn/Manifest
+++ b/net-vpn/openfortivpn/Manifest
@@ -1,4 +1,6 @@
AUX systemd_substitute_bin_and_sysconfig_dirs.patch 490 BLAKE2B 071747a713f2b155959768d827b9b256842a6f587d23992a06be9ab7a701a6b4bc6b86b56fe0853f04ff81dc43f739d07f8cf60ba37c0bc9da2712a23d8a7f5a SHA512 511e8179a7f36a5e5bd2b4a07e62812aac8065b34b767992b823b5f4135addaf662f8a6061215898281dc128b8386b166f614307680416aaeba183db3ef5e2cb
DIST openfortivpn-1.17.1.tar.gz 167127 BLAKE2B 4b8f9fb82c4f7c8ffcecf9f14c576d73c999712b7b183b74f9d60d59c67017080a3d16d95ae74fa7f07188e9b28bdf8384f9b41ea7a4ce8e24813044d27216b9 SHA512 9d8be1043833bfa0eba6e4032c767946e88d079d329f8039964ea659c4dffb54a5a3b2a6431b66bd86590eaca8bf598a110c368714ecd7ea00312ee97f329085
+DIST openfortivpn-1.18.0.tar.gz 169141 BLAKE2B 28ac333bd1aa5b7be1e8cfb5a3dd968f2852c445d86050db2eb3161a6b7cd7f765607a3c8ec8bb8c65ba7d8340d8f526f08703ab6df9ab4f7a9f2d2666d767df SHA512 77a1c102e8bd6dfe5a86fe375449a3dd0253634d555dc084bd188a97d855afdd16f71b5b25fd6b737381c7da332228e22e3519d5a2b1d49099c56bc7c21e6088
EBUILD openfortivpn-1.17.1.ebuild 770 BLAKE2B bac4a88892ed1fff57c2ac8d4a92c9085a700cee8b237beb47c68b5bdaad4c9b5851ab54a089a45c8a21bc8566cf748402695f16773ee395413a7e02220894b8 SHA512 29200739dd930e2719bf61a346ca074923322f757786c5b9f078788c49d8f96a323d0dd046807dbf3ca4b0503cbe129e8e82ea09c5da9a13b2474fc0c30ebd1a
+EBUILD openfortivpn-1.18.0.ebuild 771 BLAKE2B bcad58650825c4d0c85bdc14aa88d3492aa97750520f44830a1f875bd5456296c61edf915054b32ecf879b8a14672b52fb439f0c7629a4672a3b677f4694eea4 SHA512 f383ce18b93b1580267fa2d9fabc2866b1d083f46015c96aa44dc0586d8dccfb6c9130bc6e68bacdc4645a9cd1d5c2b3acf8617094d1c0f6b7ae372df1f383d7
MISC metadata.xml 257 BLAKE2B f87135c9aedf98ef822404eb43e8214ed1e6d3cfc71db8d1aece9c3f8c30fda5b63f1de77b8d8d98b9b6b8d671e164199bcd810a34fe71939b836b164261ec2e SHA512 7719a7bd4abd3115b6279c4446e87c0c552f8b7dadd7429cbd8844ee2fe2509b712287f2d2e5926d6711dbe21efaebb289d187ebc297be770bb538f8bf799d31
diff --git a/net-vpn/openfortivpn/openfortivpn-1.18.0.ebuild b/net-vpn/openfortivpn/openfortivpn-1.18.0.ebuild
new file mode 100644
index 000000000000..f9a5078e5045
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.18.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/openssl:0=
+ net-dialup/ppp
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+PATCHES=(
+ "${FILESDIR}/systemd_substitute_bin_and_sysconfig_dirs.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}