summaryrefslogtreecommitdiff
path: root/net-vpn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-23 16:28:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-23 16:28:44 +0000
commit191f9d51469a31970723ed9eb0aee70ffe63094e (patch)
tree2502e164870943a5ca491043010657f1b83e4a27 /net-vpn
parent2114f9bc3d55c52f926a43f08765b350871e86f2 (diff)
gentoo auto-resync : 23:11:2023 - 16:28:43
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/Manifest.gzbin7243 -> 7583 bytes
-rw-r--r--net-vpn/eduvpn-client/Manifest5
-rw-r--r--net-vpn/eduvpn-client/eduvpn-client-4.1.3.ebuild38
-rw-r--r--net-vpn/eduvpn-client/eduvpn-client-4.1.99.0.ebuild38
-rw-r--r--net-vpn/eduvpn-client/metadata.xml24
-rw-r--r--net-vpn/eduvpn-common/Manifest7
-rw-r--r--net-vpn/eduvpn-common/eduvpn-common-1.1.2.ebuild74
-rw-r--r--net-vpn/eduvpn-common/eduvpn-common-1.1.99.0.ebuild73
-rw-r--r--net-vpn/eduvpn-common/metadata.xml28
9 files changed, 287 insertions, 0 deletions
diff --git a/net-vpn/Manifest.gz b/net-vpn/Manifest.gz
index 16c8caa3ec9a..984d4da97523 100644
--- a/net-vpn/Manifest.gz
+++ b/net-vpn/Manifest.gz
Binary files differ
diff --git a/net-vpn/eduvpn-client/Manifest b/net-vpn/eduvpn-client/Manifest
new file mode 100644
index 000000000000..abf31acc3960
--- /dev/null
+++ b/net-vpn/eduvpn-client/Manifest
@@ -0,0 +1,5 @@
+DIST eduvpn-client-4.1.3.gh.tar.gz 1163669 BLAKE2B 75184f21ecf24466e1496ced1295cb95a42e35f80d070a90dc9a2e2ed46272604703c0f56ebbc9a53b78f09a9ed685e64f578539502ef93b384d779d2a69af8c SHA512 2f180b238fc22dd19ae07a5e9e0518e51b302ecb1413a2d7f4fdb551f9cee5ef82ecf74498b63abb86745b8f9719a075b8d9758104cf124f88d65767944bc839
+DIST eduvpn-client-4.1.99.0.gh.tar.gz 1023712 BLAKE2B 5aabb6b1ade2b14299d107f4c666dc4d1f4858ac4f1cbdae0b1a0064fb943a685fe74181ac3301af4b3e1da8ec920c3cb8be9ac554387de018f9dafb3be1ec4a SHA512 29ee7feb7c7a5b23cb2d75f85b028c8830907b7b803ac8c03967e45bd8ed0bb4c1d0969bd543f9c369cbfc27b73c6c023a5d28df26681450a6242b83331f31f1
+EBUILD eduvpn-client-4.1.3.ebuild 939 BLAKE2B 6f2ae3b23aca95283783bc2926ffda375e7e9ab2b8e02f4228130d856e08ecf97b479c7385d24d22125176d10da7064adaee083be6ba6df7117e46bfaa1e0827 SHA512 3c6d66c216e4ea2aad4dd0b1cef359c263354aa6dddc3fc0001926672445c82a6bd169f92afd8adb4a664aae8dc131a2624b496aa684c8880d08c5c76d2267f8
+EBUILD eduvpn-client-4.1.99.0.ebuild 931 BLAKE2B 10010fa7247f6b64676a90189ede9f8d972c53caf7d08cf128cf7c90cf139841a596e4e6496adda19d7e3bad3d9a498de32a7ad15fe2f5436c46f32cf0debcfd SHA512 918998b8bd48a41562730a4f335ae2070b73e2351cad3bbfd05a01868420f3655419700057b9360be0640e01d22692c49a3ef204ab5bdfc892c0bbd46a642c27
+MISC metadata.xml 856 BLAKE2B 5ffc1c4ebc7429ef744cdcab2424fe68ada060c875c4b42666daff942bc3f9666a3ce4e981c90b4996df11f22b22e86b34df63da734d9bb64e7181a278110a8a SHA512 eab0db175a2e567c6b928b8b0ddd95b42bdf84a60f9297fb04666268539d5e288ab40d5ef38b36d1e6eced5f73e90f1fbda0c1978818952de2d34c75383d949a
diff --git a/net-vpn/eduvpn-client/eduvpn-client-4.1.3.ebuild b/net-vpn/eduvpn-client/eduvpn-client-4.1.3.ebuild
new file mode 100644
index 000000000000..58124218aa8c
--- /dev/null
+++ b/net-vpn/eduvpn-client/eduvpn-client-4.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/eduvpn/python-${PN}.git"
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="https://github.com/eduvpn/python-eduvpn-client/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/python-${P}"
+fi
+
+DESCRIPTION="Linux client and Python client API for eduVPN"
+HOMEPAGE="https://www.eduvpn.org/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+# Test suite involves adding NetworkManager configuration entries,
+# disable for now.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=net-vpn/eduvpn-common-1.1.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc
diff --git a/net-vpn/eduvpn-client/eduvpn-client-4.1.99.0.ebuild b/net-vpn/eduvpn-client/eduvpn-client-4.1.99.0.ebuild
new file mode 100644
index 000000000000..c5909a9568a4
--- /dev/null
+++ b/net-vpn/eduvpn-client/eduvpn-client-4.1.99.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="dev-python/mkdocs-material"
+DOCS_DIR="doc"
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 docs
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/eduvpn/python-${PN}.git"
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="https://github.com/eduvpn/python-eduvpn-client/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/python-${P}"
+fi
+
+DESCRIPTION="Linux client and Python client API for eduVPN"
+HOMEPAGE="https://www.eduvpn.org/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+# Test suite involves adding NetworkManager configuration entries,
+# disable for now.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=net-vpn/eduvpn-common-1.1.99.0[${PYTHON_USEDEP}]
+"
diff --git a/net-vpn/eduvpn-client/metadata.xml b/net-vpn/eduvpn-client/metadata.xml
new file mode 100644
index 000000000000..9eb729cd0bdd
--- /dev/null
+++ b/net-vpn/eduvpn-client/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Linux client for eduVPN
+
+ eduVPN is a frontend for either WireGuard or OpenVPN used widely at
+ european academic institutions. It features an easy to use VPN
+ configuration utility. Users just need to login occasionally with their
+ credentials issued by the institution to refresh their VPN
+ configuration.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">eduvpn/python-eduvpn-client</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-vpn/eduvpn-common/Manifest b/net-vpn/eduvpn-common/Manifest
new file mode 100644
index 000000000000..c7cbcfabcf0f
--- /dev/null
+++ b/net-vpn/eduvpn-common/Manifest
@@ -0,0 +1,7 @@
+DIST eduvpn-common-1.1.2-deps.tar.xz 7517364 BLAKE2B a6bd2c11d5056170d88ca8c35d054cd6d529462af6595fe31c535640cdf59a25ae4811c04bc738832fa4c28d2d3308ca5615170547b0c93edf7c4dd3f475978b SHA512 ce167298a76df4e22b23e3cfb7640f0272ea546dc5767f66baab900029c2a4850b383521d2f74ae0d77c53f47ba6eb51d80ab122362e4a7470e69a1fc3ac423f
+DIST eduvpn-common-1.1.2.gh.tar.gz 208300 BLAKE2B 8cb7e96d4a6a5032a1696aa57a6322f6a861aebba8b1f653d8be98e0044eacb3f23dc400ac9a8598dd83f30ca2140394ee2aa5733a27547f2a0378ad03ab422d SHA512 dbc290e48bc045456ad83e58e63c223cef5a7e1c7178537a44ed306a423276e644fb0f5607a7d8ddc5014b48ae11b57e365068d72887062277f8ab4f6f1ae660
+DIST eduvpn-common-1.1.99.0-deps.tar.xz 7581560 BLAKE2B faa8a91a3eaff9a49e2c39059687d3e2264dd2f0dfcd711b301776a90df34e5f85aa1f5b724771a7b0e6c5f2ee3ec62fe72ddfdb6c35cb4cd664069fe189f26c SHA512 05d8f9785d0b967f7e2d64ec735b8e1dbf251b895ea7b860471128cb13d66ae6ffbb8507d831d7e2a7a4d0cf585bdd3f4514f74ff14202fa604d7a36a2d7d540
+DIST eduvpn-common-1.1.99.0.gh.tar.gz 209972 BLAKE2B 3547be10495bed8dd7ac185bf711d32cfdedee44b4acd7e1ef3ac7d56a7d4ca335deea34d8c9744738ef104d2f1ffe30b4623b0abb3589d7d3380ba00d6cf09d SHA512 f4e2ef80a1c4736bbfc30d0c8d439f993ccde87c93daa5d1f7179494938513123afeb44f23bbc4287d0309da10d5a0aeddfb77eae51933bbe6e5c57d461b1d5f
+EBUILD eduvpn-common-1.1.2.ebuild 1421 BLAKE2B ef5534f84867f5ca4bb8cc85bc8c96268d5de0307ee520180f7654f3f74fab6e3a5619b4664bdadab67a5035e46f85c7a34c87b4a9167c6267cfca8cb18932a8 SHA512 573fe8c374474e58a3460d23aa3b5cbe6ffb7005ff3c530f46abc14650a4ba8f81ed34a338782e6675f279df222fdca2f0c21233895e605838b50219f61a6fb5
+EBUILD eduvpn-common-1.1.99.0.ebuild 1397 BLAKE2B 2d69521491fd271fd11417fb668b64ab6b741e6b8b4e44e46ea616f1e96cc12193e173d3e8fc694a9ca0226a58ddd223a8e763153dcbfdbedf8211f32922f010 SHA512 020db438e43d2b9b086beed2e972448bdf4f9a7d64bc5dee8366a52af4927a31dcdcbe3947a37e812c2ac4f3bf369dca0c8328f98ec4d44c3032849089e8de47
+MISC metadata.xml 999 BLAKE2B 258c481ed43a5d388677aa7a5029201a01364059045c4285ba8b8da49c8c105832d59aa357a3a2dcaa36474ee206c8c1e7855ad7d8b0e402722c6cb50d6175ef SHA512 73b524373d8268083d9e5c979a8dee7fb52e54fbe27cac54219bd14a3851755e2c5aced686ff08e24d5cf08330cc6485a97734aea89d2de2b45bbe682a1e2f8a
diff --git a/net-vpn/eduvpn-common/eduvpn-common-1.1.2.ebuild b/net-vpn/eduvpn-common/eduvpn-common-1.1.2.ebuild
new file mode 100644
index 000000000000..21519b3a39d0
--- /dev/null
+++ b/net-vpn/eduvpn-common/eduvpn-common-1.1.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+inherit distutils-r1 go-module linux-info
+
+DESCRIPTION="Linux client and Python client API for eduVPN"
+HOMEPAGE="https://www.eduvpn.org/"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/eduvpn/eduvpn-common.git"
+else
+ SRC_URI="
+ https://github.com/eduvpn/eduvpn-common/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://www-user.tu-chemnitz.de/~hamari/eduvpn/${P}-deps.tar.xz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="openvpn wireguard"
+RESTRICT="test"
+
+RDEPEND="
+ openvpn? ( net-vpn/openvpn )
+"
+
+wrap_python() {
+ local phase=$1
+ shift
+
+ pushd wrappers/python >/dev/null || die
+ distutils-r1_${phase} "$@"
+ popd >/dev/null || die
+}
+
+pkg_pretend() {
+ if use wireguard; then
+ CONFIG_CHECK="~WIREGUARD"
+ WARNING_WIREGUARD="You must enable WIREGUARD to use wireguard."
+ check_extra_config
+ fi
+}
+
+src_prepare() {
+ default
+
+ mkdir -p wrappers/python/eduvpn_common/lib || die
+
+ wrap_python ${FUNCNAME}
+}
+
+src_compile() {
+ default
+ wrap_python ${FUNCNAME}
+}
+
+src_test() {
+ default
+ wrap_python ${FUNCNAME}
+}
+
+src_install() {
+ # The shared library is installed within the python package. There is no
+ # need to call the default routine.
+ wrap_python ${FUNCNAME}
+}
diff --git a/net-vpn/eduvpn-common/eduvpn-common-1.1.99.0.ebuild b/net-vpn/eduvpn-common/eduvpn-common-1.1.99.0.ebuild
new file mode 100644
index 000000000000..3545e366925a
--- /dev/null
+++ b/net-vpn/eduvpn-common/eduvpn-common-1.1.99.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+inherit distutils-r1 go-module linux-info
+
+DESCRIPTION="Linux client and Python client API for eduVPN"
+HOMEPAGE="https://www.eduvpn.org/"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/eduvpn/eduvpn-common.git"
+else
+ SRC_URI="
+ https://github.com/eduvpn/eduvpn-common/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://www-user.tu-chemnitz.de/~hamari/eduvpn/${P}-deps.tar.xz
+ "
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="openvpn wireguard"
+RESTRICT="test"
+
+RDEPEND="
+ openvpn? ( net-vpn/openvpn )
+"
+
+wrap_python() {
+ local phase=$1
+ shift
+
+ pushd wrappers/python >/dev/null || die
+ distutils-r1_${phase} "$@"
+ popd >/dev/null || die
+}
+
+pkg_pretend() {
+ if use wireguard; then
+ CONFIG_CHECK="~WIREGUARD"
+ WARNING_WIREGUARD="You must enable WIREGUARD to use wireguard."
+ check_extra_config
+ fi
+}
+
+src_prepare() {
+ default
+
+ mkdir -p wrappers/python/eduvpn_common/lib || die
+
+ wrap_python ${FUNCNAME}
+}
+
+src_compile() {
+ default
+ wrap_python ${FUNCNAME}
+}
+
+src_test() {
+ default
+ wrap_python ${FUNCNAME}
+}
+
+src_install() {
+ # The shared library is installed within the python package. There is no
+ # need to call the default routine.
+ wrap_python ${FUNCNAME}
+}
diff --git a/net-vpn/eduvpn-common/metadata.xml b/net-vpn/eduvpn-common/metadata.xml
new file mode 100644
index 000000000000..26731a22c57e
--- /dev/null
+++ b/net-vpn/eduvpn-common/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Code to be shared between eduVPN clients
+
+ eduVPN is a frontend for either WireGuard or OpenVPN used widely at
+ european academic institutions. It features an easy to use VPN
+ configuration utility. Users just need to login occasionally with their
+ credentials issued by the institution to refresh their VPN
+ configuration.
+ </longdescription>
+ <use>
+ <flag name="openvpn">enable support for OpenVPN</flag>
+ <flag name="wireguard">enable support for WireGuard</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">eduvpn/eduvpn-common</remote-id>
+ </upstream>
+</pkgmetadata>