summaryrefslogtreecommitdiff
path: root/net-vpn/protonvpn-cli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /net-vpn/protonvpn-cli
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'net-vpn/protonvpn-cli')
-rw-r--r--net-vpn/protonvpn-cli/Manifest3
-rw-r--r--net-vpn/protonvpn-cli/metadata.xml11
-rw-r--r--net-vpn/protonvpn-cli/protonvpn-cli-2.2.0.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/net-vpn/protonvpn-cli/Manifest b/net-vpn/protonvpn-cli/Manifest
new file mode 100644
index 000000000000..e0670489c15a
--- /dev/null
+++ b/net-vpn/protonvpn-cli/Manifest
@@ -0,0 +1,3 @@
+DIST protonvpn-cli-2.2.0.tar.gz 42694 BLAKE2B fb32401580090401cd6c2c3c692313992c62ed24b383c88e006f69f99a6b96e7081d6927778817245c604cb978b2157e88288ab5236211297258b02dc63a197a SHA512 9ff188ddba679187cf69ab2a18023bd030ff8e734cc5f8516cd93490e601cf21482573b2ab0b7586e371c1f83955db1ad66fa98203f3abdf848a0755484c079e
+EBUILD protonvpn-cli-2.2.0.ebuild 717 BLAKE2B f271545fd78cb810a52c500c852fab8965f2c559d6243f2bc4ee21d513be6c63fc0baecf0132d859c079d78f93ab803e3ff952fbf2bb211e998025095b8bc339 SHA512 6e3b3c46cf78deb803a7219fc64e1d07138fec166b27df5f3dd533f4b2be1ad4945c1620bd580e75ffec19d40bc775b5b74b9f4e3b24398085da0866eee970a0
+MISC metadata.xml 336 BLAKE2B bc23b58762a67e72e5a2080f20154f6e6b12903b856cfcc3cdc105246b66c41fc39dcec3d97267724f494cef84b7ae7ec446f2a4b8ee9ee0283abf5d7ceaf826 SHA512 ada3c3038cb84a38a4e2a0ae9371a19242f8d250297855769bbe1eeea05b5000415b946b963fd0fa8a12524caee5fe334ede05dd88ee024708755b5401dd5a16
diff --git a/net-vpn/protonvpn-cli/metadata.xml b/net-vpn/protonvpn-cli/metadata.xml
new file mode 100644
index 000000000000..6ad1720cb5cd
--- /dev/null
+++ b/net-vpn/protonvpn-cli/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ilmostro7@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-vpn/protonvpn-cli/protonvpn-cli-2.2.0.ebuild b/net-vpn/protonvpn-cli/protonvpn-cli-2.2.0.ebuild
new file mode 100644
index 000000000000..d1f445f5b0e2
--- /dev/null
+++ b/net-vpn/protonvpn-cli/protonvpn-cli-2.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A VPN command-line tool from protonvpn - python rewrite"
+HOMEPAGE="https://protonvpn.com https://github.com/ProtonVPN/protonvpn-cli-ng"
+SRC_URI="https://github.com/ProtonVPN/${PN}-ng/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pythondialog:0[${PYTHON_USEDEP}]
+ net-vpn/openvpn"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-ng-${PV}"
+
+DOCS=( CHANGELOG.md README.md USAGE.md )