summaryrefslogtreecommitdiff
path: root/net-vpn/ocserv/ocserv-1.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-05 17:31:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-05 17:31:39 +0100
commit8b5a92f1e1eccecfa61db8a4744e1b9d449522b6 (patch)
tree427b7c54371dc36d63e7fa3590ec577ad265eac9 /net-vpn/ocserv/ocserv-1.1.3.ebuild
parent3023707d355581e5dc6945aa9c8f4d59e508a8b5 (diff)
gentoo auto-resync : 05:05:2023 - 17:31:39
Diffstat (limited to 'net-vpn/ocserv/ocserv-1.1.3.ebuild')
-rw-r--r--net-vpn/ocserv/ocserv-1.1.3.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/net-vpn/ocserv/ocserv-1.1.3.ebuild b/net-vpn/ocserv/ocserv-1.1.3.ebuild
deleted file mode 100644
index 459da4219219..000000000000
--- a/net-vpn/ocserv/ocserv-1.1.3.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd
-
-DESCRIPTION="Openconnect SSL VPN server"
-HOMEPAGE="https://ocserv.gitlab.io/www/index.html"
-SRC_URI="ftp://ftp.infradead.org/pub/ocserv/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="geoip kerberos +lz4 otp pam radius +seccomp systemd tcpd test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- net-libs/gnutls[tools(+)]
- net-libs/socket_wrapper
- net-vpn/openconnect
- sys-libs/nss_wrapper
- sys-libs/uid_wrapper
- )
-"
-DEPEND="
- dev-libs/libnl:3=
- dev-libs/libev:0=
- >=dev-libs/nettle-2.7:0=
- dev-libs/pcl:0=
- dev-libs/protobuf-c:0=
- >=net-libs/gnutls-3.3.0:0=
- net-libs/http-parser:0=
- sys-libs/readline:0=
- sys-libs/talloc:0=
- virtual/libcrypt:=
- geoip? ( dev-libs/geoip:0= )
- kerberos? ( virtual/krb5 )
- lz4? ( app-arch/lz4:0= )
- otp? ( sys-auth/oath-toolkit:0= )
- pam? ( sys-libs/pam:0= )
- radius? ( net-dialup/freeradius-client:0= )
- seccomp? ( sys-libs/libseccomp:0= )
- systemd? ( sys-apps/systemd:0= )
- tcpd? ( sys-apps/tcp-wrappers:0= )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local myconf=(
- --without-root-tests
- --without-nuttcp-tests
-
- $(use_enable seccomp)
- $(use_enable systemd)
-
- $(use_with geoip)
- $(use_with kerberos gssapi)
- $(use_with lz4)
- $(use_with otp liboath)
- $(use_with radius)
- $(use_with tcpd libwrap)
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
-
- dodoc doc/sample.{config,passwd}
- use otp && dodoc doc/sample.otp
-
- doinitd "${FILESDIR}"/ocserv
-
- if use systemd; then
- systemd_dounit doc/systemd/socket-activated/ocserv.{service,socket}
- else
- systemd_dounit doc/systemd/standalone/ocserv.service
- fi
-}